GE Z-Wave On/OFF Switch settings for Indicator LED? (Asked Before)

This will do what you want


It has an on screen button to toggle the indicator light

1 Like

Do you mean in the config, if so they all have that button. I will try it just to test but it like it to run local…

Not in the config. On screen as go to you’re “Thing” in the mobile app. You’ll see.
Also, it will not run local, but through the cloud.
Only some smartthings devices run local, not custom.

When you first install the generic device handler, light defaults to always OFF. You can modify behavior in IDE.
Smartthings has been having issues lately and changes from mobile app do not always propagate.

I have a good portion of my devices running local, but one switch won’t matter if it is in the cloud. I will try that Device Type. Thanks.

You might try excluding, resetting and then adding the switch again to your ST. And never change network node for any device.

Tried that.

This works really well. Do you have a similar DTH for the dimmer?

Thanks.

Is this what you need?

I hope this is a good place to ask this, since it is sort of related. I have the ZWave switches and the default is to have the LED on when the load is off. A mistake in my opinion, but it’s programmable, or so I’ve read. Jasco states that parameter 3 can be set to 0, 1, or 2, depending on the characteristic desired. Since I am not a coder, my question is, What combination of controller and application has the capability to modify parameter 3? I have a Wink hub 2 but that doesn’t appear to be sophisticated enough for this task.

@joelw135 it’s possible the LED got accidentally disabled completely. Have you tried the procedure to re-enable it at the physically switch itself?

Press ON three times in quick succession (unfortunately I’ve not found just how quick)
Press OFF once.

Unfortunately the ‘never lit’ LED setting is broken on the 12730 fan controller but that’s another story.

2 Likes

Is that on the switch, or in the DTH?

THANK YOU!!! I’ve had one out of over two dozen of these switches that the LED NEVER worked! Drove me crazy for the past year. The “press on 3 times real quick then off” trick worked! When nothing else would. Not sure how it got disabled on the first place!

3 Likes

At one point my son thought the dimming on the switch was done via pressing quickly/repeatedly rather than just press and hold…so maybe someone in your family hit the magic combo of presses when trying to dim the light and then giving up and hitting off.

But good news to have it fixed, I’m sure. :slight_smile:

The physical switch itself.

Haven’t gotten it to work, but will try again.

it took me a couple tries to get it, the ‘press on three times’ has to be done pretty quick!

I had one GE switch do this. Jasco replaced it under warranty. They sent a Plus in it’s place not that I needed a Plus version.

Updating… After a LOT of searching, and while using only the ‘new’ Samsung Smartthings app, here’s how to control the blue LED on a GE zwave+ paddle switch, model 14291.
First off, make sure the light even works. After adding it to the hub, check to see if the light comes on at all. If it does not come on in the ON or OFF position, press the top paddle SUPER fast 3 times, then the bottom paddle once, in very quick succession, all 4 strokes.
Verify the light comes on in either position.
Now, the options.
Go to your smartthings webpage, (NOT the app) and go to devices tab, and click the device, IE, Light switch-whatever-you-named-it.
Above Preferences, it should say Current States. Check that there is an entry titled IndicatorStatus, should say when on or when off. This is when the led light will be ON.
scroll down to -Preferences-, and it should say (edit) beside that. Beyond that, to the right, it should say enum and then Value. Again, this is what status the switch is turned to when the LED is ON.
Click edit.
The page changes, and you’ll see:
LED Indicator - Turn LED indicator… (here, in this box, simply enter on or off. no caps, etc.
(Off=LED off when switch is ON, LED ON when switch is OFF. ** On=LED on when switch is ON)
Then hit Save.
Go back to the devices page, give it a minute to refresh, and it should be accurate, as well as the LED turning on when you want it. These are the only 2 statuses (LED on or off) that I messed with, and after piecing together several pages on info.

Hope this helps someone with this switch, the 14291, and it’s possible it works with others, YMMV.

Similar issue adding several GE / Jasco zwave outlets (TamperProof) all but one added with correct state on light. Careful read of the instructions, included in the box, in the bottom right of step/box #3 says “quickly press the ON/OFF button 10 times, the light will invert if done correctly” … i did this and it returned to the desired state (ie light on when power on)