GE Z-Wave Dimmer. Stopped Working Manually


(gfbuyer) #1

I had a Z-Wave Dimmer installed 3 days ago. The device paired immediately and worked well from the app and also manually. Yesterday the switch stopped working manually. The blue light is on and is still paired to the app. I can turn it on and off from the app but it is not powering the lights. When I press the paddles on the switch the blue light comes on and off as expected but again no lights. Is this a dead switch or maybe the wiring came loose ? I have a bunch of these around and have not had any issues with any others.


(Michael) #2

I would recommend contacting GE/Jasco. Their support can help you identify its it’s a faulty switch, which it does sound to be.


(gfbuyer) #3

Thanks. Great suggestion. I have opened a case with them. They want to lay it off on the bulb going bad. However the switch controls 4 overhead lights so the chance of all 4 going out at the same time seems pretty low to me.

The electrician who put it in is going to stop by and verify the wiring today. It seems that either we ended up with a loose wire or the switch went bad.


(Jimmy) #4

Sounds like the load wire came loose


(gfbuyer) #5

Turns out it was a wiring error. The electrician has put a bunch of mine in previously. I have had him do the 4 ways at my home because they all needed some adjustment of the wiring. On this one something just got hosed up. The curious thing is that everything worked fine for the first 2 days and then stopped.

Thanks to all for the input !