GE Link Lights and ST integration


(Brian) #1

I have read the multiple threads about the compatibility of the GE Link lights from Home Depot with ST hub. I have done the following:

Made sure my Zigbee is at 1.5.4 firmware
Turned the bulb of and on for 3 seconds each and saw it fade out then in to reset it
Went to my application to see if the bulb shows up (which it doesn’t)
Made sure the hub and bulb are right next to each other.

I am still not able to see this bulb (without a “hue” hub to assist which I don’t have)

Any suggestions?


(Greg) #2

I believe the off/on 3x is only to re pair it. I didn’t have to do that to set mine up. Perhaps your zigbee network doesn’t reach the bulb? Try moving it closer to the hub or a repeater.


(Viren Patel) #3

During pairing with my hub which was about 25 feet away it took a good 20 mins. I would definitely move the router closer. The bulbs will blink when they connect. I also turned them on and off repeatedly but that did nothing. Just leave them on and bring the hub closer if you can. Also make sure your phone is searching for a new device.


(Cass) #4

I had a similar issue and I ended up unscrewing the bulb then screwing it back in while the switch was turned on and it worked. I thought turning on and off would work but it did not.


(Scott G) #5

I now have 15 of these bulbs connected in my basement. It was a tough process to get them all linked appropriately, but they seem to work ok now. I had no trouble with initial pairing for most bulbs, but I used a lamp about 5-7’ from my hub as the main pairing location.

For a while it seemed like I could only get 5 to work at any given time, but these bulbs seem to need patience. The on/off trick is used to reset the bulb, and I needed to do it a few times when a bulb stopped syncing with my hub.

I would recommend linking one bulb at a time, then placing the bulb in its permanent place and turn them all on and leave them on for a few minutes to allow the Zigbee network to work out its routing before connecting the next bulb. (I also am using the Wackware GE Link Bulb deviceType which adds status updating).


(Scott G) #7

I was mistaken, he added the SetLevel event, so it can be subscribed to. Code is here:

Seemed to improve the connection to my bulbs. Big thanks to @wackware for putting it together.


#8

Thanks! Just as you posted this I found it too.


(Brian) #9

Thanks for the replies, I would like to know, since I use the hub out of the box and the “code” you posted is an apparent fix, how do you introduce this “code” to your SmartThings Hub?


#10

@brian_rhoden, the code isn’t the fix, but more of an improvement. It enables status updating.

Based on your original post, you haven’t included the bulb correctly. Did you go into the phone app and start the process to Connect New Device? Once you do that all you need to do is turn on the bulb and wait for it to be discovered.

https://support.smartthings.com/hc/en-us/articles/202824790-Connecting-and-configuring-new-devices

Code for custom device types and smartapps is something you do using the IDE (ST developer tool). I suggest you look through other threads, support links, and tutorials on how to get started and in using the IDE.


(Brian) #11

Yea, I read the developer section on how to publish your own device type / button. You are correct however, I have yet to see the bulb on my router’s “Wireless LAN” section (I see my LIFX bulbs just fine) and I have left my phone on for an hour and still have yet to have it be detected.

The ST hub is 2 feet away from the lamp, the router is about 5 feet away, but no communication has been established.