GE Link bulbs - I need a beginner How-To

Also, try physically moving the floor lamp closer to the hub, or as close as possible to the table lamp to try and eliminate range as an issue.

I know you said they were in the same room but that doesn’t necessarily mean anything. The signal stops eventually and it could be stopping somewhere between the two, how big of room, etc.

I typically pair the bulb on a portable lamp by the hub then install it in the final location

For those of you having issues with GE Link bulbs acting up, i may have just found a quick fix.

I was haivng trouble with two of mine and was doing everything not to have to remove and re-add them. I was doing every trci in the book. Power cycling things that didn’t even make sense to power cycle lol. Then i noticed that the icon for the device changed back to default.

I thought hmmmm thats weird. Thinking it could be a DB thing that could cause this i renamed the bulb. Boom it worked again immediately. Thought this was too good to be true… so i tried it on the next bulb… boom worked immediately.

Looks like some sort of DB issue im thinking. Give this a try next time. Hopefully it works as well for you as it did me!

For those considering these bulbs who use the Harmony Hub and Remote, they do not play nicely with each other. I had one of my Home Activity buttons to turn on a GE ZWave Appliance/Lighting Module and it worked great. I swapped it out with a GE Link Bulb and when I press the button on my remote to turn on the light, nothing happens. It did turn on when I pressed on in the Harmony app, which makes it stranger.

I have had great luck with the GE Link light bulbs. Although I would like some kind of indicator that it is on, it has always shown accurately in the ST app when the light is on or off. The only time it is inaccurate, is when the actual light switch (standard paddle switch) is off. The switch can be off, but the ST app shows the bulb is on.

I haven’t deployed Zwave dimmer switches because I like the thought of being able to group and automate the bulbs rather than re-install all my switches.

My challenge isn’t either approach but rather my little minions (young children) who go around turning on and off the switches. For this scenario, the Zwave replacement switch seems like a better alternative, since I can switch it back on via the ST app, rather than the bulb itself.

I would love to hear your experience, and approach from those who experience their children flipping on and off switches. I know there are physical switch covers that I can install, but I can’t stand the look.

Has anyone removed all their switches and completely automated their house with the use of motion detectors and bulbs (Hue/Link/Connected)? I can see this happening in the next 5 years, as long as there is some sort of remote switch, via the phone, Aeon remote, or Hub Tap

I see @johnconstantelo has addressed the “ON” state issue in the following thread. Thank you!

2 Likes

I’m having a devil of a time with this GE Link bulb.

  1. bought just one bulb to test. It’s in a floor lamp right next to ST hub.

  2. got ST support to update my zigbee firmware to 1.5.4 and double checked it updated.

  3. Add Things sees the GE Link bulb, etc. Once added, Things tile lets me manually control on/off/dim features.

  4. did a simple proximity sensor on and off test. Worked great. All seemed to be working great!

So I leave house, come back and…my lamp is still on.

ST app isn’t controlling it any longer. On/Off/Dim…no response.

House was empty so nobody manually switched it off.

I remove everything, reset GE Link bulb, reboot ST Hub, re-add the bulb…but now ST app can’t control bulb at all. It sees it, but can’t control it.

I can’t figure out why it worked great earlier out of the box and now…just a brain dead light bulb.

What else can I try? Defective bulb?

it happened twice to me. Try resetting the bulb by turning it off and on several times with a second pause in between. It will dim then blink and you should be able to re pair it.

Thanks, removed the bulb from ST app, reset it, re-added it…I’ve now done this four times. Each time, the ST app will go all the way through the process as if it see’s the device just fine…even auto names it for me as GE Link bulb.

But I can no longer control it with the ST app at all. If I pull up the web based console, I can see that its registered the device but it always says “Inactive” in status (all other devices say “Active”).

Other things I’ve reset…

-ST Hub
-My cable modem
-My Netgear WAP/Router
-All other ST lighting devices (all others are just power switches…this is my only smart bulb)

I am really stumped. ST ‘sees’ the bulb, it even sets it up for me. But once setup, it thereafter fails to acknowledge its existence.

A couple of tips. My guess is you just got a bad bulb, so I’d exchange it and try again. I have 16 of these now, and I’ve had to exchange 2 that would not pair or work right. The replacements worked with no issues.

Tips:

  1. If you can, create some distance between your hub and router during the pair process. For whatever reason, these bulbs are prone to interference during the pair process.
  2. Try the device type that @Lupismaximus linked to. Around post 50 of that thread has instructions if you’re new to the ST and the IDE.

Hopefully that helps!

ST has been a complete disaster for me. I have 17 bulbs total, 3 of which are Hue, the rest is GE link. They worked ok through the Hue bridge. So I connected the Hue bridge to my ST hub. Most lights worked, but I lost 2 living room GE Links. Also, on/off status only worked for the hue lights, not the GE links. So I thought, OK, time to consolidate. I reseted the Hue Bridge. Lights off. ST app on, find new devices and turn living room lights on. 2 of the GE Link lights were found immediately and work great. On/Off works great, dimming is responsive. However, ST now doesn’t find any other light. Even both the GE and Hue lights in the same room are not found.

I do not have a hue bridge. My bulbs are linked directly to smart things and use the community device type.

If you let smart things run the bulbs directly what happens?

Well, that is exactly what I am trying to do. These were the steps

  1. removed all the hue-bridge associated bulbs from ST
  2. I reset the hue bridge, unplugged it and left it unplugged.
  3. Even with all the events and apps removed, the hue bridge cannot be uninstalled in ST. I think the hue connect app and the bridge and gridlocking each other, but anyway, that shouldn’t matter.
  4. Switched off all bulbs.
  5. Add new device on ST, triggering the search process
  6. Switched lights on section by section. So 4 lights were switched on in the living room.
  7. 2 of the 4 lights appeared and are not working great, connected straight to ST.
  8. Connecting any other bulb to ST fails.

This requires making a major decision. Once you pair the Hue bulbs directly to ST they can no longer (ever?) be controlled by the bridge. And there is a current known problem with uninstalling a hue bridge.

See the Hues discussions for more details.

Then talk to support@smartthings.com There are some changes in flux with Hue right now.

I would just like the GE bulbs connected to ST, but the hue bulbs to hue. It just seems like the zigbee part of ST isn’t well-designed.

Is there a way to connect wink to ST? Wink is much more reliable, but it lacks some functionality.

I think the ZHA (zigbee home automation) part isn’t bad, but the ZLL (zigbee light link) was added after Hue became popular and does still need a lot of work.

They still don’t have official support for all ZLL device types.

Which reminds me–definitely contact support to make sure you have the most current zigbee firmware, 1.5.4 . It hasn’t been pushed out to all ST hubs, but you need it for the GE bulbs.

It says

zigbeeChannel: 20
zigbeeFirmware: 1.5.4
zigbeeNodeID: 0000
zigbeePanID: 11DE
zigbeePowerLevel: 254

Also, it is odd that 2 GE links work just perfectly, but nothing else works.

Ok, that’s the right firmware. I would definitely contact support, there have been multiple changes to Hue processing in the last few weeks.

And I agree it’s totally frustrating when some bulbs work and some fail when they were all working through the bridge. All I know is other people have reported some similar ST issues with other ZLL devices, whether Hue, GE, or Cree, and ST is currently working on the Hue ones.

Interestingly, the working bulbs are the 90W replacements, while the 60W replacements aren’t found.
Well, turns out they were just easier to reset. On/Off 6 times, and things work.

Hi Joseph,

I had a hard time pairing them as well. I finally was able to do it I had to do these two steps:

  1. Ask support to upgrade your zigbee firmware to 1.5.something.
  2. I then put smartthings into pairing mode looking for new things.
  3. I would in 2 second intervals turn on and off the ge link. After about 10 seconds it finally paired.