GE Link bulbs - I need a beginner How-To


Hi Calvin, try cycling power again. If nothing “Zigbee” shows up then you’d better contact support. You should have these Zigbee elements:


(Sonny Silva) #12

Upgrading zigbee firmware is as simple as sending your request with your st id to Turnaround time was 5 minutes! These guys are great!!!


Primary issue I have found with the bulbs is they don’t dim down that much. At 10% power, they are still around 1/2 brightness. As such, I still am finding I prefer my dimmer switches.

(Mike Swanson) #14

Seriously, at $15 a pop, there should be no complaints with this bulb. Best deal in town.


I agree. The only improvement I’d ask for would be for status updates when the bulb turns on, or when you tap refresh and the bulb is on.

I tried the custom device type mentionmentioned in the thread below, and refresh did actually work, but it wasn’t quite right in how on/off worked:

(Sparty) #16

I have the latest Zigbee firmware version 1.5.4 on my ST hub. But I still can’t connect my GE link bulb…any ideas?


Have you excluded and re-included the bulb? I think you reset the bulb by turning it on and off three times pretty quick, and then you’ll see it blink 3 times to confirm it’s been reset.

How about after rebooting your hub?

(Sparty) #18

It works! Turning the light switch on and off as suggested allowed me to reset and reconnect my GE link bulb to my ST hub. Thanks!


Excellent! Glad it works.

(Kashif Ahmed) #20

I just lost the ability to dim the ge link bulbs. I added 3 new ones yesterday and now I get an error every time I try and dim one… Did something go wrong on Smartthings end??? Anyone else having this issue??

(Scott G) #21

Just tested mine and no issues.

(Jeffrey Hess) #22

Thanks to everyone who note that I need to get the Zigbee firmware updated. I contacted Support and they fixed it within a couple of hours. This allowed me to control my new GE bulb, sort of…

When I set up my bub I did it a table lamp, I then switched the bulb to a different floor lamp and it won’t turn on at all. Vey strange. A regular “dumb” bulb works in the floor lamp just fine. The GE bulb continues to work in the table lamp, just not the floor lamp.

Why would it work in one lamp, but not another. Very strange… Any thoughts???


Those GE bulbs are not dependent upon any physical device, just as long as they get power they’re happy. Does the GE bulb work when turning it on manually via the switch on the floor lamp? If so, it could just be as simple as communication - ie, it may be too far from the hub.

(Jeffrey Hess) #24

It is weird, both lamps are in the same room. When I swap bulbs, the regular bulb works in both lamps, while the GE Link bulb only works in the table lamp. The GE bulb will not turn on at all in the floor lamp.


Any type of dimmer on the floor lamp?

(Jeffrey Hess) #26

It has a knob with a high and low setting. I tried it on each position several times.


Yeah that’s weird. This could be a reach, but could there be anything from keeping the bottom of the bulb from making contact with the bottom of the socket?

The reason I ask is that I had some LED candelabra bulbs that just would not screw all the way down because of the shape of the bottom part of the bulb and a decorative cover on the socket. I had to trim the cover to get the bulb to seat properly.

(Brandon) #28

Also, try physically moving the floor lamp closer to the hub, or as close as possible to the table lamp to try and eliminate range as an issue.

I know you said they were in the same room but that doesn’t necessarily mean anything. The signal stops eventually and it could be stopping somewhere between the two, how big of room, etc.

(Sonny Silva) #29

I typically pair the bulb on a portable lamp by the hub then install it in the final location

(Tim Slagle) #30

For those of you having issues with GE Link bulbs acting up, i may have just found a quick fix.

I was haivng trouble with two of mine and was doing everything not to have to remove and re-add them. I was doing every trci in the book. Power cycling things that didn’t even make sense to power cycle lol. Then i noticed that the icon for the device changed back to default.

I thought hmmmm thats weird. Thinking it could be a DB thing that could cause this i renamed the bulb. Boom it worked again immediately. Thought this was too good to be true… so i tried it on the next bulb… boom worked immediately.

Looks like some sort of DB issue im thinking. Give this a try next time. Hopefully it works as well for you as it did me!