GE/Jasco Z-Wave Plus 14294 will not pair with HUB

I have two GE/Jasco 14294’s purchased new. I am 100% sure they are new from the manufacturer. Never been paired with a hub. I can not get them to pair with my V2 Hub. I have been trying this in the classic app for the most part. A few times I have tried it in the new app just for the sake of covering all possible angles. When I go to pair, the app just sits there and spins until “it’s taking too long” appears and after waiting a long time I either give up or try manually adding. For the most part, I have no problems with any other device in my home. (aside from the occasional drop-off, usually a monoprice plugin switch or WeMo. But very rarely!) So this is particularly frustrating.

The first 14294 I bought two months ago. It was for my office. It would never pair. I left it in just to be used as a switch until I had time to troubleshoot some more. I have two other z-wave switches and a z-wave water shut-off switch in the office, further away than this switch.

Things I have tried:
exclude and re-pairing
exclude several times before repairing
cutting the power to the switch (either on the switch with the pull out tab or at the breaker)
moving the Hub closer and repeating all of the above. SEVERAL TIMES!
rebooting the Hub (obviously done when I moved the hub closer but check this box again anyway)
repairing the z-wave network
resetting the switch to factory default (up 3x, down 3x)
All of the above has been tried many times over the course of the last two or so months.

So, I purchased another 14294. This time I thought, I will try installing this switch close to the hub (where I happened to want an automated switch anyway). IT WILL NOT PAIR. Tried all the same stuff except moving the hub closer. It’s about 15ft away and in line of sight of the hub. It excludes just fine and instantly. It just will not show up when I pair devices.
I have searched this forum and anything else on the internet I can find for anything different I can try.
I have many z-wave and z-wave plus switches in my home and I have never had problems like this.

When I exclude, I get an immediate response back in the app stating the device has been excluded. This tells me, the hub sees the switch.

My only thought is, some of the switches I am using use custom handlers for double tap or fan operations. Is it possible these new 14294 switches are conflicting with custom handlers during pairing? I have tried manually pairing these 14294’s. so this really doesn’t make much sense if that’s the case.

Any thoughts?

For the custom device handlers you have installed for switches, you might try opening them in IDE and re-publishing. Then exclude and try to add your switches again.


That’s a good thought. Do you think I need to remove the the custom handlers (switch my working switches to stock handlers and remove custom ones from IDE) and then re-publish?
I suppose I could try it the easy way and just re-publish first and if that doesn’t work try remove/re-publish. I sure would hate for current working switches to get botched up. lol

Best method would be to open the device handlers and publish for me again. No need to remove them if you intend to use them. There is a known issue where some custom device handlers become stale and users can not add devices because of that. Publish for me generally resolves the issue.

1 Like

I think @jkp is referring to this issue of stale DTH. Republishing them should fix the issue if the DTH’s are causing the problem.

Did you check your hub events in the IDE to see if the device paired?

1 Like

Ok, I have done the publish for me. I’ll have to try excluding and re-pairing when I get home. I’ll probably try this on one switch at a time too. Both are currently connected (using them as dumb switches)

I have actually not live logged adding devices. I will do that tonight and see what shows up.
I opened a ticket for this as well. Maybe they will see something in my logs. So far the response I received was asking for a screen shot of the error message. What error message? Has this tech ever added a device in the app before? I explained the steps taken to add devices and the screens that appear. Hopefully they better understand my issue. Seems rather straight forward to me though.

I’m skeptical about the DTH causing the issue only because I have tried to manually add using the stock DTH. “Press the button at the bottom Add Devices Manually. I pick Switches & Dimmers, then I pick GE Dimmer Paddle Switch Z-Wave (I have also tried a few other listed GE Z-Wave switches) then I press connect now.”
It makes no logical sense why this doesn’t work. All my devices thus far have connected without a hitch. Especially switches. (maybe an exception or two with some off brand motion or water sensors) Every one I have installed, until these two, have connected in seconds. I would think if there was a bad batch of 14294’s out there, more people would be having this issue. And since I purchased them two months apart, I would think the odds are pretty low both are bad switches. The fact that when I exclude them, the response is almost instant really makes me think I’m missing something.

I read some posts about ghost devices and nothing really fits my situation. It’s almost the opposite.

Thank you jkp and RBoy for the help.

I re-published two custom switch device handlers in the IDE and excluded the switches again in the classic Smartthings app. After doing this, I was able to successfully pair both switches within seconds. FYI, both switches paired with my custom switch handler. nuttytree’s GE/Jasco Z-Wave Plus Dimmer Switch. (for using double tap features)

I’m not sure what makes a new device want to use custom handlers over the standard stock handler? Especially when I was attempting to manually add the device and picked the stock handler. Maybe because I have other switches on the network using this custom handler?

I love this forum. This is exactly the kind of help I was hoping for. RBoy, your link in your comment above was particularly insightful. Thank you!

1 Like