GE In-Wall Outlet 12721 is being finicky

It has no problem if I manually turn it on or off, but from a schedule in Smart Lighting it works about every other day. I looked at the device type, and it’s set to Z-Wave Switch. Is that that best type?

That’s how mine is configured, and it’s never given me a bit of trouble. If you have a a small number of installed devices, it’s possible you have insufficient mesh coverage to the outlet. Try a Z-wave repair. If it works, then all good; if not, you’ll be no worse off than when you started.

It’s about 6-8 feet away from the hub. I’ve tried the Zwave repair too.

Well, it was a shot in the dark. The next thing to check is if the scheduler killed your job because it took to long to execute (for whatever reason). Go into the IDE, My Locations > List SmartApps, scroll to the Smart Lighting instance for your outlet and click/tap its name. A window will open; scroll to Scheduled Jobs. If the date/time is missing or blank, that’s the problem. To fix (possibly only temporarily), close the window and click/tap the ‘Update’ link for the outlet. Alternatively, you can do it from the mobile app by going to My Home > SmartApps,and pressing ‘Done’ after accessing the Smart Lighting rule for your outlet.

It’s set to turn on at sunset + 12 minutes, so it shows that as a trigger, but nothing under scheduled jobs. Hitting update doesn’t seem to change anything. Should I try setting it for a certain time? My front porch light which is a GE light switch and is setup the same way never has this problem.

Darn! That’s normal for this device when set for sunset. You can try a specific time - it likely won’t fix it, but at least you’ll have visibility to where it’s failing.

Scheduler in ST is buggy. It’s a known issue.

This could help you update/reinitialize the schedules. Announcement: New "Update" feature in the IDE

Or just switch to something that works like Rule Machine created by @bravenel. He recently updated Rule Machine to work around the ST scheduling issues. It’s been working flawlessly for me. You can download it here: Rule machine - as per the app developer, this app is no longer available for new installs, distribution, or support

1 Like

This automation is security related so I want it to run local. I actually have a rule machine routine setup now to notify me if the automation fails. It turns on a different lamp and sends me a notification with the results, lol. One thing I noticed about the porch light switch automation, it seems to send 5-10 on commands when it’s time. I don’t see that with the outlet.

Your best bet is you try to “fix” the scheduling. Here is the link: [quote=“jgravert, post:7, topic:38294”]
This could help you update/reinitialize the schedules. Announcement: New “Update” feature in the IDE

EDIT: You can try this also.

1 Like

Well after playing around with all this it worked today. My fingers are crossed. Thanks!

1 Like

@Seahawk has your outlet been working? I am wanting to get 2 of these things and stick them outside on my back porch up around the ceiling.

Yes it has. The problems I was experiencing must of been something on the backend, or whatever the problem was they fixed. It’s been fine for months.

1 Like