GE/Fasco 14924 Zwave Plus Dimmer double tap issue

I have several Zwave dimmer switches that are successfully listed in ST IDE and the classic ST app with increased options such as double tap, inverted, delay settings, and associations. I can set any dimmer switch unique ID in association 2 and it will collectively turn on or off if I double tap the switch. However, my wife really desires to have dimmed lights go full brightness with double tap up. It works on the app pressing the small up arrow in top right corner but does not work on the physical switch. I can see in the ST IDE device events that when I press double tap on the switch, it shows as “Double tap (button 1)” so I feel like i’m super close but can’t find where to say “Button 1 = 100% dim”. Took a screenshot of what I see on the app and my device in ST IDE. I do not currently have any apps loaded such as webcore because someone said doing simple things like double tap doesn’t require those. If I’m wrong maybe that’s the next step but I’d rather avoid webcore as it was surprising I got this far without breaking anything.

While it’s correct that using double tap in its simplest forms doesn’t require Webcore, what you’re talking about likely does (or a custom smartapps). It would be trivial to setup in Webcore, but you may not be happy with the random delays for such an event to occur. Sometimes it will feel instantaneous, sometimes it will take several seconds.

I’m in a similar boat, but it’s because of my own choices. I used dimmers where simple on/off switches would have been a better choice in some applications (bedroom closet, hallway).

I tried 2 smartapps just for simplicity sake but neither worked when I installed them on the classic ST app. I tried Konnected and “advanced button controller ABC” which some people said they had luck getting the simpler functions like double tap to work.

If you know of a smartapp that works for my model/version I’d give it a try. Otherwise, are you saying webcore is required for double tap to perform 100% brightness?

I don’t know of any smart apps, but I do think one could be made to work. I’m not saying Webcore is the only way, but it’s a way that I know for sure works as I use it for similar stuff.

… and by “made to work” I mean that someone could write a smart app to do what you want.

You already have Advanced Button Controller (ABC) installed. so do this:
Write two separate routines that does what you want (set device level 100%, set device off…) and name them appropriately.
Test that routines and make sure they work.
Go to advanced button controller, make a new device mapping.
Select your GE device.
It will present you a screen to select actions for button 1 and button 2
Button 1 pressed is = double tap up. Scroll down to run routine and select the routine you created above that does what you want when you double tap up.
Button 2 is double tap down so do the same with the other routine.
Save and exit.

Enjoy your double tappy goodness.

1 Like

Thank you nathancu, the problem i had with Advanced Button Control was when I tried to “discover new devices” it would error out on my smart phone and I couldn’t get it working. Maybe others will have better luck with that smart app and be able to avoid creating a custom piston with WebCore like I ended up doing.

Speaking of WebCore, if anyone else is like me and struggled with this entire process…take a breath, grab a beer, and come back to it. It’s worth it once you get it working. WebCore has a very intuitive programming that opens up a lot of ideas/features I never thought of. I created double tap features within 10 minutes and then got creative and made a double tap “down” to set all lights at 10% which the wife loves even more. Then, I decided with our gate on the stairs always being left open by our 3 year old, I added a piston to make our living room lights blink until the gate is closed. Now our 1 year old won’t fall down the stairs because my wife can easily see the lights blinking. It’s kinda addictive how strong webcore functionality is.

The website that helped me get Webcore working was this

Hope that helps the next person.

Awesome work. I love Webcore, I just wish it ran locally on the hub for those times when the Internet being the Internet slows things down.

WebCoRE is the BOMB! However, with ST, it depends on the cloud. If you really want things to work when the internet goes down , you might want to consider adding a Hubitat Hub to your setup.

I am not advising replacing ST but rather supplementing those action that “must” run to run locally on Hubitat.

I use both as well and yes webCoRE does run locally on Hubitat.