SmartThings Community

GE Fan Switch - Turn off blue indicator light

devicetype

(Brian Korb) #1

I’ve tried about 10 different DTH’s to turn it off (including 3 custom ones). I was unable to get Sticks18’s to work, I would select it and it would revert to the last saved. I’ve tried the at the switch option of press 3 times on and then off once. Nothing works. All the threads I’ve seen are old and mentioned that they need to do a update to fix it. Does anyone have a solution that works or know when a solution will be available.


Z-Wave Smart Fan Control Custom Device Type
(jkp) #2

I use the following DTH for my GE z-wave fan switches and it handles control of the indicator lights.


(Brian Korb) #3

Thanks jkp. This is the one I am currently using and have not had any luck on any of the 4 that I just bought in the last few weeks and installed a week ago.


#4

The GE Fan Switch has a known issue where the LED does not follow the settings with ‘always off.’ There is an app that handles this by jury rigging things but the bottom line is there’s an issue with the stock device settings.


LED on/off on GE switches
#5

@Nezmo: Does

@Nezmo: Does this SmartApp actually still work for you? I haven’t been able to get it to impact the LED no matter what I do, and I’ve tried every possible permutation I can think of.


#6

Hi, while I provided a link to the SmartApp I do not actually use it so I can’t comment if it still works, sorry.

Tagging the app’s author @sticks18.


#7

Got it, thanks anyway.


(Brian Korb) #8

Unfortunately, I never got it to work either with the fan. I tried every possible combo including a few others, but no luck. right now I have a sticker over them, but when I have time I’ll put something on the backside of the cover plate, so the kids can’t remove it. might glue something in, since I’m not sure I’ll ever what the light on as it is like a beacon in a dark room.