GE (Jasco) Z-Wave fan controller troubleshooting

I got one of these and installed it, and started running into issues. The switch showed up in smartthings immediately, and will turn on and off power to the ceiling fan when you physically operate the switch, but smartthings has no actual control over the device. It shows on at all times, regardless of if the switch is on or not. Trying to turn the fan off in smartthings results in the “on” tab turning grey and reading “turning off” for a variable amount of time before going back to green “on.”

There is also no speed control on the switch, though it does flash the correct sequence for “high speed” on the light located at the bottom of the switch.

Ideas?

Hi, and welcome to the Community. There are several discussions on this device, so I highly recommend doing a search to find and use a DH specifically designed for this. ST’s default DH is a dimmer, not a fan switch.

Here’s the result of a quick search:

https://community.smartthings.com/search?q=ge%20fan

and here’s a DH I wrote for it. There’s another one in the community as well, and the search I posted above will get you that as well.

https://raw.githubusercontent.com/constjs/jcdevhandlers/master/devicetypes/jscgs350/my-ge-fan-control-switch.src/my-ge-fan-control-switch.groovy

Here’s what it looks like with the latest version of the ST mobile app:

I have seen this before. I have had that symptom several times. Each time it was because the values that decide the different speed zones were not written in the IDE on the Web under the device.
I have fixed it 2 different ways.

  1. I went into the IDE and clicked edit under the device and entered the numbers there.
  2. The other time I opened the smartthings app. Selected the fan. Clicked the edit gear in top right and set them there. When I saved those edits it wrote them into the IDE.

I know this is obvious but make sure the pull chain is on the high speed setting.

I also use the custom DTH referenced above. I recommend it over the default slider option.

It’s about time ST really put out official support for this switch. You have good advice above but really, Smartthings need to get on this. Furthermore, the LED option on this for ‘always off’ does not work. How hard can it be?

2 Likes

If I remember right you have to change the DTH to smart fan not switch which it defaults too.

Is that smartthings fault or the switch manufacturer?

There is a smart app that you can install to force toggle this to compensate for the switches inability to do this.

I put it down to us having to use the dimmer switch device handler and that an official one has not been released. I assumed the code for the LED in these is different to the dimmer but I could be wrong.

I know - just silly we have do use that to compensate.

1 Like

Ok, been reading a lot of posts and cannot find one dealing with this issue.

In the kitchen/dinette combo room I have a triple gang box with one switch handling the kitchen can lights, one switch handling the lights on the fan and one switch handling the on/off of the fan blades.

There are two separate switches to control the fan. (light and fan) Each of these switches has there own load and a line wire.
I added the needed common jumper.
The fan is a Hampton Bay 3 speed controlled with a pull chain. The original wall switch just controlled on/off. I would like to confirm that such a 3 speed fan does work with the GE Fan Controller switch.

I am using a Smartthings V2 Hub.

When I hooked up the GE fan controller the blue ED did not light. The GE smart dimmer switches for the fan’s lights and the kitchen lights work perfectly.

I was even able to determine and set the fan to it’s high speed setting when trying the GE fan controller.

The blue LED never lit and the fan never turned on. I also tried two different fan controllers to be sure the one wasn’t bad.

Is there a trick to wiring the fan controller? Does it work with a mechanical 3-speed fan? (meaning the speed is controlled by the pull cord only). Should I just get a GE smart on/off switch?

I also notice there is NO “fan controller” option in the ST’s app to add the unit manually? What is the correct “thing” to select to manually add the fan controller? I tried using the GE Smart in wall dimmer (z-wave) and the GE on’off switch (z-wave). No luck using either.

And to just confirm. I was able to add no problem (well it took a few minutes for the hub to find the switches) the GE smart dimmers for the lights. So the hub was close enough. The troubling thing is that the led in the fan controller did not turn on. I also confirmed the system was hot and had power going to it and when I re-installed the original switch the fan worked as normal.

I just replied to your other post.

Thanks. I posted here to get maximum coverage since this was a similar ongoing thread. And I do understand the ‘dimmer’ nature of the fan controller. Just aggravating that two different fan controllers were not working.

i used the custom dth here and got it in my app, i can see the settings and turn the fan on and off, but regardless of what speed button i select it stays the same speed (approximately medium) i know the switch is on high, and prior to the dth i could adjust the speeds thru the slider and it would crank up to full at 100 and down to low at 1

thoughts from the hive mind? its the newer ge z-wave+ fan control

Having a similar issue that the fan only works when set above 70%.

I have two fan control switches in two separate rooms connected to two identical fans. One works perfectly. The other only works if the switch is set above 70% and the run the fan at whatever speed the pull chain is set. Tried it at all three pull chain speeds. Any ideas?

I never got that fan to work. When installed on a different circuit with a new ceiling fan, the switch will control the fan on/off, but still will not control fan speed, and none of the remote zwave functions work. My patience with SmartThings ran out well before I found a solution.

The answer is in the other forum post. Tap ON ON ON OFF really fast to turn off the led when the fan is off.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.