GE fan controller acting like dimmer

Question, I recently bought a ge fan controller, 14287, but when installing it via smartthings I’m provided with a sliding scale for the fan as if it were a dimmer. I find this odd, workable, but odd. I’ve seen a number of self made interfaces posted online, and am curious if there are any recommendations, and if there’s a guide to installing/integrating them.

Yes the default DTH works like a dimmer where:

0 = Off
1-33 = Low
34-66 = Med
67-100 = High

Personally I stick with the stock DTH because it’s really not that hard to use (for me, I can understand family members might not get it) but MOST importantly, it keeps the device running locally which is more critical than anything.


Here’s a DTH which lets you pick low-med-hi.

Here’s a modified version with child devices that can be accessed by smart speakers:

Which one is the Stock DTH? Zwave Dimmer?

Z-Wave Dimmer Switch Generic


Mine are the non-plus versions but all list as just “Dimmer Switch”. You’ll get over the whole slider/percent thing pretty quick, especially if you use voice control. I just say 30, 60, or 90 for low. med, hi.

1 Like

Alternatively, if you use the 3-speed fan thermostat smartapp, you won’t need to control your fan manually :slight_smile:

Just to note: these device handlers are not confirmed to work with the Samsung Connect app which the OP’s second image shows they are using.


Has anybody noticed that in the new app there is a GE Fan Controller, was wondering if anybody had seen this or tried to use it. I would have to remove my fan and readd under the new app to make it work.

OK, I guess I didn’t consider the other DTHs not being local, that makes sense.

1 Like

I have it installed on my phone, not a fan, prefer the “classic”.

Has anyone tried this and how does the tile look in the “New App”?

Not sure but I’m using the generic “Z-Wave Fan Controller” for all my GE fans and it’s been working for at least 6 months. The speed is now a slider with Off / Low / Med / High but there is no way to change the LED behavior. Mine are all defaulted to Off = LED on, on = LED off which is fine for me but if you don’t want it that way I’m not sure what you can do. It also for some reason runs in the cloud. Only the generic dimmer one ran local.

Hopefully they fix that.

1 Like

Missed this! Giving Alexa High, Medium and Low commands works as well.

In the Classic App, the slider is funky

However, in the New App, the tile is rather sleek and snappy. Also, there is a setting in the New App for the LED.

I also can confirm that mines says Cloud as well…Guess, I’ll switch the rest over now since the custom DTH I am currently using does not display the 3 speeds in the New App.

Wait…what DTH are you using? I don’t have a Settings but I do have the nice Off/Low/Med/High.

The one that you pointed me to! The “Settings” option is there if you press the Hamburger Menu on the top right.

Lol. I don’t have a settings option, only edit and info. I don’t understand how that’s possible…

Nevermind…just SmartThings being dumb. Switched my DTH, which was on “Z-Wave Fan Controller”, to “Z-Wave Dimmer Switch Generic” and then back and now I have a settings option. However it doesn’t do anything…I can’t actually change the LED behavior. Also the Timer/Power On/Power Off showed up the first time after the switch but then going into it again and they are not there.

There is some screwiness going on.

1 Like