GE Fan Control Install Issues

I’m trying to install a GE fan control switch, the existing set up is a fan only install that had a 3 speed wall switch. The wall switch only had load and line wire connected, no neutral or ground attached. When I installed the GE switched I pigtailed the neutral and ground from inside the box. The GE switch connected to Smartthings and seems to work in the app with on/off and speed changes, but the fan does not run. I even installed a new fan, but still no go so I reinstalled the original switch and still nothing. I’ve checked the load/line with a noncontact tester and all seems OK. Any suggestions appreciated.

pull switch on the fan is set to 100%?

1 Like

I assume the fan was working before you starting changing the switch?

Yes, actually the fan had run pretty continuously for the last 15 years, that’s why I finally decided to put the smart control in. I tried bypassing the switch and still nothing from the fan which is why I figured the fan went bad so I bought a new fan. Thank you for your response.

Just for testing, could you hook up something like this to see if the power is actually getting to the fixture?

I think I have one in the basement so I will try that out. Thanks.

I hooked up the light and no luck. Though the line connected to the light shows it is hot with the switch on or off.

sounds like you haven’t identified you’re loads and line correctly

Also make sure that you have a good neutral. With the non-contact tester that’s only going to tell you if you have 120 volts on the power line. You really need a true tester and put one lead on the hot /slash black wire and 1 lead on the white/neutral wire . It should read 120 volts

Thank you for the response. I don’t have a meter so I’ll see if I can borrow one or go buy one. I did draw up a sketch of the wiring in the box. As I mentioned in the original post, the new switch for the ceiling lights works as it should and the fan control switch seems to operate with smartthings at least it changes state and speeds in the app, but the fan does nothing.

What was the red wire connected to previously with the dumb switches? Do you have one set of 14/3 romex going to to your ceiling fixture or two sets of 14/2?

There is 14/3 going to the fan. The red wire was not connected with the original dumb switch. Actually the neutrals and grounds were not connected to the original dumb switches either. It’s my understanding it is used to provide power for the fan light, but I’m not installing the fan light. Thanks.

ah, i see. Can you post a link to the fan you installed? maybe it uses a motor type not compatible with the GE switch.

but without the light kit? Looks like it should work.