GE/Enbrighten Z-Wave Firmware Update Issue - Please Help!

I have the Zooz S2 700 stick and have previously updated the firmware of my GE/Jasco/Enbrigthen Z-wave switches using the PC Controller software for windows. For some reason, I can no longer get it to work. I’ve tried excluding and re-adding the Zooz controller (as 2nd controller to SmartThings). I’ve tried doing Z-wave repair. I’ve tried updating a number of my GE switches and all give me the same result — unable to receive. It simply doesn’t progress from packet #1 and eventually times out.

If anyone has any ideas on how to get this to work I would greatly appreciate it. I recently replaced a few failed GE switches and the new ones require a firmware update to get the double-tap behavior like I need it.

Thanks in advance!

Have you tried to exclude the switch and add it to the stick INSTEAD of trying to update the switch using the stick as a secondary controller? I had that issue with a Zooz switch. I was able to update the firmware that way, but not while the stick was included as a controller. Zooz had no idea why…


Agree. Answered in detail on the other thread where this question was posted


Thank you! That worked!