GE Dimmer Module won't work with ST

So recently one of our cats unplugged our GE Z-Wave Dimmer module (sigh) and after plugging it back in it will no longer work with ST. I can make it work by manually pressing the button, and it shows up in the ST App on my phone, but when I press on or off it just says “turning [on/off]” and after a bit it does nothing more.

It’s part of a TON of routines, so I’d rather not remove it and rediscover it unless that’s my only option (which sucks). Any ideas on how to fix?

Try turning it on. Then doing a zwave repair. Worked for me when I took down the Christmas tree and repurposed the plug back to my bedroom.

Sounds like it got dropped , lost sync with hub.
open it in the app, click on settings ( gear/hamburger ) and click replace. ST will try and force a connection and either succeed or ( likely) fail. If it succeeds it will say " device is not considered failed" and it should now work. If it can not force a connection it will come back with " ready to replace". Now put the plug into inclusion mode ( if I remember it is plugging it in and clicking the button while hub is searching ) ST will find the " new device" and put it right back into all of the automations .

1 Like

Thanks for the info – neither worked, so perhaps somehow the device itself is broken (didn’t think these things “broke” but there you have it).

I’m guessing that putting a new one there is going to be an issue with all my routines. Sigh.

Oops, spoke too soon. It DID work, when I turned the device off (for some reason clicking it on didn’t work but turning it off did).