GE 12722 Switches Stopped working with ST


(David Christensen) #1

Installed two GE 12722 switches a few weeks ago to control my front door and garage door entry lights. Got them added to ST, setup Smart Lighting / Turn on Front Door/Garage Door Outside Light at sunset/sunrise lighting automation and they worked like a charm.

Two days ago I noticed the lights didn’t come on at sunset so I manually had to turn them on. I am pretty new to ST and Zwave devices in general so I am trying to troubleshoot what the issue is and figure out how to fix it. I tried the zwave network repair but it didn’t help.

Has anyone else had an issue like this? What should I be looking for and where do I look? Is there a process to delete and re-add the switches?

Thanks in advance!
David


(Kevin) #2

Have you tried cutting power to them by throwing the breaker in the box for them? Basically reboot them :slight_smile:


(David Christensen) #3

Just did, didn’t seem to help.


(Joe) #4

Exclude them then add them back. It’s strange I have over 40 of them and so far flawless.


#5

How far are these switches from your hub and do you have other zwave switches between the hub and these switches? When I first started with my HA setup, I had very few devices and had the same problem. Moving the hub to a different location helped.


(Ben W) #6

Pull the airgap to “reboot” the light switch. Are they reporting at all?

Do you have other zwave devices working?

And my old standby, reboot the hub. Occasionally it just needs a kick. I would try this before excluding and re-adding them. A couple times I lost all control over zwave and a reboot fixed it.


(Sean) #7

I have had to move my hub several times now trying to get my ge switches all working. They have a very limited range


(Rick S) #8

I have 5 of these switches since Dec and only 2 days ago did one of them fail. The air gap didn’t work so I ended up completely removing the device from ST and re-adding it. Didn’t think to reboot the hub, will try that the next time

The switch that failed is about 20 feet from the hub in a direct line and totally un-obstructed. I have switches that are 40-50 feet away with no issues

Rick


(David Christensen) #9

I had removed one of the switches before I saw this reply…and wouldn’t you know it that fixed the 2nd switch I didn’t remove. So now I have to try to re-add the switch I removed.

I already tried this once this morning, using the same technique I used when I added it the first time, it didn’t work. I keep seeing references to using general device exclusion when a device doesn’t get added. I have enable this from within the ST mobile app and it says I need to follow the manufacturers directions but I don’t see anything mentioned in the literature that came with the switch that discusses this functionality. What do I need to do to add this bad boy back to ST now that a hard reboot fixed my issue?


(Morgan) #10

I had the same thing, and I had to reboot them ( throw the breaker) make sure to do it for at least 15 seconds. I had several devices that weren’t responding so I did a Zwave repair, and it seems to have helped. I noticed a few of my issues were with the bug w/ the 2014 ST motion sensors stopped reporting motion as well.

Morgan


(Ben W) #11

To exclude light switches its basically the same as including. Go to the excluding search. Turn on/off the light switch a couple times. Wait 30 seconds or so to see if it is excluded. If it is not, then there is a good chance its orphaned and should be able to be re-added.


(David Christensen) #12

When I enable general exclude and toggle the switch a couple of times (if 30+ times is a couple) and nothing happens. Is the app supposed to report something when an exclusion occurs? I can’t tell if the switch is orphaned but attempting to re-add the switch isn’t working either.

Is there real time scrolling 'aka tail -f" for the log files to see if ST is even seeing a device that may just not be responding?


(Ben W) #13

You can look at live logging in the IDE and see if the device is reporting.

Usually on exclude it will say something like “zwave switch excluded”.

You can try this:


(Jason "The Enabler" as deemed so by @Smart) #14

I have about 40 or 50 of these installed. When one acts up, this is what I do.

 - Pull air gap
 - go into mobile app
 - go to things tab and select the device
 - tap on the great and go into the settings
 - scroll down and tap on replace (the air gap must be pulled before this step)
 -when the app says the device is ready to replace, push in the air gap.
 - manually turn on/off the switch serveral times, or until the app says the device had been replaced or success, or whatever it says.

As long as the switch is physically working like it’s supposed too, this should work.


(David Christensen) #15

Thanks for the info, I’ll have to give this a shot next time I run into this.


(David Christensen) #16

I was able to get the switch added back to ST after trying the following:

  • Pulled/Pushed Air Gap
  • Enabled Exclude Device
  • Pressed and Released the top of the switch 10 times while ST was in Exclude Device Mode (GE describes this action as resetting the device)
  • ST acknowledged device was excluded
  • Proceeded with adding switch to ST following GE and ST documentation

Didn’t read anywhere that doing the “reset” on the switch would facilitate the device getting excluded but it was the only thing that worked after several other things were attempted. The air gap may or may not be necessary as I tried it several times before and was unsuccessful prior to doing the “reset” procedure.


(Alonso Garcia) #17

I’ve been having lots of problems with GE Smart Switches 17222/ZW4005. At first they worked fine, after a few months they became a bit flakey, then all of a sudden they stopped working. I’ve had 2 of them for the last 18 months or so, but practically just using them as a standard switch. They lost all z-wave functionality a a while back :frowning:

I even bought a brand new one yesterday (which I already returned) to try again… No luck.

Even the new one did not pair correctly. I’ve tried 1000 times, moved the hub within a few feet from switch, and all possible solutions posted here and all over the web. Got it to pair I think twice, but with very limited/intermittent functionality, pretty much useless. I am a fairly technical person, and not new to z-wave devices.

Could it be a firmware incompatibility? I am running an old ST hub v1 on 13.13 and my old 2 switches stopped working almost simultaneously, maybe after a hub update?

Other brand devices (some z-wave, some zigbee) work like a charm, even a GE outlet works fine. I factory reset the hub yesterday and removed/added all other devices back in seconds. GE Smart in-wall Switches just don’t want to cooperate.

What other brands do you recommend for basic on/off in-wall? Most of what I’ve seen on amazon has very mixed reviews.

Any experiences with Linear/GoControl?


(Jonathan) #18

This is the exact situation I am having. I have experience everything you described. Have you found a solution? I was just about to factory reset the Hub (v1.1 on latest firmware).