GE and Zooz Dimmers - turning off the blue LED

The GE and Zooz Dimmers have a blue LED that turns on when the dimmer is off. Is there a way to disable that LED turning on permanently from the SmartApp or in any other way?

I don’t know about the zooz, but for the GE there is a parameter that you can set by reconfiguring the device.

What you do depends on the exact model, so we would need model numbers.

The GE switches are made by Jasco, and here are the instructions for the Z wave plus devices:

There is a link on that page at the top to the instructions for the older models.

Some of the devices can be reset just by a specific tap pattern on the switch, for others you will need to use the app.


1 Like

Thanks for the tag @JDRoberts!

@crimson depending on which models and version of the Zooz switches you have, you should be able to turn the LED indicator off either from the switch itself by tapping any of the paddles 6 times quickly or by changing it in the advanced settings (you’d need a custom handler for that, you can fin instructions on how to install them here:

If you run into any issues or aren’t sure which version you have, just get in touch with Zooz support (include your order number in the inquiry to speed the process up):

1 Like

Thank you!

1 Like

Found it:
Alternatively, the LED default setting can also be changed at the switch.

To disable the LED indicator:

  • Press the “ON” switch 3 times successively
  • Press the “OFF” switch 1 time

Use this same process to restore the original LED setting.

And it works. Thank you?