GE 14287 Ceiling fan switch only works on Low or High, not Medium

I have a ceiling fan which has been connected to a 14287 switch for about a year. It worked flawlessly until one day, it started only operating the fan at a super low, worthless speed or at 100%. I tried removing the switch and re-adding it to smartthings, a factory reset of the switch, and using 2 different device handlers but nothing fixed the issue. I reasoned the switch must have gone bad so I ordered another one and replaced it.

I had all 3 speeds again and it was glorious… for about 2 hours. Now the fan is back to super low and 100% speeds again. My wife said she heard a “pop” from the area the switch is located so I have a feeling the switch might get overloaded for some reason in the medium setting and burn that out, but keep the low and high.

What other steps can I take to figure out how to fix this issue? I’m not opposed to replacing the fan but want to make sure I’m fixing an issue rather than just throwing money at it. The fan has been manually set to the high setting via the pull chain then operated by the switch the entire time.

Given it could be a hardware problem I would recommend reaching out to the manufacturer, GE/Jasco:
https://byjasco.com/contact

They offer a 2 year warranty, last time I checked.