GD00Z "Error Fetching Device"?

When I select the gear to access the preferences for my GD00Z I get an error “Error Fetching Device. Please try again”.

There is nothing in the live logs.

Anyone know what causes this. I have not modified this device and it always used to work so no idea what has changed.

Support is useless. I have added preferences to this device but I can’t access them because of this error. If SmartThing is going to produce an error there should be something in the logs to help us understand what is happening. How am I supposed to fix this when there is absolutely no details on what they are rejecting/failing on.

This was the reply I got from Support. Basically they an no longer helping those of us in the community that are providing device code. Ridiculous !

Jim (SmartThings)

Dec 20, 9:17 AM MST


Thank you for contacting me!

I’m sorry that you are getting that error message.

Unfortunately we do not have a lot of resources available to help with custom integrations. Very sorry about this, but the volume of support requests we work with from day to day prevents us from being able to spend the time we’d need to help with custom solutions like this.

However, if your only need is to rename the device, that can be accomplished from our IDE by going to devices, clicking on the device, then clicking on edit.

Let me know if you have any further questions that I can help you with and I would be happy to assist you with those!



@Tyler I saw you helping some others out with DTH code. My version of the GD00Z device code has worked for a long time but I am getting error when trying to implement preferences.

Currently my device handler doesn’t implement preferences. I used to be able to open preferences and change the device instance name but now I get this strange Error Fetching Device error.

I have preferences in this device and it works fine.

I have tried adding a preferences block, I want to add the following preference. I have tried placing in outside metadata like my zxt-120 device code which works. And inside the metadata as it is documented in the api docs.
I get this error regardless of not having a preference block, having on outside meta data and having one inside meta data.
The block I am adding is as follows, as documented

preferences {
input name: “enableSwitch”, type: “enum”, title: “Enable Switch Capability?”, options: [“Disabled”,“On=Open”,“On=Close”], description: “Enable Switch Capability?”, required: true

I have also tried it as I have it in my working ZXT-120 code.

preferences {
input(“enableSwitch”, “enum”, title: “Enable Switch Capability?”, options: [“Disabled”,“On=Open”,“On=Close”])

Nothing I try corrects this error message about problem fetching device. I am thinking this error has nothing to do with my device code but rather is an issue with a corrupted device in my account. But since support refuses to help because “we do not have a lot of resources available to help with custom integrations”, I am stuck! Any help you can provide would be appreciated.