FX Luminaire Luxor Landscape Lights [edge driver link in post 24]

Has anyone successfully integrated this with SmartThings? Just installed a new Luxor ZD Power Controller transformer and would love to be able to trigger themes and turn on/off lights through SmartThings.

It looks like a pretty proprietary/closed system on their website. What kind of integration did you have in mind?

It has a wifi module with mobile app to control the lights (on/off - set theme - timers, etc). Found a golang library on github to control the unit through the wifi module.

Looking to use Smartthings to turn the lights on/off or to set themes based on Smartthings triggers.


do you have the ZDC or ZD controller? I have the code up and running with the ZDC currently. Just need to test out the ZD controller code but I’m on the road this week. If you have a ZDC I can publish up the code for you to try. If you have the ZD I should be able to get a tested version in about a week.


Hi Tag,

I have the Luxor LZD-300m. Thanks so much! I was surprised to find so few posts on FX Luminaire. Great lights and transformer. Hard to find good options for landscape.

Agreed… This one is good but the IoT integration strategy is non-existent for them. They’ve been working with me and encouraging me to push out these integrations.

I have my code hosted at https://github.com/tagyoureit/SmartThings_Luxor. Again, it has been fully tested with the ZDC but not the ZD yet. I do have the ZD face pack so I will be able to test/debug the code but won’t be back until the end of the week. For some reason, they decided to make some small, but significant changes, in the API’s. For example, the ZDC controller uses “Inten” while the ZD uses “Intensity” to represent the brightness.

Will look forward to having you test it out as well. Stay tuned.


Finally had a chance to install. I have to say, this is absolutely amazing! Fantastic job. ZD controller on/off works. Individual lights imported perfectly and work. Dimming works. Themes imported perfectly and trigger when pressed.

A few questions. With the theme buttons, when they’re pressed, they stay depressed (highlighted) unless you click them an additional time. Also, is it possible to add an all lights off button like in the Luxor app?

I’ll test more this weekend and provide any additional feedback, but so far it seems to work perfectly!

1 Like

Cool! Glad it worked for you. I did look through my code and had a feeling it might work as is.

With the theme buttons, when they’re pressed, they stay depressed (highlighted) unless you click them an additional time.

I think this might be a timing/refresh issue. If you pull down to refresh the entire page (all devices or just the details), you’ll see that it does indeed change state (revert to off), but I’m not sure why it isn’t more responsive to the event in real time. If you wait a few minutes it may update itself. But I’ll also look to see if I can ‘force’ a refresh somehow.

Also, is it possible to add an all lights off button like in the Luxor app?

Already there. You can use the “Luxor (ZD/ZDC) Controller” device as the all on/all off button. It defaults to 75% on now, but I could make that a user configureable setting (level %). Or were you looking for a dedicated “off” button? Right now the Luxor Controller device will turn on when any Light Group is on (and become an Off button) or turn off when all Light Groups are off (and become the On button).


Just did a quick test this morning and you’re correct on both counts. The refresh issue is odd. The Luxor ZD controller switch seems to update much faster to state than the individual lights. Sometimes forcing a refresh or even killing the app doesn’t seem to help, but waiting does. Could be an issue on Luxor’s side. Still I don’t see this to be much of an issue either way. Have to run to the office, but ill try to play with it more this evening and/or on the weekend. Excited to start writing rules with it to see what new functionality we can do.

This couldn’t have come at a better time, as I was just about to scrap my entire smartthings configuration (hundreds of rules and devices…) due to a bug with modes. Been working with support for months and just can’t seem to pin it down… but that’s for a story for another thread.

Have you shown this to the folks at FX Luminaire yet? Very impressive!

I tested out the ZD portion of the code and see no issues, like you indicate. I also did fix the Themes button issue and it is now coded to stay on for 2 seconds and then turn off.


Just here to chime in and say thank you @tagyoureit!! Worked perfectly the first time. Up and automating in under 2min from finding this post! :smiley:


And FYI for anyone else, I recently updated the code to support the LXTWO model controllers.

I was very glad to see this exists! I have a LXTWO though, and after the SmartApp discovers the controller at the IP address, It says it is adding a Luxor ZD (instead of the ZDC I have) and then clicking save it first says it is installed and automating, followed immediately by a red banner that says an unexpected error occurred. The screen does not advance or go away, and every time I re-click save, the red Unexpected Error banner appears again. Any ideas what to do? I’ve been desperate for SmartThings control. Thanks so much for your effort on this!

Oh silly me. I forgot to add the device handlers. But now I’m thinking it still thinks its a ZD and not ZDC. All of the light devices have only on/off and brightness settings?

tag, didn’t see the update. Have been trying to get this to work, looks like a great job but cannot get it to work with my LXTWO controller. Any thoughts?

I’ll need some more information about what’s not working to even make a guess.

The drivers are now updated and the repo has moved to https://github.com/tagyoureit/hubitat-luxor. It is fully compatible with ST and Hubitat now.

Just got this working and wanted to say thank you! I was only able to see the enter IP address screen on the classic app, but after setting it up, it worked on the new app. Any plans to add the IP selection to the new app? Thanks!

I am unable to find this in the Hubitat PKG Manager. Is this related to the repo change? I am fresh meat. Literally bought the Hubitat today just for this app.

**Went the manual install route.


1 Like

Hi, glad to hear it!

I had an issue back in August that I haven’t checked on in a while. It was closed without comments (but looks like it was fixed) so I just submitted today to be included on the HPM app. Thanks for the reminder. Hopefully, it will show up in a day or two.