Fortrezz valve (kinda desperate here)


(Dave) #1

The whole reason I bought this thing is to prevent floods to the extent possible. But I can’t find a way to control my fortrezz water valve with flood sensors. There seems to be no way in the app to control one, only switches, thermostats, and door locks.

I can copy and modify a smartapp, so if anyone knows of something I can repurpose, please, please let me know. But searching for one doesn’t seem possible in the IDE, and I’m not a programmer, so I really need your help. Thanks!


(Todd Wackford) #2

Try changing the type to a zwave switch. It may respond to it correctly. If not, submit to support@smartthings.com I think @Urman got it working.


(Dave) #3

I did that. Now it just switches from on to off and then right back to on within seconds.


(Todd Wackford) #4

Just so I’m clear. The valve goes from open, to closed, and a few seconds (how many?) later, goes back to open using the zwave switch device type. Is this correct?

Also, what model and part number is the valve?

Twack


(Jim Beletti) #5

Dave,

Sorry that I’m not home to test this for you. Looking at the device from my hub from the ST web panel, I see I used this for the device type: Fortrezz Water Valve

I remember testing after I Included this valve to ST and I got a bounce (off then back on). However, when I hit the road a week ago and hit the valve in the Things view of the app, the valve closed and still “shows” closed. I looked at the activity log and it looks like it’s still closed.

You may want to look at your hub activity for this device to see if the log mirrors what you are seeing at the valve. If it does, perhaps snip the log and send to support@ to see if they have any ideas.

Jim


(Dave) #6

I can make it function correctly with the Fortrezz Water Valve device type and using a tile as a trigger. The problem I’m having is that I can’t use the iOS app to set up an action that will cause the valve, because at the moment the mobile app only allows for switches, thermostats, and door locks as items that can be acted upon by actions.

If I set the valve to use the zwave switch device type, I can, of course, use the mobile app to set up actions that will cause the valve to close. But, it bounces when I use the switch device type.

If I was a programmer, I could make it do what I want with a smart app, I’m sure, but I’m not. And I can’t find an appropriate existing smartapp in the ide which I could repurpose.

In any case, I did send an email to support, and got a response from Andrew Brooks that also asked Andrew Urman to help me out. I’ll post back here with the result.


(Todd Wackford) #7

@chzdanish (Dave),

That is so weird it bounces back. The zwave command string is exactly the same as an on/off to a zwave switch as the valve open/closed commands. Do you know how to watch your log file? I wonder if you have another app running that is telling to open. I curios to see if there is something commanding the valve to open after it goes closed.

Twack


(Dave) #8

If so, that is strange. Here’s what the events list shows after having just triggered it.

59ea6e2d-e061-42aa-ad92-a094e6160c9b 20 Jan 2014 04:54:35 - moments ago DEVICE /digital switch on Main water valve switch is on false false

a30319ee-96b8-4541-8ca3-152fde9b7470 20 Jan 2014 04:54:35 - moments ago DEVICE zw device: 04, command: 2202, payload: 00 false false

da392686-4ad1-4769-83f4-01f70a24ef92 20 Jan 2014 04:54:35 - moments ago COMMAND off off command was sent to Main water valve false true

Not sure what it all means, except that the valve was sent a command to turn off, and it immediately turned back on. “DEVICE/digital” is suggestive, though. Of what, I’m not sure. As far as I can recall, the valve isn’t bound to anything other than its tile. Also, the valve isn’t reacting to the tile anymore. If I set the device type to Fortrezz water valve I get this.

f5fd283c-a4df-4791-a602-77dcc486bd45 20 Jan 2014 05:11:40 - moments ago COMMAND poll poll command was sent to Main water valve false true

ac6d6bb9-714a-4748-bd83-b8f88da1ba40 20 Jan 2014 05:11:12 - moments ago DEVICE contact open Main water valve valve is open true true

a05ec9fc-c0ac-43de-a19b-96bbebf9b7f4 20 Jan 2014 05:11:09 - moments ago COMMAND open open command was sent to Main water valve false true

And the valve operates as expected when commanded via the tile.


(Dave) #10

Oh, great! That’s perfect! Thanks, and I’ve submitted a ticket.


(Beckwith) #11

@chzdanish

I’m using the FortrezZ Water Valve device type and my valve opens and closes fine but after tapping the button to close, SmartThings gets stuck on “Closing”. Does yours do that?

ST support says official support is pending. Did you ever get TWAKs code to work?


(Bob Kantor) #12

Thanks Twack! This is working for me about 2/3 to 3/4 of the time, even when the moisture sensor is sending its alert 100% of the time and the ST app is opening and closing the ball valve 100% of the time. I.e., there appears to be either a logic bug or some other condition that is impacting the function of this smart app, as both devices on their own are working 100% of the time.

If you could offer any further thoughts on how to debug/investigate further, I’d greatly appreciate it. ST Support say they have taken my ticket as far as they can, since their devices all seem to be working on their own.

Thanks for any help you may be able to provide. (I’m at bobkantor@hotmail.com if you prefer to respond that way.)

Regards,
Bob


(Todd Wackford) #13

Bob,

Have you looked in the log files and see if the close command is being sent immediately after the sensor picks up the moisture?

Twack


(Bob Kantor) #14

Twack, No, I haven’t. Not sure where/how to do that. Will try to figure it out and then let you know. Thanks, Bob


(Bob Kantor) #15

I’ve tried listing my log files using the Logs option from the online dashboard, but am not getting any data to display. I’ll put in a Support request.


#16

Did you ever successfully/automatically link your water sensors to the Fortrezz valve via a SmartApp? I recently bought Fortrezz (WWA-02AA) water sensors and a Fortrezz (WV-01) valve. I can control all devices independently through Smartthings. I tried the App posted by Twack but it only runs partially (requests for user input) and does not automatically shut off the valve when moisture is sensed. I noticed that the Web simulator creates errors if the App is run there. Any help or directions would be most appreciated. Thank you!


(Jay Hahn ) #17

Hey Twack-

Thanks for the code! Like others on this thread I also have a working FortrezZ 3/4 Water Valve (device type=FortrezZ Water Valve) that I am able to open and close the ball valve perfectly from the ST phone app. I created a SmartApp using your code and incorporated a Everspring/Utilitec Flood Sensor. All devices work independently of each other. When the flood sensor is selected as the “where” in the Smart App, and the sensor is tripped with water it sends a refresh command to the selected water valve. Thus far I have been unable to get a tripped wet sensor to send a text or send a close command to the water valve using the copy and paste code. I was wondering if you had any ideas?


(Todd Wackford) #18

You can download and install an app I posted last night (link below). Please read the warning on the top of the file header. Do not use this if your valve is installed upstream of your home sprinkler system if you have one. You don’t want the sprinkler shut off if the moisture sensor senses water during a fire.


(Jay Hahn ) #19

Twack- You are the man! The code installed without errors and worked like a charm the moment a sensor detected water the valve closed and a text was sent and received. The Send Text feature can be deceiving if you have several sensors installed. Luckily the issue with several sensors is not an issue because you can set each sensor to send an additional text if it detects water. Thanks again for the fix!


(Phillip Miller) #20

I have also installed the Water Off When Wet provided by twack and it works flawlessly with the FortrezZ Water Valve and the SmartThings Water Sensors. When the sensor detects even a drop of water the Valve shuts immediately.

Twack - thank you for sharing this app, it adds significantly to the capability of the FortrezZ Water Valve. I have two additional questions for you.

  1. I currently have 3 SmartThings Water Sensors installed and am considering installing 5 more. Is there any limit to the number of Water Sensors your code will support?

  2. In order to add additional sensors beyond those already installed, do I need to uninstall and re-install your app or is there some other way to add the additional sensors?

Thank you for your help!


(Todd Wackford) #21

I’m glad the app is working well for you. Here are the answers to your questions:

  1. There is no limit to the number of sensors. If you have installed and working in ST, they will work in the app.

  2. Just tap the little gear on the app icon and then tap on the existing list (already incorporated sensors). A list will display where you can select more or deselect the existing ones. After the list looks good. Tap done a couple of times and you’re good to go.

Enjoy!