"First Alert Z-Wave Smoke and Carbon Monoxide" adding as "Z-Wave Sensor"

Hi All. I bought a 3-pack of “First Alert Z-Wave Smoke and Carbon Monoxide” detectors and have successfully added two of them to SmartThings.

However, when I try to add the third, it gets added as a “Z-Wave Sensor” instead of a “Z-Wave Smoke Alarm”.

Has anyone else experienced this and/or know how to get ST to recognize it as a Smoke Alarm?

Merry Christmas,

Have you tried to manually change the driver?

Mobile app, open device tile, 3 dots in upper right, driver, change driver and select smoke detector if available.

If that doesn’t work exclude the device from ST. And start over near your hub.


Thanks for the reply.

When I follow your suggestion, the only driver listed is Z-Wave Switch.

Is there anyway to manually assign the “Z-Wave Smoke Alarm” driver if it doesn’t show up in the drop-down?

You need to check and compare the fingerprints of the work and non- working detectors.

To check go to Samsung account. The fingerprint is the model and manufacturers code.

Working Fingerprint

Manufacturer Code


Non-Working Detector

Manufacturer Code


The manufacturer code 0000-0000-0000 indicates it did not pair correctly with the hub. You need to exclude it and then pair it again, very close to the hub. If you can’t exclude it, then delete it and factory reset the device and pair it again.


Can you tell me process for how to exclude it from the hub?

1 Like

Go to hub icon in mobile app, open tile, click on 3 dots in upper right corner, chose settings, Z-Wave utilities, Z-Wave exclusion.

1 Like

after that then you need to put the device in esclusion mode and then you should see a message that the device has benn excluded.


  1. Slide battery door open.
  2. Remove and re-insert batteries checking the correct orientation.
  3. Press and hold the test button. Keep it held down as you slide the
    battery drawer closed. You may then release the button (AFTER FIRST SINGLE BEEP IS HEARD)

I keep wanting to get these but always worried about the reviews I’ve read with the low battery chirp coming at 70+% vs like 20% or so. Curious if that has been resolved in recent years.

And if it supports Z-Wave Plus and S2 security, don’t bypass setting it up properly by either scanning the QR code or manually entering the DSK when prompted.


Hi All. I successfully excluded it and re-paired it and now all is good. Thank you for the help everyone!!!


I believe this is normal. To get a UL listing the detector has to beep for 30 days with low battery in case you are away for an extended period when the beeping starts. Therefore they need to reserve power for 30 days of annoying, non-stop beeping.