First Alert Z-Wave Plus Combo Detector

Time came for replacement of my smoke detectors. I was using the V1 First Alert ZCOMBO. So I purchased V2 replacements. Then came the problem. SmartThings keeps adding the new detector as a generic Z-Wave switch and will not let me change the driver info from that. I do have both the Z-wave Smoke Alarm and Z-Wave smoke alarm-MC drivers installed in the hub. SmartThings shows no model information or manufacture code information on the devices page so it seems it isn’t installing properly and I don’t know what to try now. I’ve removed and re-added several times using the QR code and not using the QR code. No dice so far.

What in the Mfg. Code in the Advanced Web App ?

If it is all 0000 you need to exclude and re-pair. When re-pairing do it next to your hub.


It is all 000 Paul but I’ve already removed and re-paired multiple times with the same result each time.

Did you pair it right next to your hub? If not try that.

0000’s have nothing to do with drivers. It is a pairing issue

1 Like

Within a foot Paul but I’ll set it right on top and give it another go.

Yep, same result with the detector resting right on top of the hub.

I am out of good ideas. You could try rebooting the hub before re-pairing.

I will give that a try.

Unfortunately after a hard reboot same result.

Wait a couple hours and try pairing again.

1 Like

Okie Dokie

That seemed to solve the problem. It installed correctly this time.