First Alert Smoke/co detector only paired as a basic smoke detector

I bought 6 first alert smoke/co detectors to replace the ones in my home. When I set them up, Smartthings detected all as Smoke/carbon monoxide detectors except one. One of them was detected as a Basic smoke detector. I looked at the package it came in, and it looked like the rest of them. Any ideas on the next move?

Try excluding and re-pairing.


ill give it a shot

Worked like a charm…thanks!


I’m looking for some myself, what’s the model number that works with SmartThings?

The model number for this one is ZSMOKE. I’ve been looking for the combo, smoke/carbon monoxide.

I found the First Alert M/N: ZCOMBO-G on Amazon, has anyone tried it on the SmartThings hub?

They’re both listed on Smartthings website. I have 4x zcombos

I have the first alert smoke/CO combo and now wondering if it only installed as a smoke. On my mobile app in the “right now” all I get is “All Clear” and a battery 100%

If it detects CO will this tell me it’s CO (not Fire) or just just alert?

Okay, this is somewhat confusing, I have 3 of these combo units.

It looks like the device type
“Z-Wave Smoke Alarm”

may handle both zwave smoke alarms and combo units.

Their device type is
“Z-Wave Smoke Alarm”

In looking at the available devices types, I do not see any other device type like zwave smoke carbon combo.

In drilling down into the device it shows carbonMonoxide clear as a state, which implies this device type handles smoke and carbon monoxide.


When I hold down the test button on the smoke detector this is what shows in the history. The app itself only shows alarm

I use to have these before going with the now defunct company - Halo (devices still work great), but if I remember right, you will see alerts specific to CO. There’s an old discussion in the community somewhere about this, and where a few of us had/have a CO tester can to test with. If I find it via a search, I’ll update my post with that link.

@johnconstantelo Well. I just went in my garage which has 4 zwave devices in It including a wired light switch(repeater). I opened the door, started the car and held the sensor by the tailpipe until the sensor started beeping and the CO light was flashing… and … nothing on ST. I have it set for push alerts and SMS

I deleted it and re-paired it while in then garage… did it again … and … nothing on ST again. The recent only shows where I paired it. I deleted it and re-paired it again and it synced as a “Z-wave basic smoke alarm” which won’t delete thru the app.

What happens when you change the DTH to Z-Wave Smoke Alarm?

Okay, looking again I now see both DTHs in the list
ZWave Basic Smoke Alarm
ZWave Smoke

All of mine synced as ZWave Smoke Alarm