Firmware v48 Failure to create devices

I am currently unable to create EDGE_CHILD devices in my driver using try_create_device. There is a silent failure and no errors produced. Not sure if this is a hub or cloud issue, but the call is made without any error/success messages:




  "manufacturer":"My Manufacturer",
  "label":"My Label",
  "vendor_provided_label":"My Label",

I have tried it with and without external_id as ST recently added that field.

Hi @blueyetisoftware

I thought I was alone in this too. @nayelyz

It’s desperate!!!

one day they break one thing another day another and it seems that when you ask it sounds Chinese, sorry to the Chinese!

how if they didn’t know that they are changing in the code, it’s outrageous!!!

On top of that they announce that they are going to release firmware 48.9 for everyone when they are breaking important things like the calls to the init life cycles in driverSwitched and unresolved.

and now this!

Why launch beta versions, if they later go into production without solving the problems that users report!!!


Hi, @blueyetisoftware
This is under investigation but I’m curious, do you still have the Hub’s firmware version v48?
The beta group is now on 49.8 but if you also see the error, I’m wondering if there’s something else going on.

I’m not in the beta. I am seeing this on v48 (000.048.00005). It’s been a while since I have added a child device, so I’m not sure when it may have started, or even if its child specific. In my case, these are child devices for a connected LAN device which is the parent.


Your zwave child issue looks very similar, other than zwave vs LAN. It points to the shared child device creation.

Yeah I reported this to the staff last week and they’ve been looking into it.

It’s happening in both the beta and the current release hub firmware so my suspicion is that it’s something in the cloud. There’s no error in the hub API’s but there’s no device created in the cloud either.

1 Like

@nayelyz Based on these different reports, I’d like to make a suggestion about where I think the bug may be if you want to pass it along to the team. There are no errors in the hub firmware logs, so I’m fairly certain the issue is in the cloud. I also noticed that the docs recently made the device_network_id required for try_create_device. It wasn’t required in the past and is not possible for devices of type EDGE_CHILD. You get a warning if you try. My best guess is that something in the cloud is doing schema validation checking for device_network_id and failing if it isn’t present. This shouldn’t be required.


Hi, everyone.

I shared your comments with the team, linking this comment here as well:

I don’t have further information, only that the team found the error log about the creation of the child device and they are already working on it.


Hi @nayelyz

To add some information to this topic that seems entrenched and without information from smartthings and 6 days.

There are users with:

SmartThings V3 Hub.
Firmware: 48.00005
App: SmartThings version (Android 13)

They can create EDGE_CHILD devices without problems with my drivers Mc

I have the same configuration but with the beta 49.8 firmware and can’t create edge_child devices

Firmware 49.8, which is being distributed to all v2 and v3 users this week, has the issue been resolved?

The issue isn’t in the firmware according to the findings of the team and others’ reports (which have 48.00005 as well), the error found was in the Cloud, not the Hub logs, so, something else should have caused the issue, I’ll share this with the team to see if that helps them with the investigation.


Currently, the same phenomenon occurs even if only two switches do not have Child Device and re-register.

What’s the reason?

Known issue being discussed in multiple threads. It is affecting all protocols. I’m moving your note to an existing conversation, so go up to the top of this thread to see the full discussion.

Firmware v48 Failure to create devices

@nayelyz , note that this one is Zigbee. :thinking:

1 Like

Hi @nayelyz

The creation of child_Edge devices already works for me

1 Like

Any update on this? I’m seeing mixed results. It’s suddenly started working on one hub but not on another. The hubs may be connected to different cloud servers as they are in different geographical regions

Not yet, the team mentioned they were working on that but there are no other updates, in which region is the one that works for you?

1 Like

The US north east region hub started working this morning, it’s intermittent, say about 80% of the times it will create the EDGE child device. The UK region hub still has 100% failure (no edge child device created).

1 Like

UPDATE: when a Z-Wave driver tries to create a EDGE_CHILD, there’s a 100% failure rate (never created across all regions), when a LAN driver tries to create an EDGE_CHILD there’s a 80% success rate.

I’m seeing 0% for LAN. I don’t think it is protocol specific.


Nayely could we get an eta for the fix? This is a rather basic functionality that having a severe impact on the user experience as there is no work around either.

Hi, everyone.
The team keeps working on the fix, however, they mentioned they can help you continue with your development/installation if you provide the ID of the location where you tried to create the Edge child and weren’t successful.
For that, you can use the Advanced users’ app > locations
Share with me over DM, the Location ID shown in the table:

@blueyetisoftware, @makizo, @dschnell89, @PAndras, @RBoy