Fibaro Wall Plug EU ZW5 2019 issue

I have bought 2 new Wall plugs in addition to my 3 from 2017 which are working fine. I can’t get the new to work even it is same model.
After investigation I can see a difference in the data MSR and will ask anybody if that could be the problem???
Here are some facts:

  • Device type: Wall Plug, Device generation: EU ZW5 model number, FGWPF-102, * Device firmware version: 3.2
  • Short description Device not working properly (can’t switch on/off from SmartThings Hub)
    • The wall plug can be added to the z-wave network, but not recognised correctly and therefore not switched on/off from the app. It can switch on/off manually, and the app display Power usage.
    • I have 3 other wall plugs from 2017-18 (EU ZW5) and they work fine and I am trying to use same device handler.
    • I can get the wall plug to work with the device handler: Z-wave Generic,(on(off) but not displaying network usage.
    • After studied detailed the differences between the devices I can see a difference in the MSR and maybe this is the problem:
      2017-2018 models: 010F-0602-1002,
      and the new 2019 models: 010F-6002-1003.
      Anyone have experience with the version??

I’m sure that’s very frustrating. :disappointed_relieved:

They are on the official UK compatibility list, so I would contact support and see if they know anything. Make sure you give them the model number and tell them it’s on the compatibility list, that will save you a step.

Tagging @Kianoosh_Karami

Redacted post.

@Peerf, Let’s continue this conversation in DM as I may need to ask you for some private info and additional debugging steps to identify the issue.

1 Like

My email

I have approximately 8 to 10 of the same device (EU version) (don’t want to count because it will upset me all over again).
They are by far the most unreliable of the approximately 200 physical devices connected to the Smartthings hub. I have tried every possible version of DTH I could get my hands on. A DTH would work reliably for a week or more, when all of a sudden it stops working. Changing to another DTH would sometimes do the trick; other times I have to use the button on the plug to toggle it on/off a few times; other times I have to remove power to the device to get it going again.
Because I have so many of them, I tried my best to get them working reliably. Eventually I gave up and accepted that on the day they work, I regard myself lucky. I, however, don’t expect them to work. (It seems that some of them are more troublesome than others, although I’ve been unable to determine any difference. They all have the same firmware. Moving them to different locations makes no difference.)

Any solutions, @Kianoosh_Karami? I’ve got exactly the same issues with my plugs.