Fibaro Smoke detector

Have you found anything that isn’t butt ugly? The Fibaro’s are so small they look great!

Where are you? US/UK?

I’m in the UK

Have you had any success finding a good replacement? At the moment the only thing I would actually want to screw to my ceiling is the Nest Protects. I should be able to get a mains feed to them reasonable easily

Hi,

Are you able to confirm that you can set preferences for the 002 detector ok in ST?

thanks

I can confirm that it does not update preferences and I found the problem too.
It checks that the device MSR (manufacturerId-productTypeId) is correct before sending configuration commands.

I checked the log and it seems getDataValue(“MSR”) returns null for some reason.

Log:

19:19.37: debug After zwaveEvent(cmd) >> Parsed 'zw device: 07, command: 9881, payload: 00 84 07 ' to [['descriptionText':Smoke Sensor (Kitchen) woke up, 'isStateChange':false, 'displayed':false, 'linkText':'Smoke Sensor (Kitchen)'], physicalgraph.device.HubMultiAction@42f7eddf]
19:19.37: debug Device has been configured sending >> wakeUpNoMoreInformation()
19:19.37: info checking this MSR : null before sending configuration to device
19:19.37: info Executing zwaveEvent 84 (WakeUpV1): 07 (WakeUpNotification) with cmd: WakeUpNotification()
19:19.37: debug command: 98 (Security) 81(SecurityMessageEncapsulation) encapsulatedCommand: WakeUpNotification()
19:19.37: debug parse() >> zwave.parse(description)
19:19.37: debug parse() >> description: zw device: 07, command: 9881, payload: 00 84 07

Also I noticed that some default values in device handler do not match Fibaro Smoke Sensor manual (http://manuals.fibaro.com/content/manuals/en/FGSD-002/FGSD-002-EN-A-v1.01.pdf)
I edited the default values to match manual, removed the MSR check and it updated configuration without any problems.

I have Fibaro Smoke Sensor FGSD-002 ZW5 v3.3 and I’m using the device handler that is available in IDE

Hi. I just got a Smartthings Hub v2 and a Fibaro Smoke fgsd-002 (I’m new to this).
I have some issues regarding updating the preferences. It shows
secured: true
configured: false
And the sensor is not reporting back correct as I try to change the preferences.

-I get the same “info checking this MSR : null before sending configuration to device”. Can you share your device handler data or give some more detail to which values you changed, and to what?

-I have also a strange issue; If I remove the battery from the smoke sensor, there is no updated information in Smartthings about this. It behaves as if everything is fine and that the sensor is just not detecting smoke. Makes me a bit worried. Does your sensor behave this way?

-And the “Opened enclosure detection” does not work for me. Does that work after you got to change the preferences?

Thanks, sorry for all the questions :slight_smile:

Hi poisike,
Would it be possible to send a copy of you altered handler?

Hi there,
still not confident my FGSD-002 working properly.
I can manually get it to report using the IDE simulator and Configure option.
However, when left to itself, it doesn’t seem to be waking up and doesn’t report temperature. So no confidence it would report a fire!
I’ve seen mention of a wake up interval but there doesn’t seem to be a way to configure this.
I’ve set temperature reporting interval to 5 and hysteresis to 1.
Any ideas?

Here are logs:
Logs
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:25: debug After zwaveEvent(cmd) >> Parsed 'zw device: 11, command: 9881, payload: 00 31 05 01 22 00 EA ’ to [‘name’:‘temperature’, ‘value’:‘23.4’, ‘unit’:‘C’, ‘isStateChange’:false, ‘displayed’:false, ‘linkText’:‘Fibaro Smoke Sensor’, ‘descriptionText’:Fibaro Smoke Sensor temperature is 23.4°C]
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:25: info Executing zwaveEvent 31 (SensorMultilevelV5): 05 (SensorMultilevelReport) with cmd: SensorMultilevelReport(precision: 1, scale: 0, scaledSensorValue: 23.4, sensorType: 1, sensorValue: [0, 234], size: 2)
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:25: debug command: 98 (Security) 81(SecurityMessageEncapsulation) encapsulatedCommand: SensorMultilevelReport(precision: 1, scale: 0, scaledSensorValue: 23.4, sensorType: 1, sensorValue: [0, 234], size: 2)
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:25: debug parse() >> zwave.parse(description)
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:25: debug parse() >> description: zw device: 11, command: 9881, payload: 00 31 05 01 22 00 EA
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:15: info Sending secured command: SensorMultilevelGet(reserved110: 0, reserved212: 0, scale: 0, sensorType: 1)
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:15: info Sending secured command: ConfigurationSet(configurationValue: [0, 30], defaultValue: false, parameterNumber: 20, reserved11: 0, scaledConfigurationValue: 30, size: 2)
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:15: info Sending secured command: ConfigurationSet(configurationValue: [0, 90], defaultValue: false, parameterNumber: 32, reserved11: 0, scaledConfigurationValue: 90, size: 2)
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:15: info Sending secured command: ConfigurationSet(configurationValue: [0, 180], defaultValue: false, parameterNumber: 31, reserved11: 0, scaledConfigurationValue: 180, size: 2)
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:15: info Sending secured command: ConfigurationSet(configurationValue: [7], defaultValue: false, parameterNumber: 2, reserved11: 0, scaledConfigurationValue: 7, size: 1)
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:15: info Sending secured command: ConfigurationSet(configurationValue: [7], defaultValue: false, parameterNumber: 3, reserved11: 0, scaledConfigurationValue: 7, size: 1)
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:15: info Sending secured command: WakeUpIntervalSet(nodeid: 1, seconds: 21600)
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:15: info inside commands: [WakeUpIntervalSet(nodeid: 1, seconds: 21600), ConfigurationSet(configurationValue: [2], defaultValue: false, parameterNumber: 1, reserved11: 0, scaledConfigurationValue: 2, size: 1), ConfigurationSet(configurationValue: [7], defaultValue: false, parameterNumber: 2, reserved11: 0, scaledConfigurationValue: 7, size: 1), ConfigurationSet(configurationValue: [7], defaultValue: false, parameterNumber: 3, reserved11: 0, scaledConfigurationValue: 7, size: 1), ConfigurationSet(configurationValue: [0, 30], defaultValue: false, parameterNumber: 20, reserved11: 0, scaledConfigurationValue: 30, size: 2), ConfigurationSet(configurationValue: [1], defaultValue: false, parameterNumber: 21, reserved11: 0, scaledConfigurationValue: 1, size: 1), ConfigurationSet(configurationValue: [0, 180], defaultValue: false, parameterNumber: 31, reserved11: 0, scaledConfigurationValue: 180, size: 2), ConfigurationSet(configurationValue: [0, 90], defaultValue: false, parameterNumber: 32, reserved11: 0, scaledConfigurationValue: 90, size: 2), BatteryGet(), SensorMultilevelGet(reserved110: 0, reserved212: 0, scale: 0, sensorType: 1)]
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:15: info Sending secured command: ConfigurationSet(configurationValue: [2], defaultValue: false, parameterNumber: 1, reserved11: 0, scaledConfigurationValue: 2, size: 1)
db8c3711-4b8a-48eb-9feb-9da376118151 09:54:04: debug Updated with settings: [smokeSensorSensitivity:Medium, zwaveNotificationStatus:all notifications, visualIndicatorNotificationStatus:all notifications, temperatureReportInterval:5 minutes, temperatureReportHysteresis:1, lackOfZwaveRangeIndicationInterval:15 minutes]

FIXED FIBARO SMOKE SENSOR DEVICE HANDLER

As the original device handler seems not to be working properly, and haven’t give a chance to update the sensor:

  1. I used “poisike” tip and removed the check for MSR datavalue:
    if (!isConfigured() && getDataValue(“MSR”)?.startsWith(“010F-0C02”))

so the configration is being send properly now. Tip: remember to click the button on the sensor after you update the configratuion in UI.

  1. updated the default values based on the spec from here, as not all them was proper:
    http://manuals.fibaro.com/smoke-sensor/

  2. added configuration for wakeup interval. Minimum is 70 mins based on the spec.

The device handler can be downloaded form here:

Feel free to testm, share and let me know if it works for you.

1 Like

Can we make smoke sensor to work as siren for security?

No, as it is not possible to trigger it on fibaro smoke sensor. The simply don’t give such option.

Is there any way to link sensors together?
If one detects smoke one or all of the others will sound as well?

This is more or less the standard today, but it seems to not be possible with the fibaro one?..

Even 20USD sensors will do this…

If there would be a way to trigger siren manually then there would be lot of different ways to link sensors.
Red manual and it says:
“13. Alarm broadcast
A value other than 0 means that alarms are being sent in broadcast mode, i.e. to
all devices within a Fibaro Smoke Sensor’s range.
Available settings: 0 - 3
0 – broadcast inactive
1 – SMOKE ALARM command broadcast (2-nd & 4-th Association Group) active;
casing opening notification broadcast (3-rd & 5-th Association Group) inactive
2 – SMOKE ALARM command broadcast (2-nd & 4-th Association Group) inactive;
casing opening notification broadcast (3-rd & 5-th Association Group) active
3 – SMOKE ALARM command broadcast (2-nd & 4-th Association Group) active;
casing opening notification broadcast (3-rd & 5-th Association Group) active.
Default setting: 0 (broadcast inactive)
Parameter size: 1 [byte]”

Btrial seems to be the man who knows lot about this. I’m using this device handler:

It’s only one that is working for me. Others was recognized as flood sensors etc and couldn’t get them work. I do not have broadcast settings included in device handler and I do not have led settings.
Could it be possible to add these settings to your device handler?

From another topic:

“You can use Z-wave tweaker to do this. Change the device handler to Z-wave tweaker. set the option and then change it back to the smoke detecter.”

I have to test this and see if it works. ATN1 you should too.

I’m sorry but… what? :slight_smile:
Whats this going to do?

Activate option to broadcast alarms. If I got it right you asked is there a way to link sensors together so that when one senses smoke it broadcasts alarm to all sensors.
I did not test this yet.

I’m not sure how to activate the setting :roll_eyes:

Im not 100% sure too but I suppose we should proceed like this:

  • update fibaro Smoke sensors to latest firmware. Update is possible to do as OTA according Fibaro manual but ST hub does not support OTA updates to z wave devices.
  • after fw update fibaro Sensor(s) device handler should be changed in ST to z wave tweaker.
  • then from tweaker there should be option to change broadcast settings.
  • after setup change device handler back to what ever you used earlier.

And done.

Has there been any progress on making broadcasting work?