Fibaro Smart Implant

You should be using the latest from Github, do you have all 6 groovy files in your IDE?. I made the fix in the fibaro-smart-implant.groovy file. If my fix was right, it should detect implants from all regions.

Yours should be the CEPT (Europe) version, so you should see something like this in the Raw Description section of the device:

zw:Ls type:0701 mfr:010F prod:0502 model:1000 ver:5.01 …
1 Like

Hi.

Massive misunderstanding it seems. I only installed one of the groovy files, didn’t realise I needed them all. Oops.

Removed the old one, reinstalled all 6 from code, tried to re-add the implant, picked up immediately and correctly, pressed on the button to add the child device for temp - all good !

Thank you so much!

Now if I could just figure out how the hell my 2 spare UBSs won’t install, I’ll have all the sensors I need.

Much appreciated !!!

Hi Ovidiu Pruteanu

Thanks, now it works :-). But have a problem with input, when relay on input has been open for more than an hour, status switches to closed.

@flth1968 I configured one of my implants to “Normally closed alarm input”, I’ll let you know what I find in an hour.

Is yours configured as normally closed or normally open? Have you tried the refresh button in the alarm child device, does it change the status back to open? What values do you have for parameters “150. Input 1 - sensitivity” and “151. Input 2 - sensitivity”?

Hi Ovidiu Pruteanu
So grateful that you bothered to help.
20 + 21 = Normallly closed alarm input
150 + 151 = Default 10 (100ms)

@flth1968 Good news, I was able to replicate the problem. After exactly 1 hour both inputs switched to closed. I suspect it has to do with parameters 152, 153 - delay of alarm cancellation, which I have not included in the settings page. The manual says the default is 0 (no delay), so the status should not change by itself. I will investigate further.

@Ovidiu Pruteanu Thank you very much.
Bought 4 more yesterday as it seemed to work. Will use one on my freezer, magnet contact for the door, DS18b20 for temperature inside and a cheap buzzer on the output for freezer alarm.
looking forward to hearing if you find a solution

I tried everything and no matter what settings I choose it keeps changing from open to close on it’s own. I posted on the FIbaro forum, if we don’t get an answer there I’ll try to contact support.

Have you heard anything, really hope there is a solution. If it works then it becomes popular as a garage door control

Does anyone have any idea how long a 9 volt battery would last connected to the Smart Implant with one DS18B20?

Thanks in advance

@flth1968 I have submitted a ticket 3 days ago but they have not responded yet.

@makito The implant consumes about 20mA at 9V and a 9V battery has about 500 mAh so it would only last 20-30 hours. It was not meant to be battery powered since it’s always on and it also acts as a z-wave repeater.

@ovidiu.pruteanu thanks for the quick response. I have another idea which is probably crazy but thought I’d ask for opinions. I am planning to use my setup to monitor my hot tub temperature. I plan for my hot tub to only receive power for 8 hours a day. I am wondering if I used th 12v lighting circuit from my hot tub connected to a small 12v battery such as one from a UPS and then connected that to the Smart Implant if that would keep everything charged up and running. Thoughts?

@makito I actually need the same thing (a 12v UPS) for another device I’m working on, but I have not figured it out yet, I’ll let you know if I do.

I did a quick search and it looks like Fibaro had the battery powered FGK101 Contact Sensor which supported an external DS18B20, but it’s discontinued. Maybe they still have it in stock somewhere. Here is another topic about it.

@flth1968 Fibaro Support helped me track down the issue. I had to remove the “Refresh” capability from the Contact DTH. The implant does not support it and for some reason when the hub was sending that Z-Wave command to the implant it was changing it’s status to closed.

Does anybody know how often I should receive a temperature update from the DS18B20? Is there a way to increase how often this happens?

Thanks for your work, I tested the DHT without “Refresh” capability, without this parameter the status does not change but in the NEW app the device loses the connection.

I don’t know if it’s something to do with my wiring or whether it’s software. Here’s my setup (all using the same spec wiring). In a nutshell, my central heating is controlled via a zwave boiler switch, multiple DS18b20s, and 7 zwave radiator TRVs all connected via smartthings and webcore to set heating schedules. Essentially, if front room temp is supposed to be at 22 degs at 7pm, but the front room’s probe says it’s less than 22 degs, the trv opens, the boiler fires up, heats the front room and webcore rechecks the temps every few mins until the probe reads more than 22 degs (at which point the boiler/TRV is switched off).

(All fibaro’s mounted in ground floor ‘workshop’- initially powered by a single 12v 10amp DC PSU)

  1. Fibaro UBS 1, 8m total wire running from workshop to rest of ground floor…i.e. low hallway, downstairs bathroom, utility and workshop (4 probes)

  2. Fibaro Smart implant, 12m total wire running from workshop to 1st floor…i.e. mid hallway, frontroom, kitchen (3 probes)
    image

  3. Fibaro UBS, 16m total wire running from workshop to 2nd floor…i.e. top hallway, bedroom1, bedroom2, top bathroom, top hallway (4 probes)

I’ve been having odd disconnects , but only ever with the mid floor (i.e the smart implant). The top floor (the furthest away!) has been rock solid, no problems. Now from experience, odd intermittent issues tend to be down to power issues, so yesterday I used a separate 12v 2a PSU to power the implant on the mid floor.

oops. again, a disconnect in the early hours, only solved after a power cycle this morning just after 7am. During the disconnect, all probes on the mid floor registered zero degrees (see following image, just showing the frontroom ds18b20):

Now to be honest, I generally don’t get a lot of time although at the minute I’ve got more time on my hands because of lockdown. So on and off I’ve probably been on with this project for months and now it’s just starting to feel like a huge waste of time. The amount of time and energy that’s gone into this is fairly insane, and whenever I feel like I’ve got it cracked, I’ll check in to see that the central heating has gone tits up again because the probes have randomly dropped out.

I’m wondering if there’s any chance that this is down to software, as the other two floors seem just fine (both using UBS’s, not implant).

Any feedback most welcome ! = ) I’m close to just buying another UBS (sacking off the implant), but it’d be great if I could find out what’s going on, I hate unsolved problems! =P

@makito You can change the update interval with the parameter “68. External Sensors - periodical reports”

@Ivan78 You’re right, removing the refresh capability messed it up for the new app. I don’t use the new app very often and missed it, i’ll try to fix that soon.

@djh_wolf Not sure what to say about this issue. I have 3 implants that have been running for 5 months with no disconnects, but I do live in an apartment so signal strength will never be an issue. The only thing that I can recommend is checking the route of the implant’s z-wave connection in the IDE. Also, when it disconnects does the main device appear offline, or just the DS18B20 child devices?

Signal strength is spot on, it’s right beside the hub.

The probes still don’t work, I haven’t bothered power cycling.

Here’s a few images, let me know if you need anything else - I’m not sure what I’d need to send you, but I’m happy to help.

Here’s the implant in the IDE:

…and a few of the most recent events…

Here’s the implant in the app:

Here’s one of the sensors in the IDE:

…and a few of the most recent events:

…and the sensor in the app:

If you don’t mind, could you please tell me

(a) Which PSU you use for your implant (volts and amps)
(b) How many DS18b20’s are connected
© What sort of wire you use to connect them
(d) Are you using a pull-up resistor
(e) How long is the wire… from implant to sensor

Much appreciated, everything’s on hold at the minute as I just cannot get this working reliably. And obviously at the minute, none of the UBS’s work because this latest hub firmware seems to have really stuffed everyone. That bit is a little infuriating.

Much appreciated !

a) I have different PSUs for the 3 implants (12V 500mA, 15V unknown, 12V 2A). The one with the probes connected has the 12V 2A PSU
b) Two probes connected
c) Using the wire that came with the probe, like this one
d) Not using a pull-up resistor, but it is a packaged sensor and I’m not sure what’s inside
e) 2 meters

From your screenshots it doesn’t look like it’s a z-wave connectivity issue. The main device is ONLINE and is receiving updates from the internal temp sensor and the probe device is OFFLINE. So, it’s either a software issue, or the implant is loosing connection with the probes.