Fibaro Smart Implant

Scratch that. The device’s status is ONLINE, but it doesn’t look like it’s receiving updates from the internal sensor.

Thanks for the replies.

I’ll try connecting the probes at a shorter distance, powered by a single 12v/2a PSU, and see if that helps. It’s frustrating, because I need to literally wait up to a full day before I see if it continues to work. The amount of times I’ve reconfigured something and thought “aha! that’s fixed it!” only to find (as in this instance) the next morning, it’s knacked again.

Much appreciate your responses. Cheers!

I’m trying to implement a ZWave device to open my door lock from the intercomm button. With the smart implant can I program to close the circuit and trigger the door lock?

When someone is at the door and push the call button, a buzzer turn on (chime), can I use this device to trigger a switch in smartthings?

Thank you in advance.

Gate Integration

I would like to use implant to allow me to open/close my electric gate. Currently the gate is controlled by a telephone interface (Videx ART 380).

Reviewing the interface manual (extracts below), would i be correct in thinking Implant ‘INI1’ should connect to ‘NO’& Implant ‘GRD’ to ‘C’, with the two wires i removed from the telephone interface connecting to Implant ‘OUT1’

Second question (not essential), could i connect Implant ‘INI2’ to ‘6’ to get a notification when the call button is pressed?

Any assistance would be appreciated.

Thanks in advance

image

1 Like

I’ve just tried to remove the device in order to re-add with a single 12v/2a PSU and 4 probes connected very close by, no extensions in order to troubleshoot.

Here’s what’s now happening. I think this firmware release (for the hub) has broken even more things than first suspected, it’s really a piece of crap. Grr…

Manages to add the implant again as planned, but hub won’t let me delete the old one.

4 probes picked up no issues. I’ll leave it alone and see if it drops out again. The way it was (for me) ranged between a few hours and a few days before failing. So difficult to tell.

Also, appears my posts have been deleted in the main thread reporting these problems, presumably by the smartthings staff. It really does just keep getting worse.

Well, I don’t want to jinx anything, but right now, separate PSU (12v/2a as planned) and short cable runs… 4 sensors have been functioning for around 24hrs so far. I’ll continue to leave it and make sure it continues to work before jumping for joy and moving some wiring around.

Oddly enough though, the fibaro UBS (which is obviously currently unusable) has been relatively rock solid with the longest run to the top floor with 4 sensors. Which caused me to believe that the implant here should have been fine with the shorter runs. Odd.

We got new hub version and that is not helping. Hope you have some clever idea to keep sensor states stabile after a hour.

This probably isn’t linked to anything to do with the DTH, but I’ve messed about with this for way too long.

Current situation:
Fibaro ubs x 3, runs between 10 and about 25m…all rock solid for days and days.

Implant, short run, rock solid (as post above).
Moved the wiring from test position (close) to psu - > implant distance approx 10m. Implant to furthest probe distance around 7m. Rock solid, about 2 days maybe.

Here’s the thing. Absolute reproducible problem. If I run a 3v psu wire close by (connected to a motion Sensor) …fibaro INSTANTLY stops reading temps, stops updating. Shows the last temp forever.

Sometimes it’s possible to get it going again by removing the nearby 3v power, whereby the fibaro then catches up and reads the temp again, carries on as normal. Sometimes the fibaro needs a power cycle to catchup. Other times the probe will report as a zero degrees, and I can’t find of a way to recover short of rebooting and re setting up the fibaro and probes from scratch.

Odd, but definitely reproducible. It’s got to be down to power or interference or both.

Hi I’ll be receiving my Smart Implants tomorrow and hope to enjoy experimenting with them. I’ve read all the entries in this thread but haven’t seen step-by-step instructions about how to install the device handler (sorry newbie) and then have the Classic App recognize the Implant. Can somebody provide some guidance? Thank you

Just to be complete, it seems the issues were down to cable length and voltage drop. I’ve now replaced my setup with seperate power supplies and also used thicker wires.

Plus, instead of having psu - > short run - > fibaro - > long run -> sensors, I now have…

Seperate psus - > long run - > fibaro - > short run -> sensors,

At the minute it’s Rock solid. So I’m curious as to whether replacing the seperate Psus with the single beefy one again would actually be OK or not.

Sorry, just saw this. Did you get sorted?

I wired mine up with 2 temperature probes, enabling me to chart the output using Influx+Grafana. At first the Smart Implant did not respond (no brief green LED) when using my universal PSU at 12V with <1 amp, but came up when I switch to 9V with 1A+.

Thank you for the follow up. Yes I successfully installed the device handlers and was able to pair the Implant Sensors in SmartThings (once I improved on my triple-click technique!).

I find that the internal temperature probe is about 7 degrees off. I ordered some DHT-22 sensors, with hopes that they are more accurate.

1 Like

I would like to use this for my garage opener:

Is it just a case of connecting the yellow or green to +ve, and blue to -ve connectors to the right of the picture, and then set IN1 or IN2 as a momentary switch in the ST app?

Thanks in advance

More help please. I would like to use this as a Power Loss Monitor and receive alerts when it goes off line due to having no mains power. How to set up please?

I find that the temperature probes lose the temperature reporting capability and I have to remove the FSI and add it back again which is a right PITA but invariably I lose the temperature reading from the probes.

Here working as they should:

When power is lost I sometimes get “Unavailable” notifications from the probes but not the FSI itself:

But invariably I get zero reporting whether powered or not:

In the IDE when I delete and add a probe back under FSI I get this also reporting zero:

So when the temperature probes are online and appear online they are not reporting temperature other than 0.

What could be wrong please? How to resolve?

Thanks

I had a similar problem. For me it was a combination of two things.

  1. Inadequate psu
  2. Inadequate wiring / distances.

Right now I have 4 fibaros with a total of 14 temp sensors between them. All running rock solid, each powered by seperate 12v/2a psus. The distance from the fibaro units to their psus range between 5m and 15m. The distance from each unit to the farthest connected sensor is now about 10m.

For wiring, I had lots of cheap 8 core multicoloured alarm wire. I initially used 2 cores (live/neutral) to power the fibaro (wanted to use the other cores for other things to save on cable runs), but found that this still gave occasional unpredictable issues. Since instead continuing to use the 8 core but combining 4 of each together for live/neutral (messy I know, but cheap and available), it’s been solid.

This I must stress, is after a LOT of aggro.

Now… As a test, I tried running them all off the same psu once more last night. Bam. Unpredictability. Sensors look functional but don’t update. Or maybe one sensor out of 4 actually gives a non-zero result when powered on and then continues to work with 3 remaining at zero. Sensors work and update but at some point just stop updating (but you don’t know that unless you check the last activity logs). Or they’ll sometimes update, but maybe for for 20 mins. The problems are endless. Which is why it took me so long to figure all this out, just… Randomly screwing up in wonderful ways.

So… All the fibaros back onto one big Psu… Massive problems straight away again last night after days of rock solid functionality.

Which means I’m (as I suspected) moving back in a sec to all seperate 12v/2a psus.

Hope that helps.

Thanks for that. I tried a separate 5V PSU for the temperature probes (with only the white signal line connected to the FSI) but it did not work.

This was with a single 12V 1.5A PSU.


so I kept this configuration only to lose the temperature readings after about 4 hours. I’m going to reset and try again.

Another question - I would like to use the FSI to trigger a garage door opener using OUT1 without a wired button. How to configure this under the FSI “Thing” under the Thing/Devices in the ST app?

Thanks in advance.

when i said separate psu’s, i meant one psu per fibaro. sensors still being fed from fibaro, not drawing their own power. I’ve never tried that.

Initially (and right now, which is still giving issues) I had all the fib’s powered by a large 12v 10a psu. issues then, issues now. splitting back to seperate 12v/2a psu’s now. It was just a curiosity thing I moved back to the single ‘beefy’ supply. I hoped it might have been fine after altering the wiring and distances, but it clearly wasn’t.