Fibaro Motion Sensor v3.2 Help

fibaro
motionsensor

(Not for public consumption) #1

Hey folks, I am trying to configure this device - and Refuse to let it beat me.

I am using the v2 UK hub, and the EU/UK v3.2 device.

I have tried the Fibaro Motion Sensor ZW5 handler… and it works.
I would like to change a few of the parameters.

As a pure test i would like to just disable the tamper detection (as this is very easy to check if its worked… just shake it). In the Manual this is Parameter 20, its a single byte value - and from what the manual describes setting it to 0 should disable any notifications for tamper.

So due to the template for Fibaro Motion Sensor being the old version (non 3.2) i found this code.

Which i believe is the latest code for the v3.2 device.

Now the next step is where i am confused, i have seen this code setup in multiple syntax variations.
This is the code i would like to use.

cmds << zwave.configurationV1.configurationSet(configurationValue: [0], parameterNumber: 20, size: 1).format()
or
cmds += zwave.configurationV2.configurationSet(parameterNumber: 20, size: 1, configurationValue: [0])

configurationV1 <-- should this be V1 or V2.
configurationValue and ParameterNumber, Is also swapped in the above line of code. Does this matter?

Finally where to add the code above.
From what I’ve read it should be in the: def configure() { } block but does it matter where within this?

Any help would be appreciated, as all the other device handlers outside of the official one have given varying degrees in working.


Fibaro Motion Sensor - New device-handler with all settings and auto sync feature
(Not for public consumption) #2

Updating my own thread for other peoples benefit.

cmds += zwave.configurationV2.configurationSet(parameterNumber: 20, size: 1, configurationValue: [0])
The above syntax is the correct one for v3.2 UK version (can’t comment on US version - guessing its the same).

The method i used which seems to be simple and works.

I have the Fibaro motion sensor found by the hub and use the default Fibaro Motion Detector ZW5 handler from the configure menu on the mobile app.
In the IDE interface: I then copied the above code from GitHub and created a new device handler “from code” (changing the name "definition (name: “Fibaro Motion Sensor ZW5”, to: "definition (name: “Fibaro Motion Sensor ZW5 Tweaked”,)
I then Saved and Published (for me option).

Then using the simulator (right hand side of the code in your IDE window) selected Home (my hub) then selected the fibaro Motion Sensor ZW5 from the device list and clicked the “install” button (below the devices list). This then installs the new code to the device (replacing the default one).

From here you can see the motion and vibration options changing in the GUI and logging window below.
At this point i then copied and pasted the following:
cmds += zwave.configurationV2.configurationSet(parameterNumber: 20, size: 1, configurationValue: [0])

i placed this under the following: (towards the bottom of the bottom of the code)
cmds += zwave.wakeUpV2.wakeUpNoMoreInformation() <— pasted under this.

You then save and publish again, (this resets the simulator) you must then goto the simulator again, choose your hub, then choose the fibaro device, and install.
Next i then triple clicked the fibaro v3.2 button at the back and pressed the “configure” button on the simulator.
From what I’ve read you have upto 15 seconds to press the configure button from the time you wake up the motion detector (by pressing the back button three times).

To confirm the above worked i shook the device (as i had just turned off the tamper/vibration reporting) and no LEDs flashed (like they did before) and no report/change in the tamper button on the simulator interface,

I’ve since tried a few other parameters and all seem to have stuck and work (good one to test is parameter 80, setting do configurationValue: [21] - makes the sensor LED flash RED on motion. I hope this helps someone else as i wanted to throw the little ping pong looking motion detector through the window more than once before doing the above.


(Not for public consumption) #4

True although all the settings in that post used v1 not v2 which didn’t seem to work for me.


(Ross Mc Carthy) #5

Great post. Excited to get home and see if this works. I’ve been weeks trying to turn of the LED on my 3.2 sensor. Thanks a million for posting.


#6

Try this


(John Camerin) #7

Appreaciate the post. I had read many other posts about changing the settings and different device drivers and none worked, probably because they were deprecated by v3.2 When I found this one and tested changing the LED color on motion, I was ecstatic because it worked and I thought I finally had the answer. I then went about collecting all of my config customization for a single update and then the trouble started. I change the LED motion color again (as suggested to confirm the changes had taken), published, installed in the simulator, and configured. Unfortunately for me, the LED color did not change and as best as I can tell, none of the other changes took either. I assumed I made a mistake or had a syntax error. So, I started over with a fresh copy of the default driver and tried to change just the LED motion color again, publish, install, wake, configure. But I got no change. I have tried about 20 times, and I cannot seem to update the device again. Any advice? Maybe some detail I missed? Anyone else run into this?


(Robin) #8

Parameters are updated within the device preferences page in the ST app.

You shouldn’t need to change anything in the IDE???


(John Camerin) #9

Thats exactly what I would have hoped for and would be ideal, but I do not
see a place in the app to view or update parameters. Is there a custom
device driver or an update to the default driver to enable this? Attached
is a screen shot from my app for the motion sensor using the default device
driver.


(Robin) #10

Click on the cog icon, top right of the page you screenshot above.


(Robin) #11

Hang on… Are you just using the defult handler???

You need a custom handler to change the parameters… I’ll post the link to the one I use later when I get home.


(John Camerin) #12

Yes, default SW5 handler for v3.2 of the device. Appreciate the help!


(Robin) #13

Apologies… Turns out I’m using the older version lol… So my DH won’t work for you.

The ZW5 handler is at the top of the thread linked to in post 5 above by @CSC

With this custom handler you should be able to update params from within the ST app via the device preferences page.


(John Camerin) #14

Thank so much! Frustrating that neither SmartThings or Fibaro will publish an official driver that allows the sensor to be configured.


(Robin) #15

ST like to dumb everything down… They seem to have a ‘make it suitable for grandma’ business model lol!!


(John Camerin) #16

Thanks for all the help. I’ve been trading emails with ST support. Ultimately, they don’t really support the current version of the device, particularly when it comes to the “features I bought this device for” ( their words). At one point they advised me to buy the Fibaro Home Controller to configure my motion sensor. WTF?!!
I wish either of these two manufacturers would own up and make the distinction on the device versions and lack of support for v3.2 of the device


(Slimshizn) #17

Any changes for this device yet? I bought two of them and I’d like to use them as everyone intends to.


(Bob) #18

These devices are fully configurable using csc’s device handler.
Its what i use.
Do need some guidance?


(Slimshizn) #19

Yes please, I have added the DH and now the devices have the pending status on the app. What are my next steps, I’m having difficulty finding them. Thank you!


(Bob) #20

First change the configuration settings to what you want.
If the led is set to ‘blink’ I always change parameter 80 to 0 which turns it off. (From memory). This way I know if the configuration has been taken.
Press button ‘b’ 3 times quickly and the led glows blue. This means the device is in configuration mode.
Now press the configure button in the ST app for the device.
It should take the configuration.
If the led doesn’t come on with motion you know the configuration has been taken.
Give that a try. There is also another way but its more complicated.


(Slimshizn) #21

Thanks bobbles, I’ll give that a go and report back. I appreciate this very much.