Fibaro Motion Sensor any good?

I am interested in getting this motion sensor

Does anyone have one of these ? I would like to know how folks like it from ST community.

How is the battery life ?
Looks like it can’t be plugged in like Aeon Sensor can is this true ?
Does it work well with ST ?

How creepy is the eye look ? :smile:

Is color of eye controlled by ST ?

Please do a search on the forums. Many conversations have occurred on this device.


seems good

correct, it cannot be


not at all. The advertising is misleading on how it looks. Find a video showing it “in action” to see it.

it’s controlled by temperature.

Then mine will always be the same color temp doesn’t change much in Hawaii.

Can it be changed to be controlled by anything else ?

google for “fibaro motion sensor manual” - there are tons of parameters that can be changed. I don’t know off the top of my head if you can control the color via anything other than temp.

I had but didn’t see much in the way of experiences from folks that had one. Sorry if I missed posts with my answers.

Okay, so the way the LED works is that it doesn’t stay on. It only comes on in reaction to either motion or tamper/vibration. You can turn off the tamper, or leave it on (where it flashes red/white/blue for a second.)

For motion, the modes are:


depends on temp.

glows white for 10 seconds

or pick one of the following colors (blinks in response to motion): white, red, green, blue, yellow, cyan, magenta.

There are various modes for longer or shorter blinks, but that basically covers the options.

One thing you have to remember with this is that the motion sensor isn’t always awake to accept commands, so you can’t send it commands to change color anytime you want. You’d either have to manually wake it up (by pressing a button inside of the device), or modify the device type to send the color configuration during the “wake up” event that happens every 2 hours or so.

Generally, you set it however you want, and leave it alone.

@Ron all the goodies and baddies here…including the structure/schematic diagram of @wackware’s brain…

Pre-release of Fibaro Motion Sensor


You are the first person to publicly recognize I have a brain. You’d think that there was some sort of badge for that.

@April, can you fix him up?


@wackware Come on! That’s a no brainer! :wink:

1 Like

@garyd9 Have you tried changing the LED Modes ?

I enhanced the device code for this sensor since it doesn’t have the ability to configure anything built in. You have to write a smart app to adjust it so I figured I might as well just modify the device.

I added the following to the configure method but it isn’t working at all. I have a preference I added with an enum for Off and On. The debug log shows it is entering the code to send the signal to set the LED to mode 0 which should be off.

if (ledOnOff == "Off") { log.debug "Setting LED off" // 0 = LED Off signal mode cmds << zwave.configurationV1.configurationSet(configurationValue: [0], parameterNumber: 80, size: 1).format() } else { log.debug "Setting LED on" // ToDo Add preference for other available Led Signal Modes cmds << zwave.configurationV1.configurationSet(configurationValue: [10], parameterNumber: 80, size: 1).format() } cmds << zwave.configurationV1.configurationGet(parameterNumber: 80).format()

With this not working I tried adding a tile to call listCurrentParams. The debug statement prints but none of the parameters are ever reported by def zwaveEvent(physicalgraph.zwave.commands.configurationv2.ConfigurationReport cmd) {

but I notice that report is V2 and get is V1
cmds << zwave.configurationV1.configurationGet(parameterNumber: 1).format()

I am wondering if configuration should be v2 ?

Another thought…since this is a batter device do you have to wake it with the B button before you send config ?

I tried the v2 config set and it doesn’t work.

I can’t figure out how to set parameters at all…I tried waking with b button press but this doesn’t work either…

UPDATE: Figured it out. 1) get close to SmartThings Hub 2) Pres B button to wake device 3) Select configure to send zwave param messages.

I find the list param also needs to be close and you need to wake the device. It is only reporting some of the parameters I think it doesn’t stay awake long enough to get all the messages because of the delay between each. I need to play with that a bit.

Glad you figured it out… On these, you have to wake it up (triple click on b button till solid blue diode) to update the prameters. Or, if you excluded the device…reset and rejoined the network, configure should have kicked in as far as I know.

Can you post the updated device code when you are done? I would like to disable the LED on some of my fibaro motion sensors.

Sure …

Just set the prefs for the LED and the Tamper LED to off.
Then tripple click the B Button which will display blue. Then select “configure” in the device tiles.

That should do the trick.

Great! Thank you. I’ll try it out later today.

Thanks for working on this and adding the option to turn off LED. Only issue is that I now see the option to turn off LED but the action does not seem to be working on the device and still flashes when it see motion.

Thanks again for working on this.

Did you press the b-button inside the sensor three times to get it listening to zwave and then select configure from the device tiles ?

Thanks, that worked great.

Now I just need the Lux to show correctly.

Thanks again for the help

@simjas79 What issue are you having with lux ?

Are you trying to get it to report lux settings more/or less often ?

If so there is a parameter #40 called “Illumination report threshold” which can be a value between 0-65535, the default being 200 (lux). Meaning the lux needs to change by 200lux before it reports. I imagine that saves battery. I can add that as another preference if you are interested. NOTE:0 = do not report

Lux is logarithmic so having a fixed change amount seems strange to me. I guess you have to know your environment. Inside 200 is likely a good range, outdoors something like 20,000 - 50,000 is better.

Honestly having a fixed lux change setting seems wrong to me. I think they should have sensitivity settings and some logic that determines change required to report based on current setting. In other words it should report at 20lux intervals from 1-200, 50 lux at 200-1000, 1000 lux from 1000-10,000, etc… But of course we have no control over this :slight_smile:

There is also a illumination report interval in seconds which report even if light doesn’t change. The default is 0 so no reports unless the above threshold changes.
This is likely another good parameter to add to my preferences.