Fibaro Motion Sensor Uses


(SFBayArea) #1

Ok, I got my Fibaro Multi Sensor yesterday. Few things I can’t figure out:

  1. According to the manual, I should be able to change via advanced settings different thresholds and colors. However, I don’t see how I can get to the advanced setting to make any changes.
  2. I honestly don’t see much use for it (I know I ordered it), except simply turn on the lights if it detects movement in the dark and turn lights off after some time. What else can you use it for?

(Ron S) #2

Tons of info in here…


(Joe) #3

I use this device type. It allows you to make all of the advanced changes within the smartThings App.

I use luminance levels to change modes and run Routines. My house is situated in a way where the sun blazes in the front windows at sunrise and in our back windows at sunset. We also have a second floor that gets sun mid day. So I have 1 sensor in each location to track which rooms need light when I enter and which rooms don’t. I also set a “Gloomy mode” if all 3 of them are under a certain level. With Gloomy Mode, I change my hue lights to a more cheery color.


(SFBayArea) #4

So FibaroMotionSensor Groovy lets you do “advanced” configuration of the device?
I should add FibaroMotionSensor Groovy to the “Device Type” not “My Smart Apps” right?


(Ron S) #5

@Mike_Maxwell, @garyd9, @ron and several others created custom device types to exploit the full potential of the sensor. @twack was the guru.

The one @Keo linked and others have specific how to instructions. I tweaked mine 10-11 months back. I am sure Keo can point you the latest version which is the easiest to configure. Don’t blindly pick up any particular version.

So, basically you need to create a device type in the IDE based on whichever version you want and follow the instructions for whichever version you are picking.


(Ron) #6

Since I was tagged I figured I would share the location of my device code. This version has the most parameters implemented and I am more then willing to add parameters if you feel the need for them.

I don’t know much about the other versions. I have been happy with the way mine has been working.


(Ron S) #7

That reminds me to update mine. Haven’t been spending too much time tweaking stuff since restricted to bed last week and a half or so by my doc. :frowning: Have to wait for missus to leave for work to sneak out of bed to play a little. :wink:


(Ron) #8

What is the point of being restricted to stay home if you can’t play a little :smile: Hope you get better and get some time to play.


(Ron S) #9

Or may be I am faking it to stay at home and play! :wink:


(Ron) #10

I can not condone this type of behavior, I can participate but not condone :wink:


(SFBayArea) #11

Thank you guys. So I used Ron’s code and created new device type in the IDE. I saved it and published it to myself. What is next? I am going to the things on my phone and I simply see my Fibaro device, but I still can’t configure anything on it via ST app.


(Ron S) #12

As per Ron’s instructions (All steps and troubleshooting is in the original thread i posted. Look there for @ron’s posts.

After setting my preferences you need to do the following

  1. press the fibaro b-button three times (inside the device) a blue light should appear
    This will wake the device to receive the new settings.
  2. select configure on the smart things app for the device.

The new version of the code includes this instruction in the preferences. You can keep the version you have or update. If you update just view the code, cut/paste the new code, save and publish. No need to remove the device and re-add it. The new driver will take over. I usually make sure the app is closed and open it after publish when I do this. If not sometimes it will crash based on the changes I am making.


(SFBayArea) #13

So it looks like I need to Exclude Fibaro first and then Run the Add A New Device again from the ST?


(Ron S) #14

If you are already included you don’t have to do it again. You have to follow @Ron’s instructions to push the preferences that you set by waking up the device as he says… There should be b-button inside the device. Bring your Fibaro very close to the ST hub, triple click on the b-button, you should see the Fibaro wake up (solid blue neon) and hit configure from your ST app.

Here’s a screenshot with the configure button. The screen may be different for you as I use a different device type.


(SFBayArea) #15

Aaaa, got it. So once I hit the configure button, it will take me to Ron’s device type configuration app?
Will try it when I get home tonight.

Thank you!!!


(Ron S) #16

You have to wake up the device though. Just take a moment to read his instructions before going all out. Curiosity kills the cat! And it’s a Cat’s eye you are dealing with. :smile:


(SFBayArea) #17

That is the thing, you refer to the instructions, and based on the link provided to the app code, I did not find any instructions there. I guess, that is why I am asking all these questions.


(Ron S) #18

Here’s where @Ron enters the scene:


(SFBayArea) #19

Will try it tonight.

Thanks!


(Eric M) #20

Have you assigned the device type to the motion sensor in the ide? Sorry if you have, but from reading the thread it seems like perhaps you skipped this step.