Fibaro Door Sensor on ST v2 UK hub does not show temperature


#1

Hi all,

I have just purchased the Fibaro (FGK-101) door sensor. ST app can see the device but all i get is open/close and battery. Where is the temperature gauge?

I have seen some threads with custom device types and have manually tried them via the IDE but it did not work.

According to the official UK compatibility list the sensor should be fully working.

Can someone point out how to fix this?

Thanks a lot


#2

Bump. Anyone have any idea?


(sidjohn1) #3

The device does not natively support temp reading it requires a DS18B20 to be wired in to the door sensor.

If you have already done this part then all that’s left is to create a new device handler from the Fibaro Door/Window Sensor template and comment the lines that say:
//UNCOMMENT ME IF NO TEMP INSTALLED and un comment the lines that say:
//COMMENT ME OUT IF NO TEMP INSTALLED

save, publish and attach the new device handler to your device and wait for the temp to update itself.


#4

Heu @sidjohn1 thanks a lot for getting back to me on this one. I had figured out that i need the extra sensor. I decided to return my Fibaro door sensors and stick to SmartSense ones because of the smaller size and acceleration sensor built in.

Overall, i think i like Zigbee things more than Z-wave ones, even though Z-wave is way more popular/reusable.


(David Tucker) #5

Also worth pointing out that the Fibaro door sensor can alternatively be used as a binary sensor - just by attaching outputs from some other sensor/circuit that may not be able to otherwise communicate with SmartThings.

I use one to connect to the outputs of a wired smoke alarm system, so SmartThings can notify me of any smoke alarm trigger when I am not at home. This was way cheaper than buying multiple Nest protects or z-wave smoke sensors.


#6

Did you get the temperature to work.
I tried and it didn’t work.
Had to correct mistakes in the device code to get the tamper to work and to get temperature to at least show the icon, but there is no temp showing and nothing on debug to show there is a temp being passed.

Have installed the probe but to. I avail!
Given tamper didn’t work due to using wrong name, I don’t trust the code.


(Mark Povolo) #7

Has anyone got the temperature working