Fibaro door sensor always shows open


(Joe) #1

I paired my Fibaro door sensor and the state never changes. It always reads open. Has anyone else had this problem?

I’ve already tried to remove and pair it again.

Here are the logs

4:14:34 PM CDT: debug parsed 'zw device: 20, command: 2001, payload: 00 ' to []
4:14:33 PM CDT: debug parsed 'zw device: 20, command: 2001, payload: FF ' to []

(Joe) #2

I fixed the problem by loading the device type in the IDE and choosing configure.


(Ofer) #3

Hi Joe,
I am experiencing the same problem. the sensor sometimes closes, but at many cases it remains open.
How did you configure it? I cannot see a “configure” option in the app or in the IDE.

Thanks,
Ofer.


(Joe) #4

This post is over a year old. I’ll log into the IDE tomorrow morning to refresh my memory. I remember loading the device type into the IDE and then finding configure somewhere. After that it worked fine.


(Ofer) #5

Thanks.
I appreciate your help.

Ofer.


(Joe) #6

I can’t figure out where I found it now. Maybe it was there only because it was a new device at the time. You can try removing the device from smartThings then repairing it.

Did you contact support yet? I know they’ll know how to do this since they are the ones that initially tried it. You can send them a link to this post as well.


(Ofer) #7

I’ll try that. thanks for your help !

Best, Ofer.


(Joe) #8

Ok. I figured out what I did. First I created a new device type from template and then found the fiabro door/window sensor. Then I ran the emulator (or what ever it’s called to test the device type) and selected my fiabro contact sensor. After selecting my contact sensor there is a button that is labeled configure.


(Ofer) #9

thanks. at that point - do you remember what you configured differently from the default configuration?


(Joe) #10

All I had to do was run through the configuration with the defaults.


(Ofer) #11

Thanks. I will try it !


(Ofer) #12

Quick update
I am able to see the configure button in the simulator as you said.
however pressing it does not seem to be doing anything …
In parallel, I opened a case with Fibaro, let’s see what they say.

Thanks, Ofer.


(Joe) #13

When you click on configure you should see something in the log window if it’s doing anything.


(Ofer) #14

There’s nothing there.


(Joe) #15

I’d reach out to SmartThings support to see if they can help. Sorry I couldn’t help more.


(Bob) #16

When you initially paired this device, you had to push a button so that yor hub could discover it.
Push this button 3 times (probably) which will put it in to configure mode. Now press the configure button on the Web page. Hopefully this will do the trick.


(Joe) #17

THAT’S RIGHT! I Completely forgot about that step!


(Ofer) #18

sorry, still does not work for me …


(Ofer) #19

ok, press the button on the device and then the configure on the web simulator …
I did not try that one yet … I will try tonight.

Thanks !


(Bob) #20

3 times. Quickly.