Fibaro Dimmer (211) - momentary light switch fail

I’ve got a problem with how my 3 way physical on-off-on momentary switches work with my fibaro 211 dimmers. I’ve searched the forum to see if I can’t find the solution but have come up blank so this is my appeal for help.

As background I have been (unhappily) using the Fibaro HCL as my hub for past couple of years but am in process of switching over to SmartThings. I have the Fibaro 211 dimmers behind lots of 3 way momentary switches and they all work perfectly with the Fibaro HCL. One press up to turn on, hold up to brighten, 1 press down for off, hold down to dim.

I’ve registered a couple of the Fibaro 211 dimmers on to my SmartThings hub so far, they were recognised correctly and using some custom code on this forum I updated parameter 14 to 2 (3 way momentary switch setting). Checking the parameters I used on the Fibaro HCL (all the defaults basically, except para 14) against the Smartthings hub I can see they are set the same. The lights work correctly when using app but not with light switches.

The issue is if I press the up switch to turn light on nothing happens. I have to hold the up switch down for circa 3 seconds, release, then press up switch again to turn light on. The light then turns on & switch will then work normally however if I leave the switch for a few minutes it reverts back to not working and again you have to hold it down first, release, then press on.

Any ideas on how I can get my light switches working correctly? Very grateful for any assistance!

I’ve looked at the Live Logging but being a non-expert can’t see what the issue is, log copied below:

b7655b38-7323-48ed-9759-3d1c8b0f35d8 20:50:19: trace BasicSet(value: 0)
b7655b38-7323-48ed-9759-3d1c8b0f35d8 20:50:19: trace BasicSet(value: 0)
b7655b38-7323-48ed-9759-3d1c8b0f35d8 20:50:13: trace BasicSet(value: 255)
b7655b38-7323-48ed-9759-3d1c8b0f35d8 20:50:13: trace BasicSet(value: 255)
b7655b38-7323-48ed-9759-3d1c8b0f35d8 20:50:13: debug No handler for SwitchMultilevelStopLevelChange()
b7655b38-7323-48ed-9759-3d1c8b0f35d8 20:50:13: trace SwitchMultilevelStopLevelChange()
b7655b38-7323-48ed-9759-3d1c8b0f35d8 20:50:11: debug No handler for SwitchMultilevelStartLevelChange(ignoreStartLevel: true, reserved100: 0, reserved203: false, startLevel: 34, upDown: false)
b7655b38-7323-48ed-9759-3d1c8b0f35d8 20:50:11: trace SwitchMultilevelStartLevelChange(ignoreStartLevel: true, reserved100: 0, reserved203: false, startLevel: 34, upDown: false)
b7655b38-7323-48ed-9759-3d1c8b0f35d8 20:50:08: trace BasicSet(value: 255)
b7655b38-7323-48ed-9759-3d1c8b0f35d8 20:50:08: trace BasicSet(value: 255)

I used the 211 with toggle switch and like you found the physical switch stopped working until I toggled it a few times. Then going back to it after a short time it would have stopped working again. In the end I changed parameter 10 to 0 and that fixed the problem and it has worked perfect since… Don’t know if it will work for momentary switches but worth a try.

1 Like

Brilliant - they are now working correctly. Thanks very much.

Hi!

This seems to be the problem for my Fibaro’s aswell. How do I change the parameter form 10 to 0 ? On the device or the device handler? Which paramater?

Tommy

Hi Tommy
Assuming it is the Fibaro 211 and not the newer 212 dimmer you’re having issues with then have a look at this link


It will enable you to change the parameters of the 211. You could try changing parameter 10 to value 0 and see if that fixes the problem.
Not elegant coding but it will enable you to change parameter values.
Good luck