Fibaro Dimmer (FGD-211) switching problem


(sjb) #1

I’ve recently begun migrating our z-wave devices from Fibaro HC2 to the smartthings hub v2. The main problem encountered has been the behaviour of the Fibaro dimmer manual/physical switches at the wall.

Essentially it appears that when a light is off, the on switch has the effect changing the level without actually turning the light on. So a single click will set the level to 255 (= previously set level) and double-click will set it to 99 (= full brightness), but the light stays off. The only way to turn on the light is to increase the dimming level by holding the switch down, then releasing, then giving it a single press to turn it on. The same problem (and solution) exists for switching off.

I’ve pasted the event history as it has been recorded (here in reverse chronological order) in the hope that it might help with a diagnosis. The event below relate to four separate actions I took (the starting point was light off).
(1) single click (so setting it to 255), but light stayed off
(2) double click (setting it to 99), again light stayed off (i think it records the first click of the double sequence as a ‘255’)
(3) holding down the switch, dimming up. Light still stays off. Not recorded in event history.
(4) single click (to 255), but this time light comes on

So I need to carry out 3 and 4 to get the light on, but it’s not very family- or visitor-friendly.

Interestingly, and probably importantly, the on and off single click will work absolutely fine once steps 3 and 4 have been carried out, but if the light is left untouched either on or off for more than a minute or two, it will ‘relapse’, needing a step 3 and then 4 to get it going again.

I should add that the dimmers worked fine when removed from the Smartthings network (i.e. in their default state), as they did when they were part of the fibaro HC2 network. I’m using the device as published at https://github.com/SmartThingsCommunity/SmartThingsPublic/blob/master/devicetypes/smartthings/fibaro-dimmer.src/fibaro-dimmer.groovy

Would be grateful for any ideas - please let me know if there’s anything else I could share to help with diagnosis!

Event List (reverse order):
Date Source Type Name Value User Displayed Text Changed
2016-01-25 4:30:55.699 PM GMT
moments ago DEVICE /physical level 255 Landing Wall Wash Light dimmed 255 % true
2016-01-25 4:30:55.699 PM GMT
moments ago DEVICE /physical switch on Landing Wall Wash Light was turned on false
2016-01-25 4:30:48.562 PM GMT
moments ago DEVICE /physical level 99 Landing Wall Wash Light dimmed 99 % true
2016-01-25 4:30:48.562 PM GMT
moments ago DEVICE /physical switch on Landing Wall Wash Light was turned on false
2016-01-25 4:30:48.289 PM GMT
moments ago DEVICE /physical level 255 Landing Wall Wash Light dimmed 255 % false
2016-01-25 4:30:48.289 PM GMT
moments ago DEVICE /physical switch on Landing Wall Wash Light was turned on false
2016-01-25 4:30:45.034 PM GMT
moments ago DEVICE /physical level 255 Landing Wall Wash Light dimmed 255 % false
2016-01-25 4:30:45.034 PM GMT
moments ago DEVICE /physical switch on Landing Wall Wash Light was turned on true


(sjb) #2

I should add that the automated functionality is working fine - it’s just a manual switching issue.

I hope someone has some insights!

thanks


(Timothy) #3

I also have this problem. No solution yet


#4

I’ve just moved from Razberry (Rasberry Pi based solution) to SmartThings and I’m also suffering this problem.

Just wondering if anyone resolved this or knows a good workaround?


(sjb) #5

Hi richh

I managed to solve this by changing one of the parameters… but can’t remember exactly which one. From memory it did compromise the ability to gradually dim automatically? Anyway I’ve pasted my settings in the device handler below. This now works fine. Might be worth checking against your own settings.
sjb


(sjb) #6
    zwave.configurationV1.configurationSet(configurationValue: [255], parameterNumber: 1, size: 1).format(),
    zwave.configurationV1.configurationSet(configurationValue: [0], parameterNumber: 6, size: 1).format(),
    zwave.configurationV1.configurationSet(configurationValue: [1], parameterNumber: 7, size: 1).format(),
    zwave.configurationV1.configurationSet(configurationValue: [1], parameterNumber: 8, size: 1).format(),
    zwave.configurationV1.configurationSet(configurationValue: [5], parameterNumber: 9, size: 1).format(),
    zwave.configurationV1.configurationSet(configurationValue: [1], parameterNumber: 10, size: 1).format(),
    zwave.configurationV1.configurationSet(configurationValue: [1], parameterNumber: 11, size: 1).format(),
    zwave.configurationV1.configurationSet(configurationValue: [99], parameterNumber: 12, size: 1).format(), //reduce (eg 50) for LED
    zwave.configurationV1.configurationSet(configurationValue: [2], parameterNumber: 13, size: 1).format(),
    zwave.configurationV1.configurationSet(configurationValue: [2], parameterNumber: 14, size: 1).format(), // 2 for 3 position momentary, 0 for 2 position
    zwave.configurationV1.configurationSet(configurationValue: [1], parameterNumber: 15, size: 1).format(),
    zwave.configurationV1.configurationSet(configurationValue: [1], parameterNumber: 16, size: 1).format(),
    zwave.configurationV1.configurationSet(configurationValue: [0], parameterNumber: 17, size: 1).format(),
	zwave.configurationV1.configurationSet(configurationValue: [0], parameterNumber: 18, size: 1).format(),
    zwave.configurationV1.configurationSet(configurationValue: [0], parameterNumber: 19, size: 1).format(),
	//Param 20 is different for 50Hz or 60 Hz uncomment the line that will reflect the power frequency used
	//zwave.configurationV1.configurationSet(configurationValue: [101],   parameterNumber: 20, size: 1).format(), //60 Hz (US)
	zwave.configurationV1.configurationSet(configurationValue: [110],   parameterNumber: 20, size: 1).format(), //50 Hz (UK)
	//zwave.configurationV1.configurationSet(configurationValue: [134],   parameterNumber: 20, size: 1).format(), // LED flicker control setting 134-140
	zwave.configurationV1.configurationSet(configurationValue: [3],   parameterNumber: 30, size: 1).format(),
	zwave.configurationV1.configurationSet(configurationValue: [600],   parameterNumber: 39, size: 1).format(),
	//Param 40 not needed by SmartThings
	//zwave.configurationV1.configurationSet(configurationValue: [0],   parameterNumber: 40, size: 1).format(),
	cmds << zwave.configurationV1.configurationSet(configurationValue: [0],   parameterNumber: 41, size: 1).format()

#7

Thanks, I changed parameter 10 to 0, which means now the wall switch is working. If I change to any other value to wall switch stops working.

As you said though, it means I’ve lost the nice dim up/down functionality.

Anyone managed to get it working also with the dim up/down functionality?

I’ll take a closer look at your parameters, I think 10 and 14 look different from my configuration.