Fibaro dimmer 2 shows as socket icon


i have just starting with the ST.
now i added a fibaro dimmer to the hub.
But the dimmer shows up as a socket icon ? -> solved under settings button

i have downloaded the code from githuib and added this in my device handler.
but nothing changes.

is there a way to change the icon ? -> under settings fucntion :-1:)

also the dimmer is not fuctioning properly.

Tank you :slight_smile:

Hello robin,

i did al that the fibaro is not reponding
i see power consuption used power etc…
but the switch is not reacting on any commands.

energy: 86.48 kWh
power: 19.0 W
fault: clear
logMessage: ERROR: parse(): Unknown Error. Raw message: Err 106: ZW secure inclusion failed
energyLastReset: 2018/02/01 21:22:50
syncPending: 3
nightmode: Disabled
dispPower: 19.0 W
dispEnergy: 86.48 kWh

some error in the device tap i will try to exclude the sensor and add it again

Hello robin,

i excluded the device with
Tap More
Tap the Hub
Tap Z-Wave Utilities
Tap General Device Exclusion
Tap Remove
When you see the message “Please follow manufacturer’s instructions to remove the Z-Wave device from My SmartThings,” perform the required exclusion process (e.g., pressing a button on the device)

clicked 3 times button B

then started from scratch, now all seems ok.


1 Like