SmartThings Community

FAQ: Zwave repair not working (how to fix error messages)

#81

I don’t think I recommended against the toolbox, I just said it was really expensive for a typical single home user.

0 Likes

(Tony) #82

Seems like you’ve eliminated the likelihood of range or connectivity issues given the distribution of repeaters in your mesh; that leaves environmental issues (some kind of radio interference or intermittent hardware problem) and the vagaries of the SmartThings cloud (as JD indicated maybe there is some architectural or cloud performance reason for problems in your network).
.
Given the fairly large number of devices (though less than half of the architected limit) I’d be curious as to whether or not there is a size effect that could be at play (SmartThings issue) or maybe an instance of bad hardware among one of the nodes. If your issues vanish with a smaller subset of devices this might point the finger away from environmental issues, leaving the cloud or perhaps a rogue randomly malfunctioning Z-Wave radio as the remaining suspects. Have you ever tried to temporarily pare down the size of the network to see if simply reducing the number of nodes has any effect on reliability? Deactivate some number of (hopefully non-essential) wall mounted switches by pulling their air gaps, run repair and see what happens.

This might be inconvenient to do if your typical problems have a long interval between recurrences, but if you can make the issues go away by doing this you might be able to then determine if the problem is related to a malfunctioning device (unlikely but not impossible to have more than one flaky radio) or some kind of ST implementation quirk that manifests in larger networks. If you can’t find any subset of devices that work reliably together, maybe there is some external interference at the root of your problems.

2 Likes

(Alex) #83

@Burd - I have not tried to pair down the network size but it may become necessary given the recurring issues.

A few days ago, my light between the master bedroom and kitchen stopped responding and the only fix was to exclude and include it back. Then yesterday I noticed my can light above the kitchen sink was no longer following the kitchen lights (there is a webcore piston that sets the kitchen sink light to whatever the kitchen lights do). The kitchen sink light is controlled by a Fibaro Dimmer 2 inside the metal can. Regardless of the fact the dimmer was essentially shielded by the can, the dimmer has worked perfectly for 1 or 2 years… All of a sudden it is no longer responding so I was forced to exclude and include it back. Today my kitchen lights stopped responding… and I am quite sure an exclude and include will revive them but this is getting incredibly annoying.

One thing I did one or two weeks ago was to flip all my switches that were not on Zwave Switch/Dimmer DTH to the equivalent DTH marked “Generic”. I believe I had read that the “Generic” DTH was the most recent. Regardless, this generally either works or doesn’t right away so I am not sure it is connected with these devices dropping dead randomly. Most of the devices having issues are all in the kitchen area which is central to the ground floor and also where we spend most of our time.

One other thing I have done, which I am starting to see as a very likely culprit… is running network repair a few times trying to weed out the issues and to let the Fibaro dimmer settle back in his ‘tin’ home (I had to include it right next to the hub for it to work properly).

0 Likes

(Michael Deffendall) #84

Well, I just had an issue with my Zwave network. I have a GE switch that controls my florescent lights in my kitchen. They would not turn off and zwave repair would not update route and mesh would not build. Rebooting hub didn’t fix it either
I ended up throwing the breaker for the kitchen and everything rebuilt after that.

0 Likes

#85

GE switches have had this problem for years. Many reports in many different home automation forums, not just SmartThings. The switch will stop responding to the zwave network, and the only way to fix it is to cut the power at the breaker (not just at the switch).

4 Likes

GE ZWave Switch connectivity issues
(Augustin) #86

Same here… but for me was the first time. This happened after lat Hub Update

Last time after leaving (Armed-Away) my house at 12:55pm, 7 GE stopped working.
rebooting the hub fixed the problem.

0 Likes

#87

If rebooting the hub fixes the problem, then it’s a different kind of problem. That does sometimes happen after a firmware update on the hub itself. I’m glad it worked for you. :sunglasses:

4 Likes

#88

@aruffell Did you come up with any solutions or tips? I am having similar issues with probably a similar setup as yours.

0 Likes

#89

I have a removed a lot of phantom devices that used to show up in repairs. But outside of repairs there are still lines like below that show up in the event list. These are device numbers that are not in my device list.

zw device: A2, command: 2003, payload: 00

zw device: 67, command: 5150, payload: 04 50 00 15 00 55 40 05

zw device: 7C, command: 3105, payload: 03 0A 26 79

0 Likes

(Alex) #90

My network “calmed down” and things seem to be stable. Given when issues start they typically affect an entire area of the house, I suspect that some device in that area starts causing trouble by malfunctioning and possibly messing with the message relaying to the hub from other devices. This is just a guess but it would explain why an area of the house seems to have an issue with devices dropping dead.

One likely cause I have noticed more than once are quick blackouts (or possibly brownouts) which seem to leave some devices in a locked up state. I also had devices have issues with noise or ESD on the line locking up (even though the zwave portion was still responding the switch would not operate). In most of these cases you can restore normal operation by throwing the breaker but that is a workaround not a solution.

At some point I might spring for the $250 Zwave ToolBox from Zwave Products as it is supposed to help find the cause of these types of issues. Right now, each time I am about to hit buy, my system start behaving normally again… probably because something I do (cut/restore power, exclude/include, etc eventually gets to the device that was causing the issues)

I have just received a beta firmware update (21.8?) to my hub that includes stability improvements to the zwave radio so hopefully some of my issues are addressed by this update. Only time will tell…

0 Likes

#91

With this many zwave devices in the house, I might have to go ahead and buy the toolbox. We haven’t moved in yet, but if these problems persist when we are living in the house it is going to drive me crazy.

Is there a process to get approved to be a beta tester?

0 Likes

(Alex) #92

@js1 Sign up using the link in the first post here:

1 Like

(Alex) #93

I’ve noticed this as well. I am trying to copy & paste the list of devices in Excel so that I can refer back to old exports to see what a particular ID was assigned to and then see if that device dropped off and is now showing up as a ghost but IDs can be recycled so it can get tricky if you do not export frequently.

0 Likes

#94

Seems like I created a crisis. I bought the Homeseer zwave stick and zflash tool to upgrade some of my homeseer switches to newer firmwares like others here have done.

I tried adding the stick many times to smartthings and the most devices I have been able to get it to sync is 18 out of about 140. I updated some of the switches and they run fine.

But now my repairs are finishing in less than 5 minutes, compared to 30min-60min before. It seems like it is only repairing those 18 devices, it is not seeing the rest. All my devices are working, and working well, but I am not able to add new ones.

Not sure what to do, I tried to exclude the stick, which worked. But it didn’t fix my repair or device addition issues. Anyone run into a similar issue? It would be such a huge mess to start over right now.

0 Likes

(MacTechGenius) #95

My Z-Wave repair states “Z-Wave Device Setup Started” any idea why?

0 Likes

(Diogi) #96

Worked great, thank you.

0 Likes

(Robin) #97

I had a couple of orphaned devices showing up in lists when selecting devices within smartapps.

They were created automatically by ST when I added a multi-channel device (Fibaro Double Relay), they were children of that device (endpoint 1 / endpoint 2), something I had never experienced before (or since) with a ST default handler .

I deleted them at the time using the app, and they no longer showed in the IDE or the app, but were still on the list when configuring smartapps.

They also did not show up during z-wave repairs so I was never able to get the device ID’s to follow @ahndee’s method.

I’ve finally managed to delete them by:

  • Adding them to webCoRE
  • Creating a piston with them
  • Going to the ‘installed smartapps’ page of the IDE
  • Clicking on the relevant piston to view the details
  • I could then finally get a link to each device in the IDE, allowing me to delete them.
0 Likes