FAQ: Too much Osram Lightify (bulbs lose messages from other zigbee devices)

osram

(Brian) #1

I have 9 Osram Lightify Zigbee bulbs, Most are color. As it turns out the need for them to try to repeat the zingbee signal is cause them to lose connection make motion sensors not work right and turn on and off the bulbs randomly. I have a carp load of these things and not really anymore zingbee devices. So I have constant problems with my whole setup. It is not a small deployment. I have been using ST From the very beginning. So I really need this to work. To ditch the whole system is not an option. To ditch the Bulbs is not the greatest either because I do not have the cash to go out and buy Hue. So now what? Does anyone know a way to fix these crazy things. I have seen people use the Philips hue hub, the Wemo link hub, and the Osram hub. The hue works kind as does the Wemo( wemo doesnt change color?) and the Osram hub but as I understand it the Osram hub does not talk directly with ST. There seems to be no real option here. Has anyone come up with a way to fix or work around this issue without having to reset them up every couple of days? Or did I just throw the cash down the drain.

On the complaint side. I know compatible does always mean works well, But I do not believe it means breaks all the other stuff.


RGBW smart bulbs in Europe (without bridge)
#2

The workaround for the lost messages is to get your sensors to use other devices as repeaters.

So assuming that you do have other zigbee repeaters, like pocketsockets or zigbee light switches, you going to have to go through a one time reset which will be tedious, but you should only have to do it once.

Start by taking all of the Osram bulbs off power. Unscrew them if you have to. Don’t just turn them off through the app, you need them to actually be unavailable to the network.

Now unplug your smartthings hub and remove the batteries if any. Leave all your other zigbee devices except the Osram bulbs on power. Leave the hub off power for at least 15 minutes. This will cause your other zigbee devices to go into “panic mode” because they can’t find the hub.

Now put the hub back on power, but leave all the Osram bulbs still unscrewed.

At this point, your other zigbee devices will do what is called a “network heal” automatically – – each one will rebuild its own neighbor tables, choosing a new parent based on what is currently available. One of the factors is signal strength, so since the bulbs are totally unavailable, they will not be chosen as a parent by your sensors.

Unfortunately, this whole process can take some time, so you really need to wait until the next day to screw all the bulbs back in.

Once you have the bulbs back on power, The bulbs will still repeat for each other (which they tend to do pretty well), but your other devices will not try to use the bulbs as repeaters.

So that will take care of one kind of problem.

If the Sylvania bulbs themselves are dropping offline a lot, then I think you need to update the firmware. And right now I believe the only way to do that is to buy the Sylvania Lightify gateWay, move the bulbs over to it, wait for the firmware to update, and then move the bulbs back to SmartThings. If they’ll update when connected to the SmartThings hub, hopefully someone else will mention that, but the last time I checked they didn’t.

Both of these are obviously very annoying tedious projects, but you shouldn’t have to do them often and they can help clean up quite a few problems.


#3

One thing to add to what @JDRoberts has stated, if you have to perform another power off in the future for your hub and remove the batteries (if you put batteries in) and wait approximately 30 minutes before powering back on, or possibly have a power outage for more than 30 minutes (no battery backup), when your hub boots back up it’s going to perform another Zigbee heal, but this time, it will include all of the bulbs that you previously had left unscrewed the first time you performed this power down / boot up process and may reintroduce the same issue you are experiencing now with motion sensors using them as a repeater, if that’s indeed what is happening. Perform the steps provided first and see if that resolves your overall issue, and if that fixes things, remember this 2nd post in the future should your environment ever experience downtime or you have to perform the power / boot process for any other reason.


#4

As an alternative and to avoid any future complications, instead of ditching your bulbs, you could start another topic basically putting those bulbs all up for sale at a discount or some sort of barter or best offer. There are people with different needs out here and if you could recoup some of the money spent on those bulbs, that might justify being able to jump on the Hue bandwagon. If you go this route, you want to purchase the Hue Bridge as well so that all the Hue bulbs form their own internal Network and will not act as a repeater for any of your other Zigbee devices in SmartThings. Besides the reliability and stability of the bulbs, you won’t see many, if any, complaints (outside of cost - you get what you pay for with these) from people using Hue with the Bridge. Just an additional thought to weigh out. :grinning:


(Anthony Genovese) #5

Smartthings updates Lightify firmware, but you have to have that ZigBee firmware update option turned on in the IDE.


#6

Gonna give this a shot, Thanks JDRoberts. These osram lights have sucked big time.

Have you heard any news in regards to connecting the US version of Osram lights to the hue bridge? I’ve been searching around and it looks like Osram doesn’t want to hand out firmware updates to ZLL and advised people to wait for Zigbee 3.0 but there’s been no updates or timelines.

Preferably it’d be nice to just put the Osram bulbs on the same zigbee network as the hues…


#7

Osram hasn’t given a timeline, but Phillips has said that they intend to have an upgrade for the hue bridge that will handle zigbee 3.0 devices early this year. Not sure what that will mean for the Osrams, though.

https://developers.meethue.com/zigbee3


(PPO16) #8

Just curious: how to know the latest version #?
I have:
Current Version: 0x01020492
Target Version: 0x01020492
supposedly checked today.

Thanks


(PPO16) #9

I am seeing something strange on my mesh: I have 2 bulbs, one HUE that never switch on without reason and one OSRAM that worked for a year and recently started to have unexpected switch on. It got solved after the previous HUB update and then came back since 19.20 or at least since the hub got reset or flashed with 19:20.

What I understood from the previous logs and DTH instrumenting is that the bulb gets on after a ZigBee rejoin and I’ve been told in this forum that the link quality could be the source. But in fact, what I see using XCTU is that there is no reporting at all from the Sylvania bulb (red frames): they only show the signal quality the bulb sees, but not what the distant receives from the bulb. If so, no wonder there are constant rejoin, no?

Comparing to the HUE bulb, I can see the signal quality is reported properly in both directions (green frames on the picture)

Any ZigBee RF folks could confirm that?


FAQ: Mapping your ZigBee network with Digi's XCTU
(Brian) #11

I gave up and bought Hue. I have replaced all the Osram lights. I have not thrown them away as of yet. It seems like such a shame to chuck them. But even with the hub there is no way to integrate into SmartThings. I have tried everything online to get them to work with the Hue Hub. But no luck.


#12

Is your Hue “Bridge” plugged into the same router as your SmartThings Hub?

Disregard - You meant the Osram bulbs thru the Hue Bridge.


#13

@JDRoberts still no luck on my lights and it’s driving me nuts… Trying to find another solution before just spending a bunch of money on replacing them all with Philips Hue Recessed lights that have recently come out.

Would having an additional Smartthings hub that connect to just the Osram lights fix the buffer flow issue if all of my other zigbee/zwave devices stay on the 1st Smartthings hub?

Not sure if this would cause zigbee interference or if it would segregate them off so that I could avoid the issue. Then I would run into the issue of trying to have the motion sensors on hub 1 trigger lights to turn-on on hub 2…

Do you have any suggestions?

Thanks!