FAQ: Did we lose the ability to add custom smartapps after the app update of June 2021?

The error is what I now get (as of the last 15 minutes) when I click it. Previously the Add SmartApp window would just close. Getting closer…

Ok, that means there’s something wrong with it:

  1. There’s a connection problem, it might be because the endpoint is down or the URL is wrong.
  2. There’s an error in your SmartApp, do you receive the requests from SmartThings?
    You should have verified the SmartApp before trying to install it, the following message should not appear:
    image

The app is receiving events from ST as we speak…

The error message above pops up instantly when I click on it.

From the live logging…

Nothing shows in live logging when I click on it in Add SmartApp even though I get the error message. I don’t see it failing trying to talk to my app.

I see, ok, so this SmartApp was previously installed, right?

There are some inconsistencies with the SmartApps in the iOS devices, what you can do is:

  1. Try to open the SmartApp using an Android device (if it still fails, please send an email to build@smartthings.com with your SmartApp definition)
  2. Register the SmartApp as a SmartApp Connector, to do so, go to:

New Project > Device Integration > ST Cloud Connection > SmartApp Connector

You would have to install the SmartApp from add(+) > Device.

  1. You can delete the installed instance of the SmartApp using this endpoint of the API.

Looks like the latest SmartThings iOS update has fixed the issue.

I have the latest iOS update and it’s still not entirely working for me, but it does look like somebody is working on something. Or maybe it was something I did while trying to figure it out.

My app still isn’t listed under the installed SmartApps, but if I Add SmartApp, I now see my app listed twice (but only on my iPhone, not my iPad). One gives the same error the instant I click on it, but the other opens up the configuration page and lets me successfully save changes. However, it still doesn’t show in the installed SmartApps list after saving.

Hopefully someone is actively working on it and will have it fixed soon.

@nayelyz - Unfortunately I don’t have an android device, but I will try to borrow one this weekend.

Yes, our engineering team is working on that.

No problem, as you can use one of the SmartApp instances, there’s no need for an Android device.

1 Like

Perfect! I appreciate your help!

Please let me know if you need me to try anything.

2 Likes

It’s been almost a month, so I thought I would follow-up. I still don’t see my installed SmartApp displayed within the SmartThings iOS app.

Is this something that is still being worked on? Do you need me to try anything?

Thanks!

Any idea where the Add Smart App went in the new App? I just have Add scene and Add routine. I have developer mode activated. I’m on Android

3 Likes

thank you very much

1 Like

Sorry, don’t want to dig up an old thread, but I enabled developer mode, I can see it in settings, but I don’t have any way to add a SmartApp… I have gone through Automations > + > Add Routine but there is no “Add a SmartApp”. What am I missing? Is this feature gone for real now?

There’s an option at the bottom called “Discovery”. When you enter there, you need to scroll up the page to see the custom SmartApps.

Add Routine, and select Discover tab

1 Like

Where are these apps?

I’ve finally found this thread, activated the developer account settings and found the Discover tab for Automations in the Smartthings app.

I have a published my app, everything else seems to be fine.

1 Like

FINALLY, searched the forum for a whole week every day and asked samsung support twice. Thank you!

1 Like

@jkp THANK YOU VERY VERY MUCH FOR THIS FIX!!
Exactly solved my issue with Smartapps not populating (Verisure, garage control etc).

Thanks!!!