Failed to configure Logitech Harmony Connect app

I cannot add my Logitech Harmony Smart Hub to my ST system. I have configured ST within the Harmony App, and I have authorized the Harmony App from the ST webpage as requested. I also have the latest firmware on the Harmony Hub. ST shows up as a device within the Harmony app, and I have verified that I can control all the connected things from the Harmony app.

However, when I try to configure the Connect app on my phone within ST, it finds the Harmony hub, but after selecting the switches etc that are allowed, I get a red error message at the top: “Failed to save page: deviceAuthorization”, followed by another message “Error: an unexpected error occurred.” It never fully installs and isn’t visible in my Things.

Any advice?

Sore subject:

Please go to Logitech’s forum…And give them hell…we have been doing this forever now… Output: 0.

Hmm. I added a post to the Logitech forum discussion. That’s frustrating. I’m not having any luck with ST “Connect” apps. I guess this one isn’t ST’s fault, but the Hue Connect App problem is really tedious and I wish ST would hurry up and fix it.

Please search the forums before posting. This has been talked about in a few threads already, one of which was mentioned above.

I looked at the ST FAQ, then went to the forums and first searched “Logitech Harmony” and then a second search for the specific error message. I did not see anything that was clearly related. The other thread is labeled very generically “Harmony Home Control” and starts out on a very different topic. It does not get to the issue in my question for a while, which I now see, but is a bit hard to find when you don’t already know it’s there.

If there’s a recurring/persistent issue like this, then I respectfully suggest that it get included in the FAQ, since that’s what it is.

any fix for this already?

Any fix yet ?

Nothing more annoying than spending £300 ($460) on a Logitech Ultimate Harmony Home to integrate with SmartThings and it works on the Logitech side of things but not on the SmartThings side . . . Proper let down . . . Both SmartThings & Logitech are industry leaders, surely after 6+ months of complaints from over 50+ users you guys would have made progress on this ? surely its just a case of a nice phone call to them saying " look, lets set a day aside to sort it out, we are both pissing users off here " . . .

1 Like

We’re currently testing a cloud-to-cloud integration, and hope to release real soon. Just finishing testing.


Any updates in this topic?

Any update on this? Please let us know.

Hello!!! Is there an update?

Is there an update to this? A release plan or timeline would help with planning since this break in communication between APIs has been a real pain, essentially rendering ST useless for me… Thanks

I just got my SmartThings and Harmony Hub last week. I almost have the whole system dialed in except for this piece. The reason I even bought the Harmony Hub and SmartThings Hub was for the integration. I would really like to launch Harmony Activities from Hello, Home scenes, which I see is available but I can’t get past this same error.

I sure hope this gets resolved soon. I can’t believe how old this post is and still no resolve.

EDIT: I just submitted a support incident with Logitech. I would recommend that everyone else having this issue do the same.

Any update on this? I am trying to connect my Amazon Echo to SmartThings and control my Logitech Harmony activities with Alexa. This way I can tell Alexa how to control everything in my media room.
PS. I already have the Echo to SmartThings hub part working, but still waiting on the fix to let SmartThings control Harmony activities.

Finally Harmony is back to work now! Ive succesfully set up the hub on smartthings but anyone know why im not able to addsmartthings to myharmony devices? If i try to add a new home automation device it show only insteon hub.

Already tryed to contact logitech support but still waiting for a reply… Its like trying to talk with asus…

Hi ilfakkino,
Yes finally harmony is back to work, and to connect harmony with smart things you have to add new device and search for brand: samsung and device: smarthings hub and add it as you are adding a new TV and follow the screen instruction.
I did it yesterday and it’s working very well and i’m controlling smartthings switches from harmony remote now.

I can’t seem to add harmony hub in Smartthings as of tonight? Device is available to pick (logitech harmony home hub), but when I ‘setup now’ it fails with an error.

Try adding SmartTHings to your Harmony setup in the Harmony app. That worked for me months ago for certain functionality (controlling lights with the remote, and stuff), but I could never get the full integration to work (where Activities show up in Smart Things as switches), but eventually it just started working. Good luck!

Turns out I had an old harmony hub in a funky state. It didn’t show up in the Harmony IOS app since it was long gone, but was still attached to my account from the myharmony PC app. Deleteing the device from the PC app, and then removing the Smarthing Harmony integration and reinstalling it fixed the issue.