Factory Reset Smartthings Hub v2 bring back Zwave?

My ST Hub V2 was updated and I also bought a ST Station. When I added the ST Station, it was added to the ST hub v2 as a device. Also none of my zwave devices work any longer.

When I look at the ST Web Interface, I see only 1 hub (ST Station) but I see 2 devices (ST Station and ST Station Charger). I no longer have my original hub but when I add a device it does not appear under the ST Station hub unless it’s compatible like my Sonos. If I technically only have the ST Station hub why aren’t all my working devices appearing there?

Anybody know if I factory reset my ST hub v2 if I will regain my zwave functionality again and then can I add the ST Station as another hub? I’ve seen in a lot of youtube videos when people are having to choose a hub but it only shows SmartThings and Aeotec Hub.

Help! Over time, I’ve replaced ALL of switches, dimmers, sockets with zwave devices and now nothing works. Living in a 3 floor home, I never realized how much I relied on all my automations now that I have to constantly walk up and down when I forget to turn off a light etc… :frowning:

I would recommend to NOT RESET your V2 hub at this point. Contact ST support first.

Any other details you can think of that may help us:

  • what steps did you take when adding the new Station to your account?
  • you didn’t choose Replace Hub at any point?
  • by Web interface… do you mean https://my.smartthings.com/advanced?

Are you absolutely sure you are using the same SmartThings account that you used in the past? If not, and you used a different email address in the app, then this would create a new location with a new SmartThings account containing just the Station. Consequently, you would no longer see any of your devices or your V2 hub!


Thanks for the quick reply. For the ST Station, I just followed the instructions which was just plug the ST Station in and open up the ST App where I had a popup to add the ST Station. I scanned the QR code when instructed and that was it. After that, it ‘appears’ like I have the old ST Hub still but there isn’t even the zwave exclusion utilities anymore.

I didn’t have the option to Replace Hub. I don’t believe that the ST Hub V2 supports it.

Yes, I looked at both the simple web interface and the advanced. Interestingly I run an app called ‘fing’ that gives me all the devices on my network and I do see 1 for SmartThings and 1 for SmartThings Station.

Yes, I’m sure I used the same account and to confirm that I do still see some of the devices and automations that I had in the V2 hub like my Nest, Hue bulbs, etc…

Reach out to ST support. They may be available today.

1 Like

Thanks. I’m on the East coast so I’m going to give them a few hours in case their support is in Palo Alto CA.

I don’t know if power cycling the V2 hub will have any effect but you can try. Remove the batteries if using them. Only issue is… I don’t know if it wipes out any logs that Support may need to look at so it is a choice you can make… power cycle or wait until you get in touch with Support.

There is also the soft reset option… it only resets the network settings on the hub but we can provide you with details on how to perform after you speak with ST support if needed.

Definitely don’t perform a hard reset which will wipe out everything which means you would need to start from scratch by adding all your devices back and recreating your Routines/Scenes. The hard reset may not resolve the issue at hand.

1 Like

Yeah, I get that. Hard reset was going to be my hail mary pass to get my devices working. :slight_smile:

Here is what the device looks like on my phone. When I click into the ST Station device, the only 2 things that show up is my Hue Hub and my Sonos but all my other devices do show up when I’m not in that device. Also interesting is that in the ST Advanced Web app, only the ST Station appears under Hubs but under Devices I also see a device for the ST Station and for the ST Station Charger.

It is strange how they appear in your Devices list (first image you posted for the Advanced Web app). The Station will appear in the ST app (your second image) so that one is OK. My initial thought is resetting the Station and removing it from your device list to see if that restores the V2 hub and all your devices.

When you open the Station in the ST app and tap on the 3 dots… what shows there? I am curious.

Note: I finally got around to connecting my Station yesterday. :slight_smile:


I do plan on replacing my zwave devices eventually. At the time, I thought that zwave was the best option. I am just waiting for some affordable Thread over Matter devices. I know that Eve just came out with one but I’m really waiting for Inovelli White Series. :nerd_face:

There are a few menu items. I’m assuming you want to see the Settings one but oddly, the only way that I have seen to actually add a new device once in that device is to click on the How to use menu item and once in there you have to click on Connect smart home devices and then Add device. There is also a Locate nearby devices option.


How to use:
Uploading: st3.jpg…

Finally was able to speak to Samsung ST Support and they are saying that I need to do a factory reset and then z-wave exclusion and then add all my devices, routings, etc… back again. I’ll update the post with my results. :frowning:

The results are in. SmartThings Customer Service told me to not unplug the power or ethernet but use a pin and press the reset button at the back of the hub. That did Factory reset the hub but didn’t not bring it back onto the network so it sat there switching from a solid green led to a blue led.

Finally, to get the ST Hub v2 back into SmartThings, I also had to unplug the power and the ethernet. Remove the batteries. Wait 30 seconds and then put it all back in reverse order. Once it powered on, I was able to open the SmartThings app and add the device.

Now the time consuming part but I’d prefer that then having to replace almost every light switch, relay module, electrical socket in my home. Fortunately as a software developer I knew to use the SmartThings API browser and copy all the configuration scripts for all the devices, automations, services, routines, configs and profiles.

Now I’ve been going around and excluding each device’s network id. I did a test with 2 dimmers adding them back and worked great. The only running around was to do the exclusion. the rest was all between the ST Advanced browser app and the ST API browser app.

I hope this helps others and prevents them from screaming and pulling their hair out. :joy:

1 Like