ESP8266 cannot be added in SmartThings-App -> "Device not supported"

Hi,

I’m relatively new to the SmartThings-SDK. :slightly_smiling_face:
However, I managed to built and flash the provided switch-example for the ESP8266.

After flashing the binaries on my ESP8266, it shows up in my SmartThings-App as a new device. Yeay! :smiley:
But if i try to add it to SmartThings-App, I receive a notification that the selected device is not supported. :frowning:

Does anyone has the same issue and can provide a solution?

I’m confused. You say it shows up in the app, but errors when you try to add it to the app. Which is it?

What integration are you using? What are you flashing onto your esp? Tasmota?

Thanks for the answer! :slight_smile:

No I’m not trying to flash Tasmota.
Im trying to use the SmartThings-Devide-SDK and flash the sample Script for a basic SmartThings-Switch, to control an ESP8266.

If I flash the binary I get by building the switch-example-script and start SmartThings on my phone, I receive a notification that a new device was found. However, if I click “Add device” in the dialog, the App starts to connect and fails after a few seconds with the message “The selected device is not supported.”

I did every step provided by the SmartThings-Documentation for a direct-connected-device.

My goal is, to switch on a relay which is controlled by the ESP using a Bixby-Command without having a SmartHub. This is why I need a direct-connected-device.

I hope this helps to understand, what I’m trying to do. :slight_smile:

Have you deployed all that is necessary in the ST cloud as well. There are many steps in that tutorial that have to be completed in the ST cloud to get the device to work.

Do youe mean all of these steps? -> Klick me

No, I mean all the steps on the other link you provided starting with step 4.

1 Like

Thanks!
The problem I ran into, was caused due to the fact I didn’t enabled the developer mode on my SmartThings-App! :smiley:

Now I can control the ESP8266 to the SmartThings-App. I just have to solve a Network- Servererror after I turn on/off the device.
It seems like the feedback from the ESP to the SmartThings-App doesn’t work correctly.

1 Like

I’d like to share this link