Can't add Logitech Harmony Hub to Smartthings app


I have a Samsung Smartthings Hub that I use mainly for my Ecobee thermostats and sensors and my lights.

I also have a Logitech Harmony Hub that I use for my AV system (TV, satellite, Netflix, Amazon Prime, AV receiver, Sonos, etc.).

I was able to add Smartthings to the Harmony app. Therefore, I can control the Smartthings devices with my Harmony app. However, this app isn’t as sophisticated as Smartthings and can’t add contextual elements. For instance, I can’t set an activity in Harmony to watch TV that would automatically shut down the lights, but only if it’s past 6pm for example.

Therefore, I would like to add my Logitech Harmony Hub to Smartthings. I tought it was possible because I found this webpage:

No mater what, I cannot find Logitech nor Harmony in Smartthings when I click the “+” to add a new device. Is it possible? Is it an older compatibility that doesn’t exist anymore?

The benefit of using Harmony is that if I click Netflix, the TV lauchs to the right input (Netflix), the AV receiver lauchs to the right input, etc. I don’t think (correct me if I’m wrong) that I can do that in Smartthings. Otherwise, how can I control so specifically my TV and AV receiver in Smartthings?

Thanks a lot in advance!

You can install the Logitech integration by installing the SmartThings Classic app. Then go to marketplace > SmartApps > more. Then the integration will be available in the new app :slight_smile:

Hi jkp,

Thanks for your help. I’ve just tried and the option seems to be not available.

I get the following message: “You can’t currently add this” when I click on “Logitech Harmony Trigger” in the SmartApps sections of Marketplace.

What am I doing wrong?


You are not doing anything wrong. What region are you in? Not sure if it is restricted in specific countries. You may want to contact ST support and let them assist. Sorry I was not able to help.

I’m in Canada

Looks like they removed the harmony integration in the new app back in December. Don’t know why. Hopefully ST support can provide you with more info.

You were mistakenly directed to a related community developed smartapp, which isn’t what you need. I believe they removed the Harmony integration from the new app but it’s still available in the classic app for many users. Not sure if it’s available for Canada or not. Try looking in Marketplace > Things > Remotes & Buttons > Logitech Harmony Home Hub

Smartthings IDE and create new SmartApp from template

I also can’t find the hub, the smartapp is available in the marketplace, however when i login (via email) and it starts discovery, it can’t find the hub (0 Found)

Any solutions for this?

@BazGee I created the SmartApp within the IDE from the Logitech Harmony (Connect) template, launched it from the new Smartthings app, and it immediately pops up with a “We’re having trouble connecting.” warning. I cannot figure out a way around this. Got any suggestions?


Just installed it and it worked fantastic. Found my “activities” and set them up on my Galaxy S20, Smarttings app and they worked with no issues at all. Thanks for publishing the IDE.

I am still having the issue.
Did you install it from template?

I installed the SmartApp from template and launched in the new app, and got the same connection errors noted above.

Solution: I hadn’t linked my Smartthings hub / account in the Harmony app.

[Menu → Harmony Setup → Add/Edit Devices → Devices → ADD DEVICE → HOME CONTROL → Smartthings]

Once I did that, I came back to the Smartthings app, and bingo the SmartApp now works.

Hi - I am trying to connect the Harmony IDE but it looks like Logitech have changed their system to a new combined SSO. I use a federated Gmail account to login but that button doesn’t work in the app (can’t open a pop up window) so I can’t login. Any ideas how I can fix this?

I had already set up Smarthings in Harmony. I did a refresh and re-login and no smart app shows up, so I am still stuck at the same point of being unable to login through the smart app in SmartThings as the Logitech ID page doesn’t work with the Gmail federated login in the app.

The problem seems to be related to logging into Logitech via Smartthings app, which doesn’t enable a pop up to open in a window to authorise the Gmail federated login. Any ideas if the code could be modified to address this issue?