Edge Shelly drivers for Gen1 and Gen2 Devices

What auto refresh frequency do you have configured in device Settings?

I have a Shelly 1 and have been using it with your driver since you published it over a year ago. I have no input connected to it.

I rarely open the device tile because it has worked great. Today I opened it because I was writing a routine and got a error message probably due to the input state being blank. See screen shot. Is there anyway to fix this?

It’s curious how that happened, since when the device was created that field is initialized.

There are a couple ways you could fix it:

  1. Use the CLI to issue a device command
  2. Use Postman or Curl to issue a device command through an API request

Or I could temporarily add a field reset into a driver update so it would be re-initialized when I pushed it out. Everyone would get the update, so if #1 or #2 are possible, that would be preferable.

I have the CLI installed, but have no idea what the command would be. I you tell me what the command would be it might be do able.

I went back and checked some old R1 test devices of mine and found one with the same problem, so I’ve gone ahead and fixed it with a driver update.

It should be fixed once your hub receives it: Version 2023-03-24T04:47:41.749886666

Glad you reported it; thank you!

1 Like

I forced an update, created a new device, and deleted the old one. The problem was resolved.

Thank you.

Your existing device would have also been fixed, so creating a new device wasn’t mandatory. It was actually always an option to create a new device but I was trying to fix your existing :smirk:. Just FYI in case anyone else has the same problem.

1 Like

Auto Refresh is configured for the shortest possible setting of 1 minute.

I know this driver update was for a separate issue than mine but I’ve confirmed my devices have this version and did some testing and they are now working as they did prior to the 3/18 driver update. Some devices update slower than others but that has always been the case. I’m guessing it has something to do with WiFi signal strength at the relay. I’ve been fairly disappointed in the reliability/connectivity of the relays.

1 Like

Very interesting!

So how does it work on Gen 2 Devices ?

(is Shelly Plus 1 a Gen 2?)

Hello Thank you very much for your reply and sorry for the delay in getting back to you, I couldn’t find the Shelly Device Driver V1.7 on your channel. I only located version 1.8b. Could it be under another name?

Thank you for your attention.

I even tried to install it with Driver Version 1.8b It finds the Shelly EM device, but when I select it, the consumption does not appear, everything is set to zero
Could it be something I’m doing wrong or does it need to be the driver with V1.7?

I’m waiting.

I just added Shelly EM to ST couple of days ago, by using driver Version 1.8b and it worked just fine, no issues. Did you try to hit “Refresh” or have you changed settings of “Auto Refresh” and “Refresh Frequency”…?

1.8b is now the most current version, so you have the right driver. The EM device should be working ok for you. Are you sure you have the right IP address configured on the device Settings screen? Are you able to turn the relay on and off from the device Controls screen?

As @Timppa71 suggested, try tapping the Refresh button when you know the device is on (by using the physical switch or the Shelly app if necessary).

@TAustin @Timppa71
Yes, through Shelly’s App the device is working normally, with a Fixed IP on the router. Connected to Wifi correctly and enabled shelly cloud. But when I add it to Smartthings it recognizes it and appears on the dashboard, but it doesn’t show the measurements correctly. While in Shelly’s App it is showing a consumption of 200kw in Smarthings it is 0kw.
I just hadn’t changed the “Update Frequency” yet. What value would be ideal to put in the update frequency? Automatic Update is enabled.
Thank you for your help.

It totally depends on how critical it is that you have the current value in SmartThings. I wouldn’t go any lower than 10 seconds ordinarily, but every 60 seconds is probably sufficient for most purposes.

You can also tap the Refresh button at any time to get the latest values.

If things aren’t working correctly, you’ll need to get the CLI and run some logs so I can see what might be happening. If you need some help with that, just direct message me and I’ll guide you through it.

Specifically, which add-on do you need?

Hi. Add.on with a Ds18b20 sensor connected. I need it to retrieve the exact same info displayed in the Shelly app,which is the actual temperature and the average at each hour. That specific part, the comunication at each hour, is keen for my automations.

A sábado, 1/04/2023, 23:02, TAustin via SmartThings Community <notifications@smartthings.discoursemail.com> escreveu:

If anyone besides @Bruno_Almeida has a Gen2 Plus 1, Plus 1PM, or Plus 2PM with an add-on, can you please do me a favor and enter this in your browser address bar?:


where <ip_address> is the IP address of your Shelly device.

Please direct message me with the results. Thank you!

1 Like

Hello, Sorry for the delay again in responding.
I would like to thank you for your attention as I managed to make it work. At least so far everything seems to be correct.
It was a configuration error on my part, but in the end everything worked out fine.
Thank you very much for your help time.