Can’t Get Shelly Uni to Work with TAustin Edge Driver

I’m impressed with your speedy response for this, and thank you for that. I reinstalled the Uni using the updated 1.6 driver, and am still not able to get any data from the Shelly device. The behavior of the new driver seems exactly as the old one. I am glad to help you any way I can to get this operational.
Thanks again for you good work.

I’m sorry you aren’t having any luck.

A couple questions:

  • Are any other Shelly Gen2 devices working for you with the driver?
  • You were able to get the Uni device discovered and added?
  • Is there anything unique about your LAN setup? Your SmartThings hub is on the same subnet as your Shelly devices?

Would you be able to download the SmartThings CLI so we could get some driver logs? If you have a windows computer on your LAN, the download link is here. There are others if you have Mac, Linux, etc.

If you’re able to do that, send me a direct message and I can guide you through the process once you get it installed. I’ll need you to capture logs from the driver so we could see what might be causing the issue.

I do have a Shelly gen 2 device installed and working already, (a Shelly 1 Plus).

I might not know how to get the uni discovered? I simply used the Device Creator to add the UNI device, then configured it in settings to the same IP address as the uni on my LAN, which is the same LAN as Smart things is on. The device then goes online, and Immediately Alexa says it has added the device to itself. If I select to Scan for new device in ST, nothing is found. I didn’t think scanning for new device in this case was needed.

I will work on getting CLI installed, and then DM you as requested.
Thanks again.

You should delete any device creator you may have for the GEN2/3 driver. That was something from an early version which is no longer used.

In this driver, devices are automatically discovered and created when you do an Add device / Scan for nearby devices.

So delete any device you had created manually and try that.


Thank you sooooo much! That was where my problem was. It seems to work like it is supposed to now.
I didn’t realize the change had occurred.


After some playing around with the Uni driver, the main switches are working, but that seems to be all that is. I can’t seem to get any data from the Uni input fields to display.

How do you have the inputs configured: buttons, percentages, counter? With this device I believe that input0 & input1 can be button or percentage, and input2 is a counter.

We may still need the CLI.

I don’t see how to configure the inputs. When I select settings, the only thing on the page is an able/disable toggle switch.

And when I provide an input to the uni, nothing displays on the device page.

Try the links above for information that might be helpful.

I have moved this troubleshooting conversation to its own thread to keep from cluttering the main topic.

With further experimenting with the Uni, I can now answer your question better. On the Uni, input 0 and 1 can be used with an active low applied to act like a push button. For example, internally through the Shelly app, I can configure the input 0 to energize relay 1 on the Uni when I ground input 0. I would like to have the input 0 in the Smartthings device be able to cause something to trigger in Smartthings, or otherwise be available for use in making automations. I can’t seem to get that to work. It seems the state of input 0 is not recognized by the driver. In setting up a trial automation in Smartthings, I selected to have input 0 turn on a switch, and tried the settings of “Pressed” and “Input State”. Then on the Shelly, I applied the ground to input 0, and neither of the 2 settings would produce activation of the test switch. The same applies when I select the other input 1, so it seems input states of the Uni are not getting through to the driver.

I have the CLI installed on my Windows machine as you said, but I am not experienced with using it to pull the logs you are needing. I am an electronic technician, not a software developer. I will assist you in any way I can to resolve this. The Uni is a very useful and capable device to have working with my Smartthings environment.

Gary Hunter

Here is a link to my latest log file for the Uni from my Smartthings web page.