Edge Driver needed for the Ring Alarm Contact Sensor Using the 'Z-Wave Plus Door/Window Sensor' DTH

@Drknght4 try to restart the hub

Just got home and it looks like it fixed itself. Not sure what happened but thank you for your prompt response man. Much appreciated

@milandjurovic71 - I’m using your driver for the ring door sensor and it identified the device correctly but in looking at the details via the web, I don’t see any route details like other z-wave devices. Should the Type field be changed from “placeholder” to z-wave plus door/window sensor? I’ve tried both ways and entered a device ID but I still don’t see any route info. Thanks

Don’t change Placeholder to anything else with Edge Drivers, you could mess them up.

Unfortunately you can’t see Z-Wave or ZigBee routes with Edge Drivers. The IDE doesn’t work with Edge Driver and will be phased out by the end of the year.

1 Like

thanks much @Paul_Oliver - I appreciate the guidance!


Thank you again for providing this edge driver for the Ring Alarm Z-Wave Sensors. I was wondering if it is possible to add in a “Settings” menu item that includes an option to change the “Retrigger Interval” (see screenshot) for the Ring Alarm Motion Sensor. This was a feature that was provide for the Motion Sensor in the Groovy Device Type Handler. This retrigger interval, AKA “Cool Down Period” has a default setting of 180 seconds. Previously, under the Groovy DTH, I changed this setting to 30 seconds which made the sensor much more responsive.

1 Like

Hello Milan, do you know if this driver will work with a Ring Gen 1 motion sensor? I installed it and it updates the “Tamper” status when I open the cover, but that’s all I’ve got? Is there something I’m missing?

We can try. Can you load Z-wave Device Config driver from Maraino, and provide fingerprints

They should look similar like this

Strange thing, I left for an hour and came back to it and it’s working. When I click on the device, I still receive the message, “This device hasn’t updated all of tits status information yet. Check again later”, but it’s definitely detecting motion now. Other than that, it appears to be working and detecting motion. I’ll give these other drivers a go, but I think we can safely say your driver appears to be working with a Gen 1 motion sensor. Thanks for the reply!

1 Like

Does anyone else have the problem of all these sensors always reporting 100% battery charge. I installed several of these in a vacation home and all of them show 100 % battery even after several months. One or two of them have gone offline and I suspect it is the batteries. Can the driver be updated to reflect the actual battery percentage ?

This is how device reports battery value. Maybe related to this is that my batteries lasted almost 2 years. Some of sensors reported 80% and 40%.
Maybe there is some other way of getting battery info.
This is stick driver with added fingerprints for R8ng devices.

Thanks for getting back with me. I am going to the house next week so i can check to see if the ones that are offline have dead batteries or if something else happened. I have some of these on a ring alarm system as well and they do report battery percentage. I was hoping that they would have a long battery life because I want to install them in a rental house and use them to control mini split AC’s if doors or windows are left open. Renters seem to do that a lot. I don’t have a problem replacing the batteries once a year or so but since the house is out of the country it is hard to get batteries replaced in a timely manner

1 Like

@b1haynes Do you have Ring motion sensor gen2? If you do, I have updated Settings for this device too. You need to swap driver for any other driver, and fo back to this one to show settings. I don’t have motion sensor in my possession and this was just guess work, but it should work.
I need someone to test it.
I’ll check if there is anything else reported related to batteries, like voltage.

Yes, i have the gen 2. Would there be a way to swap the driver remotely? Whenever I have tried to swap to another driver i just get the message. “Nothing found”

If you add Mariano’s Z-wave Device Config MC driver, you can swap it. His driver is used to get fingerprints, and to change parameters.
Then you can swap drivers remotely

Does this remove the device from the routines olit is used in?

Ok, I was able to change two of my sensors remotely and they now have a settings tab. Oddly enough one of the sensors that had been offline for weeks for some reason came back online by itself . I updated it as well . It is still showing 100 % battery though. I sincerely hope that they really are 100%. When I go to this location I will install some batteries that I know are low and see if they reflect a lower percentage. Thanks for the help

1 Like

It should not. There was issue with routines couple months ago, but I think it’s fixed. All my routines are still there on sensors’ routine page after swapping drivers

It just did for me. I tried on something with small number of routines to minimize potential damage.

I’m using @milandjurovic71 tweaked driver and it’s been rock solid ever since I installed it. Had a little issue but like @milandjurovic71 said, it was routine issue on ST end. I have other ring sensors that I use with my Ring alarm and the battery is still at 100% for 4 years now.

1 Like