Hub does not support edge drivers?

I have been using this hub for quite a while “to support edge drivers”.
Now, when installing another, I get this

Error: Request failed with status code 400: {“requestId”:“xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx”,“error”:{“code”:“BadRequestError”,“message”:“Hub (bedroom:SmartThings Hub) does not support edge drivers”,“details”:}}

smartthings edge:drivers:installed shows that one of my other drivers is installed and it appears to be working just fine.
So, obviously, my Hub does support edge drivers.

What is going on?

Same here. Been installing fine this morning. Just hit it within the last couple minutes. Sounds like a ST platform issue with their deployment scripts.

1 Like

Tagging @nayelyz

1 Like

Hi, @rossetyler, @blueyetisoftware
Which Hub model are you using? I was able to install a driver successfully.
Could you share the requestId, please?
I’m already checking with the team if they know of something that could be causing this issue as others have reported it as well…

Error: Request failed with status code 400: {"requestId":"AFF8C6FC-3A00-4F78-AA
    34-D666060CEF05","error":{"code":"BadRequestError","message":"Hub (SmartThings)
     does not support edge drivers","details":[]}}

This one is from an Aeotec Hub (V3 Equivalent)

1 Like

@rossetyler, @blueyetisoftware
Please try to install the driver again, it should be successful now


It succeeded. Thanks for the quick turnaround. What was the issue for future reference?

1 Like

The team found an issue on the SmartThings end and corrected the problem.
If something similar happens, please, create a post and tag me and I will contact the team directly.


Hey @nayelyz i have the same issue here, trying to reinstall a Mariano Driver: Zigbee Valve MC which was already ok, i uninstalled and now cant install any driver:


@nayelyz can you help with that please?

Sorry for the delay, @Coelhorj.
Have you tried the following?

  • Check if the driver was completely uninstalled in the ST app by following these steps:
    1. Open the ST app and locate your Hub
    2. Enter your Hub’s details and tap on Menu (three-dot symbol in the upper-right corner)
    3. Select “Driver” and verify those drivers don’t appear in the list
  • Clear the browser’s cache
  • Install the driver using the SmartThings CLI

Does it happen for all the channel invitations or only the one from Mariano that you were previously using?

Hey @nayelyz
Thanks for fast response! :wink:
1/2/3 Steps, all right. The driver is not at the list.
Cleared cache at android smartphone and windows browserS; - Same error. All Channel invitations or even official samsung drivers:

Went on Github to CLI but i´m not very confident how operate it. Any guide or video with firts steps?


Here I shared some steps to start using it:

To install a driver that you published or that is part of an invitation, you can use the command below and follow the prompt:

smartthings edge:drivers:install

If you receive the same error, please send me the email account where you’re trying to install the drivers over DM.

1 Like

foud the problem!!!

too much drivers!

deleted some and… BINGO!

Thanks a lot!


Thank you for sharing the solution, I will create a report to provide more info about the error in the browser’s version


@nayelyz Could the installed driver limit be added to the Rate Limits and Guardrails documentation?

1 Like

I’m already checking with the team for more details about the limits regarding drivers (not only this one) to add that info in the docs.


Thank you. 50 on this one is a bit lower than I expected since there are nearly that many drivers in the ST beta channel.

Are there any plans to expose stats on system resources used by each driver? Or overall hub performance?


Let me check with the team and get back to you.


The team mentioned that there are no plans at this time but I opened a feature request to keep track of that.
Also, they suggested using the collectgarbage function to get a “rough” idea of the memory consumption.
For example:

-- This will print in the log the total memory in use by Lua in Kbytes