[Edge Driver] FortrezZ Water Meter (Updated 11/28/2023 see post #23)

This Edge driver is for FortrezZ’s water meter device. All the features from the Groovy DTH are now available with this driver. A huge thanks to @Mariano_Colmenarejo for all his invaluable help in making this possible. I learned a lot thanks to him! If you use this driver and run into any issues, please post what you run into.

This driver will not work with any of FortrezZ’s legacy Groovy code, and I do not believe they have any plans to update them for ST’s platform change.

The screenshots below show the data collected and calculated from the meter, and are pretty self explanatory. The “Water Sensor” capability when “wet” is when water is flowing, and “dry” when flow has stopped. This is super handy for when you want an automation to turn off a valve when there’s water flowing and nobody is home or your location mode is in something like “vacation”. This driver also supports the ability to reset meter values, which I highly recommend you do. If you use @Mariano_Colmenarejo’s virtual calendar driver you’ll be able to schedule a reset whenever you want (see screenshot for that below).

Here is the channel invitation:

Here are screenshots, including a multi value version of the main tile. Please note that the detailed view below has changed since this posting due to undocumented changes ST is making on their end that is out of my control. There is more content now for each label, but the “units” are missing. Once these changes settle down and “units” reappear, I will update this posts with new screenshots.





Is there a way to make it not send a leak notification every time water is used? It pops up every time water is used and is not necessary for my situation.


That capability (changing the leak sensor state to “wet”) allows you to get creative with automations, such as detecting water usage while being away or after hours, and that’s something that was provided by FortrezZ in their original DTH from years ago. There are no plans to stop changing that state since many flow meter users use that, but you can disable notifications yourself per device. Here’s how:

  • In the mobile app, tap on “Menu”
  • Tap on “Notifications”
  • Tap on the three horizontal dots on the right
  • Tap on “Notification settings”
  • Scroll down to your device
  • Tap on that device to disable notifications from that specific device

Hi John,
Drivers is working great. The only bug I am experiencing is that the driver is not respecting the High Flow Rate Threshold. If I set the High Flow rate to 60 gallons, I will get the notification as soon as I open the faucet, which should not be the case. I can suppress the notification, but I want my phone to go off I reach a high usage.


Hi @Anthmar , I’ve been traveling the last few days so my apologies for the delay.

I need some time to look at the code cause I can’t remember how those events should be handled.

@Anthmar Did you really mean 60 gallons for the high rate threshold? That’s a rate value instead of a gallon threshold.

The high flow rate threshold value is only used right now to update two things:

  1. Update the “Highest Meter Flow Rate” value in the mobile app when the previous high value is surpassed.
  2. Creates an event via logcat using the CLI. The event would read “alarmState: <<<< High Flow Detected! >>>>”.

I’ve not further developed the Edge driver to do anything with the highest flow rate. The only notification the driver provides is wet/dry based on when water is flowing so you can use the meter as a water leak sensor. That is why you are notified whenever you open the faucet. There are no notifications for flow rate, gallons last used, total gallons used, highest flow rate, or highest gallons used. Those capabilities are also not yet available for Routines. Only temperature, water sensor, power source, and battery capabilities are available.

@Anthmar ,

I looked over my code again because it’s been a while, but I will get back to adding those other capabilities so that they are available in automations.

I don’t understand the edge drivers or how to install them. How do I get my meter working on the new app?

Hi @RokitRod,

Here is a great FAQ tha you should definitely read:

The section titled “2. Using a custom edge driver” gives a step by step process. The next post by JDRoberts in that same FAQ. It’s titled “How to manually switch…:”.

While that post is a year old, it’s spot on. Basically you have two choices right now. One is to install the edge driver to your hub by clicking on the link in my first post, installing the edge driver on your hub, and then manually setting things back up, or still install the edge driver and wait for SmartThings to convert you.

1 Like

Just bought a FortrezZ water meter. Not quite sure where to get your Edge driver and how to load in my hub.
Thank you for all your help. The UI looks great!

Hi @ptremblay29 , there’s a link in my very first post in this discussion that takes you my drivers. After you click on it, log on to your account/hub when prompted, then click on Enroll. After you do that you will see the available drivers, and then just look for “My FortrezZ Water Meter” and click on Install.

Once you do that the driver will be installed on your hub. After that, join the FMI to SmartThings. I recommend performing the join process close to the hub and then moving it to where you have the meter. After joining, be sure to go into Settings and set your reporting rate threshold (I recommend “1”) and high flow rate threshold.

You also may want to turn off notifications for that device, otherwise you’ll be notified of a “wet” condition every time water is running since “leak sensor” capabilities are included in my driver. You can use the meter as a leak sensor when water is running in Routines, such as notifying you of water running when you’re away from your home and/or your home is in away mode.

Thank you for the prompt response John.
I looked for your first post but could not find it. May be I just missed it.
Can you send me the actual link?

I surely appreciate your help. I would love to use my meter to the full extend.

Thanks agin.

I was finally able to get to your driver page.
I installed the driver.
I joined the FMI close to my hub and it included fine.
I disabled the notifications.
Since the driver does not allow a routine with flow rate, I will use the wet sensor status to tell me if the water is simply running.
Did I get it right?

Thank you for all your help!!

1 Like

Yup, spot on! I plan on updating the driver to enable all capabilities to be used in automations. I’ve been pretty swamped with work and other activities, but I will eventually update this driver.

1 Like

Since I did Java scripts and VB back in the days, I might start writing as well.

Thanks again.

1 Like

Hi John, i just saved you edge drivers and i have to say thanks for all you hard work! I have both flow meters up and running for my solar hydronic system. It was working for a while and then went back to electric readings… i was ready to give up. Went back to my old post and found this and saved your drivers. Painlessly easy, uninstalled and reinstalled FMI`s and turned off moisture notifications. thanks again. Mark.

1 Like

John, thank u for making this driver. The flow rate is low by about 10x on one of my meters ( I have 3. Two 2" and a 3/4")). I need two versions of your driver, hard code a multiplier, or an option to select pipe size. The standard size is 3/4 (your driver works) and larger pipes/meters up to 2 inches. In the old driver, we modified line 258 *10 to correct the flow rate for large pipe sizes.

Hi @halprewitt,

Thanks for catching that, I had no idea FortrezZ had a separate DTH for large pipes. I should be able to add a setting that will allow the user to select the pipe size and then apply the appropriate multiplier.

We’re traveling at the moment, but I can get to this as soon as I return. I’ll post back here when the driver is updated.

Thank u. I think the Meter Size options should be Standard 3/4 and Large 2". Flow multiplier: No change to your code if standard and *10 for the 2".

Regards, hp

1 Like

For one driver option, I suggest that you create two inputs that will solve for all meters and provide a calibration factor for slight errors:

  1. Allow selection for x.01, x.1, x1 or x10. These are the counters where the pulses originate and are shown on the meter face. This provides for .1, 1, 10, or 100 gals per pulse. Below are links that identify the meters with their magnet-mounted counter options.

  2. Allow for a calibration factor to correct small errors. Limit input range ± .5 to 2 so not out of useful range. A no-error value would be 1. Higher or lower adjusts up/down. Gal x CF, where CF is a floating point number so if we had a rate of 100 gal per min, with a CF of 1.1 new rate would be 110 gal/min.

See the meter image and silver color magnet on the .1 dial meaning 1 pulse per gal and where the pulse is produced by a sensor.

Meters sizes & pulse options available:

For more info about water flow capture, Tom Lafleur, a friend built a board and assorted drivers for various applications. It has excessive flow detection, a max flow rate variable and a period of time, if exceeded, it triggers an event and resets the event if the flow rate drops below the max. These options also could be built within other codes for Smartthings.

Regards, hp