FortrezZ Water Flow Meter

From what we’re hearing in the community, that is correct.

@andresg can you confirm or provide a link to an FAQ about the transition for devices that have a community developed Edge driver and it being picked up when that happens?

1 Like

Hi, @johnconstantelo

Sorry for the late response. I am not sure if I fully understand your concer, but you don’t have to ‘manually’ change the driver if that is what you are asking for. You can just wait till the migration changes it for you.

I was just checking to see if someone installed a custom driver like mine that when the migration comes it will pick up that driver.

1 Like

Ah, I already understand your concern @johnconstantelo. If your device is already handled by an Edge Driver (custom or not, it doesn’t matter) then the migration won’t affect your device at all. Migration will only affect devices handled by DTHs.

Does anyone in this community have a link to the latest John Constantelo Edge Driver for the Fortrezz Flow Meter? (I have contacted John Constantelo, Smartthings Support (via Samsung Support), and EZLO (manufacturer of the Fortrezz FMI) but without any luck…no one seems to have the actual link that I need in order to install the updated edge driver.)

As I’ve PM’ed you already, this the only and current driver:

Thanks for sending the link. However, the link you sent below is a link to a community forum, not to the driver, and I searched the entire forum (which is quite large) and still cannot find the link to the driver itself. Would it be possible to send me the link to the driver itself, instead of a link to the forum where the link to the driver appears (but I am unable to locate)?

The link is in the very first post, right below where it says "Here is the channel invitation ".

That will take you to the channel to enroll, and then to select the driver to install. Based upon your PM and screenshots you included, you have already done this.

At this point I’m not sure exactly what issue you’re having. It looks like the driver is installed but the device is not using it?

Thanks John, everything now works perfectly!

I noticed several posts asking how to automate monitoring of excess water flow (e.g. a leak). I used SharpTools to write a script that measures total gallons used in the past 15 minutes and sends SMS if the amount exceeds a threshold (which I set to be lower between midnight and 6 am and higher during the day). You can easily change the time interval and threshold. SharpTools also integrates with most other Smartthings devices as well, making them much smarter. Here are two screenshots of the script I am using:

1 Like

This is great, thanks!

Hi John,

Now that I have SharpTools handling water flow notifications, I would really like to turn off the Smartthings “leak” notification that gets sent every time the water runs, but I cannot find a way to do this.
Attached screenshot shows the Water Meter notification is turned off, but that doesn’t seem to have any effect. I set the two values in “settings” to the max, but that also seems not to have any effect. Is there any thing else I can try?



PS: I’m not sure one really needs to wire in the wet notification into the Edge driver since anyone who wants this function can set it up as a ST routine:


You have the one place identified, but within the Home Monitor application where you set up smoke, security, and leak detection, did you have the Leak Detection set up to always include all leak detectors (default), if so, you need to remove the meter from there.

I had to write that capability into the driver so that it would be exposed for automations because it’s not there by default. The driver doesn’t do any notifications, it just creates the event so that you can use a routine/automation.

Thanks! That worked…no more notifications!

1 Like

My fortrezz flow meter seems to have come back to life reporting flow today (after months of updating temperature only). I had been meaning to do an exclusion and repairing as I think the Edge switchover process hadn’t happened correctly? Not sure if today’s new activity on the device is related to the recent hub firmware update that somehow improved the connection?

I’m getting the same leak notification of the fortrezz water sensor being wet every time water runs also.

But in Smartthings home monitor, I have not included that device with the rest of my leak sensors for monitoring (and my leak Sonos audio notifications do not play when the fortrezz sends the notification message, further suggesting that it’s not coming from the home monitor).

On the device settings page I see the 3 options that do not appear to address wetness notifications.

Any other ideas?

Also, is there an edge Device or setting that allows resetting the total number of gallons now?

Thanks especially to John for keeping this device relevant!

Hi @Natec

I’m not sure why it would just start working, but I would have to imagine that it’s related to getting the proper Edge driver assigned to the device.

Since you don’t have it in Home Monitor, the only place left to check will be under Notification Settings and to disable the device there. It can be found this way:

Menu (bottom right of the app) → Notifications → tap on the three vertical dots and then tap on Notification Settings → find your water meter and turn off notifications for it

My driver doesn’t expose the reset command in the mobile app (so someone doesn’t accidentally reset the meter), but there are now two ways to reset this meter. One is described above in my first post. The other and very handy solution is with the new web app ST just released. If you’ve not seen that yet, you absolutely need to start using it:

To send or control any device via the new advanced user app, go to Devices and find your meter. Scroll down until you see Commands. Click on “resetEnergyMeter” and it will be reset immediately.

Glad to hear that its’ working for you!

1 Like

Thanks for creating this driver. It appears that you updated it recently, in June or so.

I have SmartThings integrated with Home Assistant.

Your updated driver still works perfectly within SmartThings. And, it had been working perfectly in Home Assistant before the update, creating a sensor entity in Home Assistant for water flow named “FortrezZ Flow Meter Power Meter” (sensor.zz_water_flow_meter_power_meter).

However, now it no longer updates that value. It’s stuck at the same value and does not change as the flow change. If I install different edge drivers, I can get it to update to the current flow state at the time the driver is reinstalled; however, it fails to update further.

Any suggestions? Very much apperciated!

Hi @FortranFour ,

My new Edge driver for the flow meter now uses custom capabilities and doesn’t update attributes for either ST’s “powerMeter” or “energyMeter” capabilities. That’s why any data related to power or energy don’t get updated.

What other drivers have you tried? The only other one I know that could still work would be ST’s “zwave-electricity-meter” driver that may expose energy and power meter data coming from the meter.

I don’t use Home Assistant, nor am I familiar with how HA and ST are integrated. Should that integration be updated for the meter’s new capabilities?

Thanks, much appreciated. The ST driver “Z-Wave Electric Meter” reports cumulative consumption using the “Power meter,” with units of Watts, equivalent to gallons. The “Energy consumption” does not seem to update. While total usage is communicated to Home Assistant, rate of flow is not. (There is however a capability to take a derivative in Home Assistant and compute it.) I think that updating the overall Home Assistant Integration with SmartThings would prove challenging. Is there anyway that you could repost the older version of your driver, so that I can resume using it?