[Edge Driver] FortrezZ Water Meter (Updated 11/28/2023 see post #23)

Posting blocked more than 2 links. His WiFi version: https://github.com/trlafleur/Flow-Sensor-Tasmota

Hi @halprewitt, I’ll likely keep this as simple as possible since the original code is for FortrezZ’s FMI and how it was set up with their meter to work with ST. I also need to update available actions within the driver’s profile to expose a few more capabilities for routines/automations.

This driver has been updated on 11/28/2023:

  • Added a simple new preference in Settings to be able to select the size of the meter (standard or large) that sets the multiplier for flow rate. See images below.
  • Updated descriptions for all preferences in Settings. See images below.
  • Custom capabilities are now available for routines/automations. See images below.

Your driver should automatically update within 12/24 hours, or you can force the update by force stopping the app and clearing cache. When the app restarts, the updated driver should be running.

Screenshots of the updates:





FYI @halprewitt , @ptremblay29

Thank you

Pierre Tremblay

Description: P1010008

1 Like

HI @ptremblay29 , you may want to edit your post above to remove your personal info.

Thank u.
1 How to stop or or configure these devices from producing a “Leak Detected” alert and notices (in the app) when water is flowing? Tried turning off notices without success. Not using routines on these devices.
2. Reset of the flow data does not appear to be working.
3. Flow rates & gals used still appear to be incorrect. Using 10 sec threshold

Update on my last post.

  1. If flow (wet) the notice “leak detected” is coming from the service Home Monitor in Notifications. Switching Off stops that notice. When the Water Meter notice is On sends “Moisture detected”. Switching Off stops that notice.
  2. Reset of the data works on 2 of the 3 meters. Don’t know why fails on the 3rd one. Stills shows total & highest gallons used.
  3. I am retesting the flow rate on the 10x meter.

Thanks, hp

Update on my last post.
3. Device is using 10 sec threshold. Tested a water flow of about 1 gal per min for 6 mins. Flow reporting on the 10x meter is still incorrect. History shows about 1 min per log with some 1 min reports missing and some are delayed up to a min or more from the actual time. Flowrate does not always have a rate (shows 0) and other times is 6gpm (6x actual) while totalused is .1 gals per 1 min (off by 10x). Very odd.

History Log of the flow test (key details & every report)

Nov 30, 2023, 2:39 AM waterSensor water “dry”
Nov 30, 2023, 2:39 AM totalused “0.5”
Nov 30, 2023, 2:39 AM flowrate “0.0”
Nov 30, 2023, 2:39 AM flowrate “6.0”
Nov 30, 2023, 2:39 AM waterSensor water “wet”
Nov 30, 2023, 2:38 AM waterSensor water “dry”
Nov 30, 2023, 2:38 AM flowrate “0.0”
Nov 30, 2023, 2:38 AM totalused “0.4”
Nov 30, 2023, 2:38 AM flowrate “6.0”
Nov 30, 2023, 2:38 AM waterSensor water “wet”
Nov 30, 2023, 2:37 AM flowrate “0.0”
Nov 30, 2023, 2:37 AM totalused “0.3”
Nov 30, 2023, 2:37 AM waterSensor water “dry”
Nov 30, 2023, 2:37 AM waterSensor water “wet”
Nov 30, 2023, 2:37 AM temperatureMeasurement temperature “55.4”
Nov 30, 2023, 2:37 AM flowrate “6.0”
Nov 30, 2023, 2:35 AM waterSensor water “dry”
Nov 30, 2023, 2:35 AM flowrate “0.0”
Nov 30, 2023, 2:35 AM totalused “0.2”
Nov 30, 2023, 2:35 AM flowrate “6.0”
Nov 30, 2023, 2:35 AM waterSensor water “wet”
Nov 30, 2023, 2:34 AM highestused “0.1”
Nov 30, 2023, 2:34 AM waterSensor water “dry”
Nov 30, 2023, 2:34 AM flowrate “0.0”
Nov 30, 2023, 2:34 AM totalused “0.1”
Nov 30, 2023, 2:34 AM lastused “0.1”
Nov 30, 2023, 2:34 AM flowrate “6.0”
Nov 30, 2023, 2:34 AM waterSensor water “wet”
Nov 30, 2023, 2:34 AM highestrate “6.0”

John, have any idea why?

Regarding your leak notifications from Home Monitor, you can remove your meters from the Leaks section. The “wet” notifications can be suppressed by disabling the device’s notifications “Menu → Notifications → tap on three vertical dots → Notification settings”.

I don’t use/trust the history log in the app because it can sometimes not update fast enough, not have all the data needed. The most effective way to see what the meter is actually doing is to watch it live in the CLI using this command:

smartthings edge:drivers:logcat {driver ID} --hub-address={local IP address of your hub}

This will display a ton of info while water is running and it will be most helpful to see that info. In the meantime, I can look over my code to see if I missed anything. I used the same logic for the large meter that FortrezZ is using, but most of the other logic for total used, etc. was never part of their DTH.

First, thanks for creating the drivers and doing all this work.

I have had Fortrezz water meter and shutoff valves in my rental properties for a long time. These have saved me on multiple occasions, frozen burst pipes, broken toilets, etc.

The most important function that used to exist but isn’t found in your driver is the continuous flow detection. I used to be able to command the shutoff valve to turn water off to the building if water ever continously ran for 90 minutes (or whatever threshold I chose).

Is there a driver available for continuous flow detection?

Edit: The old continuous flow detection function would shut off the Fortrezz shutoff valve, send a push notification, and had the option to also send a text.

The wet/dry sensor notifications and other leak detection notifications could be turned off so that the continuous flow and water shutoff notification would be the only notification set from the smart water meter.


Hi @Gold_Standard_Proper , your use case is similar to mine, but I don’t have rentals. Last winter we had a burst copper pipe during one of the coldest days in the Carolinas while we were traveling, and this meter caught it immediately and shut off my valve. That was done via the leak sensor capability and a home mode of away.

What you want to do for continuous flow used to be done via FortrezZ’s legacy SmartApps. That can still be done now with the custom capabilities of my driver and an automation/routine. Here’s what that looks like:

Thanks for your help! I was able to get it to work. I have one last question.

Although I installed the driver on all of my hubs, for some reason one hub shows the driver as being installed but when I go into the app and try to select it, the driver isn’t available. I can see the driver installed on this hub in the my.smartthings.com → Hubs interface. I have tried uninstalling the driver from this hub both through your link and through my.smartthings.com → Hubs, and then reinstalling it. I tried remotely rebooting the hub and reinstalling it. Still won’t work. It’s odd that it worked for 10+ other hubs but not this one.

Any suggestions for getting this last hub to work?

1 Like

Glad that worked!

Try removing the driver and unenrolling the channel via the invitation link for that specific hub, and then reboot. Go through the enrollment process again and install the driver. It almost sounds like something didn’t complete during the initial enrollment process.

Thanks. I tried that a few times both before and after your suggestion. Still didn’t work for some reason. I will probably need to go to the location of that hub and see if there are any other reset options, power off/on, etc. It’s very strange that I can install the driver, see the driver in the list of all drivers, but doesn’t show up under “Select different driver”. I also can’t find any information online related to this type of issue.

Thanks again for your help. Do you accept donations?

Ah, wait! I bet i know why. I bet the model number is different and it’s not in my driver’s fingerprint.

Im mobile right now so give me a few and let me check on a couple things.

1 Like

Ok, let’s try and capture the device’s fingerprint using a driver available from this community. Based upon the information from you, it seems like your meter has a fingerprint that needs to be set up in my driver.

If you’re familiar with Mariano_Colmenarejo’s contributions to smartthings, his driver channel is here:

Would you mind enrolling and installing the Zwave Thing Mc driver?

Once installed, switch your meter to this and grab a screenshot of what information is available. I’m specifically looking for the fingerprint. Fortrezz’s original Groovy code uses fingerprints, but its not helpful. This generic driver can capture the info we need.

Here’s what mine looks like using that driver:

For some reason when I click the callaway.smartthings.com SmartThings Channel and Driver’s link above it tries to log in but gets hung up every time. I tried both on my phone and laptop with the same results.

Also, I’m fairly certain that I have the exact same hub at the location with the issue as I do at the other 10+ locations where your drivers are working. Let me know if it would be possible to discuss over the phone to try to resolve this. If not, no problem.


My driver shows installed but none of my app screens look like this. I just have battery and Water Sensor

Hi @Gold_Standard_Proper ,

Can you try this link for his drivers please?


Is there anything different about the meter at that location? The hub won’t matter, but if FortrezZ changed anything in the FMI zwave module to have a different mfg or model, that would be the issue, so that’s what that Zwave Thing driver will help us validate.

Hi @RokitRod , what does device look like in the app? When you mean just batter and water sensor, do the temperature and all the flow values show up but just have 0’s for the value?